summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2011-07-09 21:39:58 +0000
committerChristoph Mende <angelos@gentoo.org>2011-07-09 21:39:58 +0000
commit325b537f3dc282af7b590a8089d22127cf1efc0f (patch)
tree1129f9ece83e77b6be5d42cf2cd5864c45c48115 /media-gfx
parentVersion bump and remove unused patch (diff)
downloadgentoo-2-325b537f3dc282af7b590a8089d22127cf1efc0f.tar.gz
gentoo-2-325b537f3dc282af7b590a8089d22127cf1efc0f.tar.bz2
gentoo-2-325b537f3dc282af7b590a8089d22127cf1efc0f.zip
Fix compilation with current libraw (bug #374409, patch by Tim Harder)
(Portage version: 2.2.0_alpha43/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/shotwell/ChangeLog6
-rw-r--r--media-gfx/shotwell/files/shotwell-0.10.1-libraw-config.patch16
-rw-r--r--media-gfx/shotwell/shotwell-0.10.1.ebuild5
-rw-r--r--media-gfx/shotwell/shotwell-0.10.ebuild64
4 files changed, 24 insertions, 67 deletions
diff --git a/media-gfx/shotwell/ChangeLog b/media-gfx/shotwell/ChangeLog
index 48329d1b1940..890c60471aef 100644
--- a/media-gfx/shotwell/ChangeLog
+++ b/media-gfx/shotwell/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-gfx/shotwell
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/shotwell/ChangeLog,v 1.20 2011/06/23 10:39:13 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/shotwell/ChangeLog,v 1.21 2011/07/09 21:39:58 angelos Exp $
+
+ 09 Jul 2011; Christoph Mende <angelos@gentoo.org> -shotwell-0.10.ebuild,
+ shotwell-0.10.1.ebuild, +files/shotwell-0.10.1-libraw-config.patch:
+ Fix compilation with current libraw (bug #374409, patch by Tim Harder)
23 Jun 2011; Christoph Mende <angelos@gentoo.org> shotwell-0.10.1.ebuild:
Re-add accidentally removed GCONF_DEBUG
diff --git a/media-gfx/shotwell/files/shotwell-0.10.1-libraw-config.patch b/media-gfx/shotwell/files/shotwell-0.10.1-libraw-config.patch
new file mode 100644
index 000000000000..0c3ee96b85a5
--- /dev/null
+++ b/media-gfx/shotwell/files/shotwell-0.10.1-libraw-config.patch
@@ -0,0 +1,16 @@
+diff --git a/libraw-config b/libraw-config
+index 2ddfb6d..dc49ebf 100755
+--- a/libraw-config
++++ b/libraw-config
+@@ -59,9 +59,9 @@ libs() {
+
+ # TODO: Cannot check version of library if no .pc file installed.
+ exists() {
+- if pkg-config --silence-errors --exists 'libraw_r >= $3'; then
++ if pkg-config --silence-errors --exists "libraw_r >= $1"; then
+ :
+- elif pkg-config --silence-errors --exists 'libraw >= $3'; then
++ elif pkg-config --silence-errors --exists "libraw >= $1"; then
+ :
+ elif ! searchpath $LIB_DIRS "libraw_r.a" || ! searchpath $HEADER_DIRS "libraw/libraw.h"; then
+ printf "\nPackage libraw not found\n"
diff --git a/media-gfx/shotwell/shotwell-0.10.1.ebuild b/media-gfx/shotwell/shotwell-0.10.1.ebuild
index 8266cb0789ec..0df62d81c537 100644
--- a/media-gfx/shotwell/shotwell-0.10.1.ebuild
+++ b/media-gfx/shotwell/shotwell-0.10.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/shotwell/shotwell-0.10.1.ebuild,v 1.2 2011/06/23 10:39:13 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/shotwell/shotwell-0.10.1.ebuild,v 1.3 2011/07/09 21:39:58 angelos Exp $
EAPI=4
GCONF_DEBUG="no"
@@ -48,7 +48,8 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}"/0.10-ldflags.patch
+ epatch "${FILESDIR}"/0.10-ldflags.patch \
+ "${FILESDIR}"/${P}-libraw-config.patch
gnome2_src_prepare
sed -e 's/valac/valac-0.12/' -i plugins/Makefile.plugin.mk || die
diff --git a/media-gfx/shotwell/shotwell-0.10.ebuild b/media-gfx/shotwell/shotwell-0.10.ebuild
deleted file mode 100644
index 77d614906ae2..000000000000
--- a/media-gfx/shotwell/shotwell-0.10.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/shotwell/shotwell-0.10.ebuild,v 1.3 2011/06/10 09:09:20 angelos Exp $
-
-EAPI="2"
-GCONF_DEBUG="no"
-
-inherit gnome2 versionator eutils multilib toolchain-funcs
-
-MY_PV=$(get_version_component_range 1-2)
-DESCRIPTION="Open source photo manager for GNOME"
-HOMEPAGE="http://www.yorba.org/shotwell/"
-SRC_URI="http://www.yorba.org/download/${PN}/${MY_PV}/${P}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND=">=dev-db/sqlite-3.5.9:3
- >=dev-libs/dbus-glib-0.80
- >=dev-libs/json-glib-0.7.6
- >=dev-libs/libgee-0.5.0
- >=dev-libs/libunique-1:1
- >=dev-libs/libxml2-2.6.32:2
- >=gnome-base/gconf-2.22.0:2
- >=media-libs/gexiv2-0.2.0
- media-libs/gstreamer:0.10
- media-libs/lcms:2
- >=media-libs/libexif-0.6.16
- >=media-libs/libgphoto2-2.4.2
- >=media-libs/libraw-0.9.0
- >=net-libs/libsoup-2.26.0:2.4
- >=net-libs/webkit-gtk-1.1.5:2
- || ( >=sys-fs/udev-171[gudev] >=sys-fs/udev-145[extras] )
- >=x11-libs/gtk+-2.18.0:2"
-DEPEND="${RDEPEND}
- >=dev-lang/vala-0.11.7:0.12"
-
-DOCS="AUTHORS MAINTAINERS NEWS README THANKS"
-
-pkg_setup() {
- tc-export CC
- G2CONF="${G2CONF}
- --disable-schemas-install
- --disable-desktop-update
- --disable-icon-update
- --lib=$(get_libdir)"
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${PV}-ldflags.patch
- gnome2_src_prepare
-
- sed -e 's/valac/valac-0.12/' -i plugins/Makefile.plugin.mk || die
- sed -e 's/valac/valac-0.12/' -i Makefile || die
-}
-
-src_install() {
- # This is needed so that gnome2_gconf_savelist() works correctly.
- insinto /etc/gconf/schemas
- doins misc/shotwell.schemas || die "install gconf schema failed"
- gnome2_src_install
-}