summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-08-28 17:29:28 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-08-28 17:29:28 +0000
commit3d32c947309a887ee541f72a26c14c2152411304 (patch)
tree035a2f67fb7177672d396395a282f3235482d24f /media-gfx
parentUse elisp-compile instead of elisp-comp, bug 235615. (diff)
downloadgentoo-2-3d32c947309a887ee541f72a26c14c2152411304.tar.gz
gentoo-2-3d32c947309a887ee541f72a26c14c2152411304.tar.bz2
gentoo-2-3d32c947309a887ee541f72a26c14c2152411304.zip
fix parallel make, by Diego Pettenò <flameeyes@gentoo.org>, bug #236030.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26.3 x86_64)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/sam2p/ChangeLog6
-rw-r--r--media-gfx/sam2p/files/sam2p-0.45-parallelmake.patch97
-rw-r--r--media-gfx/sam2p/sam2p-0.45-r1.ebuild5
3 files changed, 105 insertions, 3 deletions
diff --git a/media-gfx/sam2p/ChangeLog b/media-gfx/sam2p/ChangeLog
index 20b7fa1f95fc..f2ff4f3f4445 100644
--- a/media-gfx/sam2p/ChangeLog
+++ b/media-gfx/sam2p/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-gfx/sam2p
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/sam2p/ChangeLog,v 1.29 2008/08/23 17:29:14 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/sam2p/ChangeLog,v 1.30 2008/08/28 17:29:28 aballier Exp $
+
+ 28 Aug 2008; Alexis Ballier <aballier@gentoo.org>
+ +files/sam2p-0.45-parallelmake.patch, sam2p-0.45-r1.ebuild:
+ fix parallel make, by Diego Pettenò <flameeyes@gentoo.org>, bug #236030.
23 Aug 2008; Markus Meier <maekke@gentoo.org> sam2p-0.45-r1.ebuild:
x86 stable, bug #232306
diff --git a/media-gfx/sam2p/files/sam2p-0.45-parallelmake.patch b/media-gfx/sam2p/files/sam2p-0.45-parallelmake.patch
new file mode 100644
index 000000000000..25afcbff808d
--- /dev/null
+++ b/media-gfx/sam2p/files/sam2p-0.45-parallelmake.patch
@@ -0,0 +1,97 @@
+Index: sam2p-0.45/Makefile
+===================================================================
+--- sam2p-0.45.orig/Makefile
++++ sam2p-0.45/Makefile
+@@ -84,47 +84,47 @@ L1_FLAGS=-DCFG_FMT_ZLIB_ONLY=1 -DNDEBUG=
+ TTT_QUOTE=perl -e '$$s=$$_=join"",<STDIN>; $$s=~s@([()\\])@\\$$1@g; die if $$ARGV[0]!~/^(\w+)/; print "\n% TTT_QUOTE\n/$$1 ($$s)\n\n"' --
+ # vvv Dat: input file for `g++ -E' must have .h extension
+ l1g8z.pst: l1zip.psm psmlib.psm ps_tiny
+- <$< >tmp.h perl -pe0
+- $(CXX) -E $(L1_FLAGS) -DUSE_A85D=1 tmp.h >tmp.i
+- <tmp.i >tmp.pin $(PREPROC_STRIP)
+- <tmp.pin >tmp.ps0 ./ps_tiny
+- <tmp.ps0 >tmp.pst $(TTT_QUOTE) $@
+- mv -f tmp.pst $@
++ <$< >$@.tmp.h perl -pe0
++ $(CXX) -E $(L1_FLAGS) -DUSE_A85D=1 $@.tmp.h >$@.tmp.i
++ <$@.tmp.i >$@.tmp.pin $(PREPROC_STRIP)
++ <$@.tmp.pin >$@.tmp.ps0 ./ps_tiny
++ <$@.tmp.ps0 >$@.tmp.pst $(TTT_QUOTE) $@
++ mv -f $@.tmp.pst $@
+ l1ghz.pst: l1zip.psm psmlib.psm ps_tiny
+- <$< >tmp.h perl -pe0
+- $(CXX) -E $(L1_FLAGS) -DUSE_HEXD=1 tmp.h >tmp.i
+- <tmp.i >tmp.pin $(PREPROC_STRIP)
+- <tmp.pin >tmp.ps0 ./ps_tiny
+- <tmp.ps0 >tmp.pst $(TTT_QUOTE) $@
+- mv -f tmp.pst $@
++ <$< >$@.tmp.h perl -pe0
++ $(CXX) -E $(L1_FLAGS) -DUSE_HEXD=1 $@.tmp.h >$@.tmp.i
++ <$@.tmp.i >$@.tmp.pin $(PREPROC_STRIP)
++ <$@.tmp.pin >$@.tmp.ps0 ./ps_tiny
++ <$@.tmp.ps0 >$@.tmp.pst $(TTT_QUOTE) $@
++ mv -f $@.tmp.pst $@
+ l1gbz.pst: l1zip.psm psmlib.psm ps_tiny
+- <$< >tmp.h perl -pe0
+- $(CXX) -E $(L1_FLAGS) -DUSE_BINARY=1 tmp.h >tmp.i
+- <tmp.i >tmp.pin $(PREPROC_STRIP)
+- <tmp.pin >tmp.ps0 ./ps_tiny
+- <tmp.ps0 >tmp.pst $(TTT_QUOTE) $@
+- mv -f tmp.pst $@
++ <$< >$@.tmp.h perl -pe0
++ $(CXX) -E $(L1_FLAGS) -DUSE_BINARY=1 $@.tmp.h >$@.tmp.i
++ <$@.tmp.i >$@.tmp.pin $(PREPROC_STRIP)
++ <$@.tmp.pin >$@.tmp.ps0 ./ps_tiny
++ <$@.tmp.ps0 >$@.tmp.pst $(TTT_QUOTE) $@
++ mv -f $@.tmp.pst $@
+ l1g8l.pst: l1lzw.psm psmlib.psm ps_tiny
+- <$< >tmp.h perl -pe0
+- $(CXX) -E $(L1_FLAGS) -DUSE_A85D=1 tmp.h >tmp.i
+- <tmp.i >tmp.pin $(PREPROC_STRIP)
+- <tmp.pin >tmp.ps0 ./ps_tiny
+- <tmp.ps0 >tmp.pst $(TTT_QUOTE) $@
+- mv -f tmp.pst $@
++ <$< >$@.tmp.h perl -pe0
++ $(CXX) -E $(L1_FLAGS) -DUSE_A85D=1 $@.tmp.h >$@.tmp.i
++ <$@.tmp.i >$@.tmp.pin $(PREPROC_STRIP)
++ <$@.tmp.pin >$@.tmp.ps0 ./ps_tiny
++ <$@.tmp.ps0 >$@.tmp.pst $(TTT_QUOTE) $@
++ mv -f $@.tmp.pst $@
+ l1ghl.pst: l1lzw.psm psmlib.psm ps_tiny
+- <$< >tmp.h perl -pe0
+- $(CXX) -E $(L1_FLAGS) -DUSE_HEXD=1 tmp.h >tmp.i
+- <tmp.i >tmp.pin $(PREPROC_STRIP)
+- <tmp.pin >tmp.ps0 ./ps_tiny
+- <tmp.ps0 >tmp.pst $(TTT_QUOTE) $@
+- mv -f tmp.pst $@
++ <$< >$@.tmp.h perl -pe0
++ $(CXX) -E $(L1_FLAGS) -DUSE_HEXD=1 $@.tmp.h >$@.tmp.i
++ <$@.tmp.i >$@.tmp.pin $(PREPROC_STRIP)
++ <$@.tmp.pin >$@.tmp.ps0 ./ps_tiny
++ <$@.tmp.ps0 >$@.tmp.pst $(TTT_QUOTE) $@
++ mv -f $@.tmp.pst $@
+ l1gbl.pst: l1lzw.psm psmlib.psm ps_tiny
+- <$< >tmp.h perl -pe0
+- $(CXX) -E $(L1_FLAGS) -DUSE_BINARY=1 tmp.h >tmp.i
+- <tmp.i >tmp.pin $(PREPROC_STRIP)
+- <tmp.pin >tmp.ps0 ./ps_tiny
+- <tmp.ps0 >tmp.pst $(TTT_QUOTE) $@
+- mv -f tmp.pst $@
++ <$< >$@.tmp.h perl -pe0
++ $(CXX) -E $(L1_FLAGS) -DUSE_BINARY=1 $@.tmp.h >$@.tmp.i
++ <$@.tmp.i >$@.tmp.pin $(PREPROC_STRIP)
++ <$@.tmp.pin >$@.tmp.ps0 ./ps_tiny
++ <$@.tmp.ps0 >$@.tmp.pst $(TTT_QUOTE) $@
++ mv -f $@.tmp.pst $@
+ # vvv copy the .ttt, not the .tth
+ # The perl program down there is a portable cat(1) implementation.
+ bts1.ttt: bts.ttt $(L1_LIST)
+@@ -133,7 +133,7 @@ bts2.ttt: bts1.ttt ps_tiny
+ ./ps_tiny --copy <$< >$@
+
+ clean:
+- rm -f *~ a.out DEADJOE core *.o *.tth .rgd *.rgd tmp.pin tmp.i tmp.ps0 tmp.h tmp.pst autom4te.cache/*
++ rm -f *~ a.out DEADJOE core *.o *.tth .rgd *.rgd *.tmp.pin *.tmp.i *.tmp.ps0 *.tmp.h *.tmp.pst autom4te.cache/*
+ rm -f debian/changelog.dch debian/*~
+ rm -f $(ALL) $(ALL:=.yes) $(ALL:=.no) $(ALL:=.assert) $(ALL:=.checker)
+ -rmdir -- autom4te.cache
diff --git a/media-gfx/sam2p/sam2p-0.45-r1.ebuild b/media-gfx/sam2p/sam2p-0.45-r1.ebuild
index 8012a221c1cb..4b962eb7c894 100644
--- a/media-gfx/sam2p/sam2p-0.45-r1.ebuild
+++ b/media-gfx/sam2p/sam2p-0.45-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/sam2p/sam2p-0.45-r1.ebuild,v 1.6 2008/08/23 17:29:14 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/sam2p/sam2p-0.45-r1.ebuild,v 1.7 2008/08/28 17:29:28 aballier Exp $
inherit toolchain-funcs eutils autotools
@@ -23,6 +23,7 @@ src_unpack() {
epatch "${FILESDIR}/${P}-fbsd.patch"
epatch "${FILESDIR}/${P}-nostrip.patch"
epatch "${FILESDIR}/${P}-cflags.patch"
+ epatch "${FILESDIR}/${P}-parallelmake.patch"
eautoreconf
}
@@ -33,7 +34,7 @@ src_compile() {
die "disable FEATURES=distcc"
fi
econf --enable-lzw $(use_enable gif) || die "econf failed"
- emake -j1 || die "make failed"
+ emake || die "make failed"
}
src_install() {