summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-08-06 05:47:07 +0000
committerMike Frysinger <vapier@gentoo.org>2015-08-06 05:47:07 +0000
commit6c253b4eee0af3876f53659610b44fdb13bf8c55 (patch)
tree5181e0eda36baa5e87b93368aab8f01eafebbcd0 /media-gfx
parentSecurity bump (bug #55607). Removed old (diff)
downloadgentoo-2-6c253b4eee0af3876f53659610b44fdb13bf8c55.tar.gz
gentoo-2-6c253b4eee0af3876f53659610b44fdb13bf8c55.tar.bz2
gentoo-2-6c253b4eee0af3876f53659610b44fdb13bf8c55.zip
Add USE=nls to control translations, and clean up $LINGUAS processing.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/sane-backends/ChangeLog6
-rw-r--r--media-gfx/sane-backends/sane-backends-1.0.25_pre20150628.ebuild22
2 files changed, 15 insertions, 13 deletions
diff --git a/media-gfx/sane-backends/ChangeLog b/media-gfx/sane-backends/ChangeLog
index 3a348e076170..53f112e38ba4 100644
--- a/media-gfx/sane-backends/ChangeLog
+++ b/media-gfx/sane-backends/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-gfx/sane-backends
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/sane-backends/ChangeLog,v 1.276 2015/07/30 08:58:23 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/sane-backends/ChangeLog,v 1.277 2015/08/06 05:47:07 vapier Exp $
+
+ 06 Aug 2015; Mike Frysinger <vapier@gentoo.org>
+ sane-backends-1.0.25_pre20150628.ebuild:
+ Add USE=nls to control translations, and clean up $LINGUAS processing.
30 Jul 2015; Mike Frysinger <vapier@gentoo.org>
sane-backends-1.0.25_pre20150628.ebuild:
diff --git a/media-gfx/sane-backends/sane-backends-1.0.25_pre20150628.ebuild b/media-gfx/sane-backends/sane-backends-1.0.25_pre20150628.ebuild
index e099bbc2bb6c..6e7107d25e3e 100644
--- a/media-gfx/sane-backends/sane-backends-1.0.25_pre20150628.ebuild
+++ b/media-gfx/sane-backends/sane-backends-1.0.25_pre20150628.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/sane-backends/sane-backends-1.0.25_pre20150628.ebuild,v 1.3 2015/07/30 08:58:23 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/sane-backends/sane-backends-1.0.25_pre20150628.ebuild,v 1.4 2015/08/06 05:47:07 vapier Exp $
EAPI="5"
@@ -94,7 +94,7 @@ IUSE_SANE_BACKENDS="
umax_pp
xerox_mfp"
-IUSE="avahi doc gphoto2 ipv6 threads usb v4l xinetd snmp systemd"
+IUSE="avahi doc gphoto2 ipv6 nls snmp systemd threads usb v4l xinetd"
for backend in ${IUSE_SANE_BACKENDS}; do
case ${backend} in
@@ -198,6 +198,13 @@ src_prepare() {
src_configure() {
append-flags -fno-strict-aliasing
+ # if LINGUAS is set, just use the listed and supported localizations.
+ if [[ ${LINGUAS+set} == "set" ]]; then
+ mkdir -p po || die
+ strip-linguas -u po
+ printf '%s\n' ${LINGUAS} > po/LINGUAS
+ fi
+
multilib-minimal_src_configure
}
@@ -231,16 +238,6 @@ multilib_src_configure() {
if ! { use sane_backends_canon_pp || use sane_backends_hpsj5s || use sane_backends_mustek_pp; }; then
myconf+=( sane_cv_use_libieee1284=no )
fi
- # if LINGUAS is set, just use the listed and supported localizations.
- if [ "${LINGUAS-NoLocalesSet}" != NoLocalesSet ]; then
- mkdir -p po || die
- echo > po/LINGUAS
- for lang in ${LINGUAS}; do
- if [ -a "${S}"/po/${lang}.po ]; then
- echo ${lang} >> po/LINGUAS
- fi
- done
- fi
# relative path must be used for tests to work properly
ECONF_SOURCE=../${MY_P} \
@@ -252,6 +249,7 @@ multilib_src_configure() {
$(use_with v4l) \
$(use_enable avahi) \
$(use_enable ipv6) \
+ $(use_enable nls translations) \
$(use_enable threads pthread) \
"${myconf[@]}"
}