summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2014-06-20 14:31:42 +0000
committerJulian Ospald <hasufell@gentoo.org>2014-06-20 14:31:42 +0000
commit6f216e06a2851e45d2d5e6477505ac24ed51a3e0 (patch)
tree61c4b73d3076c7cc11af59cc79e516d3abbe8aa5 /media-gfx
parentclean up, drop old ebuild (diff)
downloadgentoo-2-6f216e06a2851e45d2d5e6477505ac24ed51a3e0.tar.gz
gentoo-2-6f216e06a2851e45d2d5e6477505ac24ed51a3e0.tar.bz2
gentoo-2-6f216e06a2851e45d2d5e6477505ac24ed51a3e0.zip
fix build with tiff disabled wrt #513968, rm old
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key BDEED020)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/xpaint/ChangeLog7
-rw-r--r--media-gfx/xpaint/files/xpaint-2.9.10-version.patch15
-rw-r--r--media-gfx/xpaint/files/xpaint-2.9.10.2-tiff.patch37
-rw-r--r--media-gfx/xpaint/xpaint-2.9.10.2.ebuild4
-rw-r--r--media-gfx/xpaint/xpaint-2.9.10.ebuild82
5 files changed, 45 insertions, 100 deletions
diff --git a/media-gfx/xpaint/ChangeLog b/media-gfx/xpaint/ChangeLog
index 53f7de0ad515..388b39cb49f8 100644
--- a/media-gfx/xpaint/ChangeLog
+++ b/media-gfx/xpaint/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/xpaint
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/xpaint/ChangeLog,v 1.23 2014/04/22 13:14:39 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/xpaint/ChangeLog,v 1.24 2014/06/20 14:31:41 hasufell Exp $
+
+ 20 Jun 2014; Julian Ospald <hasufell@gentoo.org> -xpaint-2.9.10.ebuild,
+ xpaint-2.9.10.2.ebuild, +files/xpaint-2.9.10.2-tiff.patch,
+ -files/xpaint-2.9.10-version.patch:
+ fix build with tiff disabled wrt #513968, rm old
22 Apr 2014; Julian Ospald <hasufell@gentoo.org> xpaint-2.9.10.2.ebuild:
fix deps
diff --git a/media-gfx/xpaint/files/xpaint-2.9.10-version.patch b/media-gfx/xpaint/files/xpaint-2.9.10-version.patch
deleted file mode 100644
index 7dfbd0376b08..000000000000
--- a/media-gfx/xpaint/files/xpaint-2.9.10-version.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-From: Julian Ospald <hasufell@gentoo.org>
-Date: Tue Mar 4 03:07:38 UTC 2014
-Subject: set correct version
-
---- a/configure.ac
-+++ b/configure.ac
-@@ -9,7 +9,7 @@
- dnl m4_if(2.65, AC_AUTOCONF_VERSION, [m4_fatal([autoconf version 2.65 is broken and unusable])])
-
- dnl Update version info on each release
--AC_INIT([XPaint], [2.9.9], [Jean-Pierre.demailly@ujf-grenoble.fr])
-+AC_INIT([XPaint], [2.9.10], [Jean-Pierre.demailly@ujf-grenoble.fr])
-
- AC_CONFIG_MACRO_DIR([m4])
- AM_INIT_AUTOMAKE([-Wall -Werror])
diff --git a/media-gfx/xpaint/files/xpaint-2.9.10.2-tiff.patch b/media-gfx/xpaint/files/xpaint-2.9.10.2-tiff.patch
new file mode 100644
index 000000000000..2aa3407b08f3
--- /dev/null
+++ b/media-gfx/xpaint/files/xpaint-2.9.10.2-tiff.patch
@@ -0,0 +1,37 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Fri Jun 20 13:52:42 UTC 2014
+Subject: fix tiff build switch
+
+--- xpaint-2.9.10.2/configure.ac
++++ xpaint-2.9.10.2/configure.ac
+@@ -125,9 +125,11 @@
+ with_libtiff="yes"
+ tiff_header_found="no"
+ #
+-AC_ARG_ENABLE(tiff,
++AC_ARG_ENABLE([tiff],
+ [ --enable-tiff[=[yes|no]] Build with TIFF support [ [default=yes] ]],
+-test "$enable_tiff" = "no" && with_libtiff="no")
++ [with_libtiff=$enableval],
++ [with_libtiff=yes]
++)
+ #
+ if test "x$with_libtiff" = xyes ; then
+ #TIFF compiled with JPEG and JBIG support?
+--- xpaint-2.9.10.2/rw/readWriteTIFF.c
++++ xpaint-2.9.10.2/rw/readWriteTIFF.c
+@@ -14,6 +14,8 @@
+
+ /* $Id: xpaint-2.9.10.2-tiff.patch,v 1.1 2014/06/20 14:31:42 hasufell Exp $ */
+
++#ifdef HAVE_TIFF
++
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include "tiffio.h"
+@@ -527,3 +529,5 @@ int WriteTIFF(char *file, Image * image)
+
+ return 0;
+ }
++
++#endif /* HAVE_TIFF */
diff --git a/media-gfx/xpaint/xpaint-2.9.10.2.ebuild b/media-gfx/xpaint/xpaint-2.9.10.2.ebuild
index d9541460223c..19c27f407371 100644
--- a/media-gfx/xpaint/xpaint-2.9.10.2.ebuild
+++ b/media-gfx/xpaint/xpaint-2.9.10.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/xpaint/xpaint-2.9.10.2.ebuild,v 1.2 2014/04/22 13:14:39 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/xpaint/xpaint-2.9.10.2.ebuild,v 1.3 2014/06/20 14:31:41 hasufell Exp $
EAPI=5
@@ -42,7 +42,7 @@ DEPEND="${RDEPEND}
src_prepare() {
epatch "${FILESDIR}"/${PN}-2.9.9.4-{QA1,submake,parallel-make}.patch \
- "${FILESDIR}"/${PN}-2.9.10.2-QA2.patch
+ "${FILESDIR}"/${PN}-2.9.10.2-{QA2,tiff}.patch
eautoreconf
}
diff --git a/media-gfx/xpaint/xpaint-2.9.10.ebuild b/media-gfx/xpaint/xpaint-2.9.10.ebuild
deleted file mode 100644
index ea94c47f646d..000000000000
--- a/media-gfx/xpaint/xpaint-2.9.10.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/xpaint/xpaint-2.9.10.ebuild,v 1.1 2014/03/04 03:10:04 hasufell Exp $
-
-EAPI=5
-
-inherit autotools eutils
-
-DESCRIPTION="Image editor with tiff, jpeg and png support"
-HOMEPAGE="http://sf-xpaint.sourceforge.net/"
-SRC_URI="mirror://sourceforge/sf-xpaint/${P}.tar.bz2"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="jpeg2k pgf tiff"
-
-RDEPEND="
- media-libs/fontconfig
- media-libs/freetype
- media-libs/libpng:0
- x11-libs/libICE
- x11-libs/libX11
- x11-libs/libXaw3dXft
- x11-libs/libXext
- x11-libs/libXft
- x11-libs/libXmu
- x11-libs/libXpm
- x11-libs/libXt
- sys-libs/zlib
- virtual/jpeg
- jpeg2k? ( media-libs/openjpeg:0 )
- pgf? ( media-libs/libpgf )
- tiff? ( media-libs/tiff:0 )"
-DEPEND="${RDEPEND}
- sys-devel/flex
- sys-devel/bison
- virtual/pkgconfig"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-2.9.9.4-{QA1,QA2,submake,autoreconf,parallel-make}.patch \
- "${FILESDIR}"/${P}-version.patch
- eautoreconf
-}
-
-src_configure() {
- econf \
- $(use_enable tiff) \
- $(use_enable jpeg2k libopenjpeg)
-}
-
-src_compile() {
- # clean up
- emake clean
- emake -C util clean
-
- # parallel make still fails sometimes
- emake substads
- emake xpaint.1
-
- default
- emake \
- WITH_PGF="$(usex pgf "yes" "no")" \
- CC="$(tc-getCC)" \
- CXX="$(tc-getCXX)" \
- -C util
-}
-
-src_install() {
- default
- emake \
- WITH_PGF="$(usex pgf "yes" "no")" \
- DESTDIR="${ED}" \
- -C util install
-}
-
-pkg_postinst() {
- elog "optional dependencies:"
- elog " app-text/gv (external viewer for PostScript output)"
- elog " media-gfx/imagemagick (external viewer for pixel graphics)"
- elog " net-print/cups (printing)"
-}