summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryon Roche <kain@gentoo.org>2002-12-03 07:33:05 +0000
committerBryon Roche <kain@gentoo.org>2002-12-03 07:33:05 +0000
commit7054516f9b4eb64a8d4a1ae90d4449d67dab2090 (patch)
treefa90619f2ecfb548bc6b82926d0d33237d9778ad /media-gfx
parentadded app-dicts to categories file (diff)
downloadgentoo-2-7054516f9b4eb64a8d4a1ae90d4449d67dab2090.tar.gz
gentoo-2-7054516f9b4eb64a8d4a1ae90d4449d67dab2090.tar.bz2
gentoo-2-7054516f9b4eb64a8d4a1ae90d4449d67dab2090.zip
fix to libtoolize a convenience library (libgimpi.a) in gimp so gimp can
parallel make
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/gimp/files/gimp-1.2.3-libgimpi-libtool.diff46
1 files changed, 46 insertions, 0 deletions
diff --git a/media-gfx/gimp/files/gimp-1.2.3-libgimpi-libtool.diff b/media-gfx/gimp/files/gimp-1.2.3-libgimpi-libtool.diff
new file mode 100644
index 000000000000..ff8b03815442
--- /dev/null
+++ b/media-gfx/gimp/files/gimp-1.2.3-libgimpi-libtool.diff
@@ -0,0 +1,46 @@
+diff -ur gimp-1.2.3.orig/app/Makefile.am gimp-1.2.3/app/Makefile.am
+--- gimp-1.2.3.orig/app/Makefile.am 2002-02-03 19:28:05.000000000 -0600
++++ gimp-1.2.3/app/Makefile.am 2002-12-03 00:52:28.000000000 -0600
+@@ -466,7 +466,7 @@
+ $(gimp_exp) \
+ $(gimp_win32_resource) \
+ libgimpim.a \
+- $(top_builddir)/libgimp/libgimpi.a \
++ $(top_builddir)/libgimp/libgimpi.la \
+ $(GTK_LIBS) \
+ $(GIMP_THREAD_LIBS) \
+ $(GIMP_MP_LIBS) \
+diff -ur gimp-1.2.3.orig/libgimp/Makefile.am gimp-1.2.3/libgimp/Makefile.am
+--- gimp-1.2.3.orig/libgimp/Makefile.am 2001-11-29 16:32:46.000000000 -0600
++++ gimp-1.2.3/libgimp/Makefile.am 2002-12-03 00:56:26.000000000 -0600
+@@ -71,7 +71,7 @@
+ gimpui.def
+
+ lib_LTLIBRARIES = libgimp.la libgimpui.la
+-noinst_LIBRARIES = libgimpi.a
++noinst_LTLIBRARIES = libgimpi.la
+
+ PDB_WRAPPERS_C = \
+ gimpbrushes_pdb.c \
+@@ -142,7 +142,7 @@
+ gimpundo_pdb.h \
+ gimpunit_pdb.h
+
+-libgimpi_a_SOURCES = \
++libgimpi_la_SOURCES = \
+ gimpenv.c \
+ gimpenv.h \
+ gimpchainbutton.c \
+@@ -187,9 +187,11 @@
+
+ if STATICLIBS
+ ## Evil hack to insure all deps are satisfied on first-run make
+-libgimpi_a_DEPENDENCIES = libgimp.la
++libgimpi_la_DEPENDENCIES = libgimp.la
+ endif
+
++libgimpi_la_LDFLAGS = -static
++
+ # help `make' along by giving another name for the file, which it knows
+ # how to build
+ ../libgimp/gimpfeatures.h: gimpfeatures.h