summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-05-04 19:55:13 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-05-04 19:55:13 +0000
commit770bb6ee2bdaca0e7c9d0652ce019fcc33293443 (patch)
treeb3f30c377350823a70a8a728e14e84cfb42f62f1 /media-gfx
parentVersion bump. Now supports OpenMP and R (diff)
downloadgentoo-2-770bb6ee2bdaca0e7c9d0652ce019fcc33293443.tar.gz
gentoo-2-770bb6ee2bdaca0e7c9d0652ce019fcc33293443.tar.bz2
gentoo-2-770bb6ee2bdaca0e7c9d0652ce019fcc33293443.zip
Initial commit of picturewall application
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/picturewall/ChangeLog10
-rw-r--r--media-gfx/picturewall/metadata.xml12
-rw-r--r--media-gfx/picturewall/picturewall-1.0.ebuild30
3 files changed, 52 insertions, 0 deletions
diff --git a/media-gfx/picturewall/ChangeLog b/media-gfx/picturewall/ChangeLog
new file mode 100644
index 000000000000..2a129038152d
--- /dev/null
+++ b/media-gfx/picturewall/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for media-gfx/picturewall
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/picturewall/ChangeLog,v 1.1 2010/05/04 19:55:13 hwoarang Exp $
+
+*picturewall-1.0 (04 May 2010)
+
+ 04 May 2010; Markos Chandras <hwoarang@gentoo.org>
+ +picturewall-1.0.ebuild, +metadata.xml:
+ Initial commit of picturewall application
+
diff --git a/media-gfx/picturewall/metadata.xml b/media-gfx/picturewall/metadata.xml
new file mode 100644
index 000000000000..d5f9562e2df2
--- /dev/null
+++ b/media-gfx/picturewall/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>qt</herd>
+<maintainer>
+<email>hwoarang@gentoo.org</email>
+<name>Markos Chandras</name>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+
diff --git a/media-gfx/picturewall/picturewall-1.0.ebuild b/media-gfx/picturewall/picturewall-1.0.ebuild
new file mode 100644
index 000000000000..f88861e37f77
--- /dev/null
+++ b/media-gfx/picturewall/picturewall-1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/picturewall/picturewall-1.0.ebuild,v 1.1 2010/05/04 19:55:13 hwoarang Exp $
+
+EAPI="2"
+
+inherit qt4-r2
+MY_PN="PictureWall"
+MY_P="${MY_PN}_${PV}"
+
+DESCRIPTION="Qt4 picture viewer and image searching tool using google.com"
+HOMEPAGE="http://www.qt-apps.org/content/show.php?content=106101"
+SRC_URI="http://picturewall.googlecode.com/files/PictureWall_1.0.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND=">=x11-libs/qt-gui-4.5.3"
+DEPEND="app-arch/unzip
+ ${RDEPEND}"
+
+S="${WORKDIR}/${MY_PN}/${MY_PN}"
+
+src_install(){
+ dobin bin/${PN} || die "dobin failed"
+ dodoc ReadMe || die "dodoc failed"
+ dohtml -r doc/html/* || die "dohtml failed"
+}