summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Nazaroff <naz@gentoo.org>2002-07-14 20:45:55 +0000
committerMichael Nazaroff <naz@gentoo.org>2002-07-14 20:45:55 +0000
commit946a986ec195066b44f8f803e26f1ff37ea13b94 (patch)
tree6d242daf50eee7151d591e7a804f9288f4f18186 /media-gfx
parentNew version. (diff)
downloadgentoo-2-946a986ec195066b44f8f803e26f1ff37ea13b94.tar.gz
gentoo-2-946a986ec195066b44f8f803e26f1ff37ea13b94.tar.bz2
gentoo-2-946a986ec195066b44f8f803e26f1ff37ea13b94.zip
Initial relase xli a image viewer
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/xli/ChangeLog10
-rw-r--r--media-gfx/xli/files/digest-xli-1.17.01
-rw-r--r--media-gfx/xli/xli-1.17.0.ebuild55
3 files changed, 66 insertions, 0 deletions
diff --git a/media-gfx/xli/ChangeLog b/media-gfx/xli/ChangeLog
new file mode 100644
index 000000000000..9c6d5dee131d
--- /dev/null
+++ b/media-gfx/xli/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for <CATEGORY>/<PACKAGE_NAME>
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/xli/ChangeLog,v 1.1 2002/07/14 20:45:55 naz Exp $
+
+*xli-1.17.0 (13 Jul 2002)
+
+ 13 Jul 2002; Michael Nazaroff <naz@gentoo.org> xli-1.17.0:
+
+ Initial relase of image viewer. Thanx to the submitter for the ebuild.
+ ebuild submitted by Paul Thompson <thompson@pobox.com>
diff --git a/media-gfx/xli/files/digest-xli-1.17.0 b/media-gfx/xli/files/digest-xli-1.17.0
new file mode 100644
index 000000000000..e1d1af9b151c
--- /dev/null
+++ b/media-gfx/xli/files/digest-xli-1.17.0
@@ -0,0 +1 @@
+MD5 996d8cd0b2be2071332412c6802852e6 xli-1.17.0.tar.gz 200069
diff --git a/media-gfx/xli/xli-1.17.0.ebuild b/media-gfx/xli/xli-1.17.0.ebuild
new file mode 100644
index 000000000000..f5c9af6a7ecb
--- /dev/null
+++ b/media-gfx/xli/xli-1.17.0.ebuild
@@ -0,0 +1,55 @@
+# Distributed under the terms of the GNU General Public License v2
+
+S=${WORKDIR}/${P}
+DESCRIPTION="X Load Image: view images or load them to root window"
+SRC_URI="ftp://ftp.freebsd.org/pub/FreeBSD/ports/distfiles/${P}.tar.gz"
+HOMEPAGE="http://pantransit.reptiles.org/prog/"
+
+SLOT="0"
+LICENSE="X11"
+KEYWORDS="x86"
+
+DEPEND="virtual/glibc \
+ virtual/x11 \
+ >=sys-libs/zlib-1.1.4
+ >=media-libs/libpng-1.0.5 \
+ >=media-libs/jpeg-6b-r2"
+
+src_compile() {
+ cp Imakefile Imakefile.orig
+ sed -e "/^DEFINES =/s/$/ -DHAVE_GUNZIP/" < Imakefile.orig > Imakefile
+
+ /usr/X11R6/bin/xmkmf || die
+
+ cp Makefile Makefile.orig
+ sed -e "/CDEBUGFLAGS =/s/=.*/= ${CFLAGS}/" < Makefile.orig > Makefile
+
+ # This is a hack to avoid a parse error on /usr/include/string.h
+ # when _BSD_SOURCE is defined. This may be a bug in that header.
+ cp png.c png.c.orig
+ sed -e "/^#include \"xli.h\"/i#undef _BSD_SOURCE" < png.c.orig > png.c
+
+ emake || die
+}
+
+src_install () {
+ into /usr
+ dobin xli xlito
+ dodoc README README.xloadimage ABOUTGAMMA TODO chkgamma.jpg
+ newman xli.man xli.1
+ newman xliguide.man xliguide.1
+ newman xlito.man xlito.1
+ dosym /usr/bin/xli /usr/bin/xview
+ dosym /usr/bin/xli /usr/bin/xsetbg
+
+ # is this even worth it? xrdb doesnt like this file; this is what
+ # their install does, though.
+ dodir /usr/X11R6/lib/X11/app-defaults
+ cp /dev/null ${D}/usr/X11R6/lib/X11/app-defaults/Xli
+ echo "path=/usr/X11R6/include/X11/bitmaps /usr/X11R6/include/X11/images" \
+ >> ${D}/usr/X11R6/lib/X11/app-defaults/Xli
+ echo "extension=.gif .jpg .rle .csun .msun .sun .face .xbm .bm" \
+ >> ${D}/usr/X11R6/lib/X11/app-defaults/Xli
+ chmod a+r ${D}/usr/X11R6/lib/X11/app-defaults/Xli
+}
+