summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-12-01 12:48:42 +0000
committerMichał Górny <mgorny@gentoo.org>2014-12-01 12:48:42 +0000
commita53c219702bacfaa1db49e69840b69192a5c0ea2 (patch)
treec2e836306491b2592b5fca676a4db9aafc8c5b8a /media-gfx
parentAdd new PaX patches (bug #529633). (diff)
downloadgentoo-2-a53c219702bacfaa1db49e69840b69192a5c0ea2.tar.gz
gentoo-2-a53c219702bacfaa1db49e69840b69192a5c0ea2.tar.bz2
gentoo-2-a53c219702bacfaa1db49e69840b69192a5c0ea2.zip
Use python-r1 to avoid issues with python-single-r1 when depending on libpeas.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/eog-plugins/ChangeLog5
-rw-r--r--media-gfx/eog-plugins/eog-plugins-3.12.1-r1.ebuild12
2 files changed, 9 insertions, 8 deletions
diff --git a/media-gfx/eog-plugins/ChangeLog b/media-gfx/eog-plugins/ChangeLog
index a3d569844426..49c0eb435ed8 100644
--- a/media-gfx/eog-plugins/ChangeLog
+++ b/media-gfx/eog-plugins/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-gfx/eog-plugins
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog-plugins/ChangeLog,v 1.20 2014/11/25 15:17:25 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog-plugins/ChangeLog,v 1.21 2014/12/01 12:48:42 mgorny Exp $
+
+ 01 Dec 2014; Michał Górny <mgorny@gentoo.org> eog-plugins-3.12.1-r1.ebuild:
+ Use python-r1 to avoid issues with python-single-r1 when depending on libpeas.
*eog-plugins-3.12.1-r1 (25 Nov 2014)
diff --git a/media-gfx/eog-plugins/eog-plugins-3.12.1-r1.ebuild b/media-gfx/eog-plugins/eog-plugins-3.12.1-r1.ebuild
index f6f5be125659..3fa1793ccd9e 100644
--- a/media-gfx/eog-plugins/eog-plugins-3.12.1-r1.ebuild
+++ b/media-gfx/eog-plugins/eog-plugins-3.12.1-r1.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog-plugins/eog-plugins-3.12.1-r1.ebuild,v 1.1 2014/11/25 15:17:25 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog-plugins/eog-plugins-3.12.1-r1.ebuild,v 1.2 2014/12/01 12:48:42 mgorny Exp $
EAPI="5"
GCONF_DEBUG="no"
GNOME2_LA_PUNT="yes"
-PYTHON_COMPAT=( python{3_2,3_3,3_4} )
+PYTHON_COMPAT=( python{3_3,3_4} )
-inherit gnome2 python-single-r1
+inherit gnome2 python-r1
DESCRIPTION="Eye of GNOME plugins"
HOMEPAGE="https://wiki.gnome.org/Apps/EyeOfGnome/Plugins"
@@ -16,12 +16,10 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="+exif +flickr map +picasa +python"
-# Let people emerge this by default, bug #472932
-IUSE+=" +python_single_target_python3_3"
REQUIRED_USE="
map? ( exif )
- python? ( ${PYTHON_REQUIRED_USE} )"
+ python? ( ^^ ( $(python_gen_useflags '*') ) )"
RDEPEND="
>=dev-libs/glib-2.32:2
@@ -51,7 +49,7 @@ DEPEND="${RDEPEND}
"
pkg_setup() {
- use python && python-single-r1_pkg_setup
+ use python && [[ ${MERGE_TYPE} == binary ]] && python_setup
}
src_configure() {