summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-03-16 14:01:16 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-03-16 14:01:16 +0000
commit90cfae3b2a816bfe7261ee8b57b0d6fe1afa7daf (patch)
treea898178cf4a5bfe2731180a0f02dd1760746791c /media-libs/allegro/files
parentCompile and link against allegro >= 4.4.1.1. (diff)
downloadgentoo-2-90cfae3b2a816bfe7261ee8b57b0d6fe1afa7daf.tar.gz
gentoo-2-90cfae3b2a816bfe7261ee8b57b0d6fe1afa7daf.tar.bz2
gentoo-2-90cfae3b2a816bfe7261ee8b57b0d6fe1afa7daf.zip
Version bump wrt #303711, thanks to Hubert Kowalski for reporting.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/allegro/files')
-rw-r--r--media-libs/allegro/files/allegro-4.4.1.1-optional_drivers.patch48
-rw-r--r--media-libs/allegro/files/allegro-4.4.1.1-shared.patch11
2 files changed, 59 insertions, 0 deletions
diff --git a/media-libs/allegro/files/allegro-4.4.1.1-optional_drivers.patch b/media-libs/allegro/files/allegro-4.4.1.1-optional_drivers.patch
new file mode 100644
index 000000000000..328ebb7b0bb0
--- /dev/null
+++ b/media-libs/allegro/files/allegro-4.4.1.1-optional_drivers.patch
@@ -0,0 +1,48 @@
+--- CMakeLists.txt
++++ CMakeLists.txt
+@@ -376,6 +376,10 @@
+ # Platform drivers
+ #
+
++option(WANT_OSS "Build OSS support" on)
++option(WANT_ALSA "Build ALSA support" on)
++option(WANT_JACK "Build JACK support" on)
++
+ set(PLATFORM_SOURCES)
+ set(PLATFORM_LIBS) # always link with these libraries
+ set(PLATFORM_LIBS_NON_MODULES) # only link with these if modules disabled
+@@ -391,13 +395,16 @@
+ list(APPEND PLATFORM_LIBS m ${CMAKE_THREAD_LIBS_INIT})
+ list(APPEND PLATFORM_SOURCES ${ALLEGRO_SRC_UNIX_FILES})
+
++ if(WANT_OSS)
+ include(AllegroFindOSS)
+ if(OSS_FOUND)
+ set(ALLEGRO_WITH_OSSDIGI 1)
+ set(ALLEGRO_WITH_OSSMIDI 1)
+ include_directories(SYSTEM ${OSS_INCLUDE_DIR})
+ endif(OSS_FOUND)
++ endif(WANT_OSS)
+
++ if(WANT_ALSA)
+ pkg_check_modules(ALSA alsa)
+ if(ALSA_FOUND)
+ # ALSA 0.5 is beyond obsolete.
+@@ -409,7 +416,9 @@
+ add_our_module(alleg-alsadigi src/unix/alsa9.c ${ALSA_LIBRARIES})
+ add_our_module(alleg-alsamidi src/unix/alsamidi.c ${ALSA_LIBRARIES})
+ endif(ALSA_FOUND)
++ endif(WANT_ALSA)
+
++ if(WANT_JACK)
+ pkg_check_modules(JACK jack)
+ if(JACK_FOUND)
+ set(ALLEGRO_WITH_JACKDIGI 1)
+@@ -417,6 +426,7 @@
+ list(APPEND PLATFORM_LIBS_NON_MODULES ${JACK_LIBRARIES})
+ add_our_module(alleg-jack src/unix/jack.c ${JACK_LIBRARIES})
+ endif(JACK_FOUND)
++ endif(WANT_JACK)
+
+ # This is untested.
+ check_library_exists(audio alOpenPort "" SGIAUDIO_FOUND)
diff --git a/media-libs/allegro/files/allegro-4.4.1.1-shared.patch b/media-libs/allegro/files/allegro-4.4.1.1-shared.patch
new file mode 100644
index 000000000000..665c03e31204
--- /dev/null
+++ b/media-libs/allegro/files/allegro-4.4.1.1-shared.patch
@@ -0,0 +1,11 @@
+--- CMakeLists.txt
++++ CMakeLists.txt
+@@ -830,7 +830,7 @@
+ option(WANT_LOGG "Enable logg" on)
+ option(WANT_JPGALLEG "Enable JPGAlleg" on)
+
+-if(WANT_FRAMEWORKS)
++if(SHARED)
+ set(ADDON_LINKAGE SHARED)
+ else()
+ set(ADDON_LINKAGE STATIC)