summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimo Gurr <tgurr@gentoo.org>2009-10-26 21:58:22 +0000
committerTimo Gurr <tgurr@gentoo.org>2009-10-26 21:58:22 +0000
commitac2aab08efc167d2453ce1535f4ac34ec5faf5f9 (patch)
tree22834c8c4d1e96e611f2c97d08c4441b7d4ef0e6 /media-libs/celt
parentStable for HPPA (bug #282290). (diff)
downloadgentoo-2-ac2aab08efc167d2453ce1535f4ac34ec5faf5f9.tar.gz
gentoo-2-ac2aab08efc167d2453ce1535f4ac34ec5faf5f9.tar.bz2
gentoo-2-ac2aab08efc167d2453ce1535f4ac34ec5faf5f9.zip
Version bump, includes API changes in this release.
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/celt')
-rw-r--r--media-libs/celt/ChangeLog7
-rw-r--r--media-libs/celt/celt-0.7.0.ebuild28
2 files changed, 34 insertions, 1 deletions
diff --git a/media-libs/celt/ChangeLog b/media-libs/celt/ChangeLog
index 6e2a13eb05e5..7486f18808eb 100644
--- a/media-libs/celt/ChangeLog
+++ b/media-libs/celt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/celt
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/celt/ChangeLog,v 1.4 2009/09/29 17:49:21 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/celt/ChangeLog,v 1.5 2009/10/26 21:58:22 tgurr Exp $
+
+*celt-0.7.0 (26 Oct 2009)
+
+ 26 Oct 2009; Timo Gurr <tgurr@gentoo.org> +celt-0.7.0.ebuild:
+ Version bump, includes API changes in this release.
29 Sep 2009; Tobias Klausmann <klausman@gentoo.org> celt-0.6.1.ebuild:
Keyworded on alpha, bug #276355
diff --git a/media-libs/celt/celt-0.7.0.ebuild b/media-libs/celt/celt-0.7.0.ebuild
new file mode 100644
index 000000000000..231938e119e2
--- /dev/null
+++ b/media-libs/celt/celt-0.7.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/celt/celt-0.7.0.ebuild,v 1.1 2009/10/26 21:58:22 tgurr Exp $
+
+EAPI="2"
+
+DESCRIPTION="CELT is a very low delay audio codec designed for high-quality communications."
+HOMEPAGE="http://www.celt-codec.org/"
+SRC_URI="http://downloads.us.xiph.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE="ogg"
+
+DEPEND="ogg? ( media-libs/libogg )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf $(use_with ogg ogg /usr)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc ChangeLog README TODO || die "dodoc failed."
+
+ find "${D}" -name '*.la' -delete
+}