summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-07-06 22:32:24 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-07-06 22:32:24 +0000
commit12e31b83ff18aa6a9e63c08062784e49184d7efa (patch)
tree1d8ef67beb02daac0bd99c06214ee62660a29f05 /media-libs/dumb/dumb-0.9.2-r2.ebuild
parent~amd64 (Manifest recommit) (diff)
downloadgentoo-2-12e31b83ff18aa6a9e63c08062784e49184d7efa.tar.gz
gentoo-2-12e31b83ff18aa6a9e63c08062784e49184d7efa.tar.bz2
gentoo-2-12e31b83ff18aa6a9e63c08062784e49184d7efa.zip
Patch to use shared libs instead of static. ~amd64.
Diffstat (limited to 'media-libs/dumb/dumb-0.9.2-r2.ebuild')
-rw-r--r--media-libs/dumb/dumb-0.9.2-r2.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/media-libs/dumb/dumb-0.9.2-r2.ebuild b/media-libs/dumb/dumb-0.9.2-r2.ebuild
new file mode 100644
index 000000000000..97ee88117dc0
--- /dev/null
+++ b/media-libs/dumb/dumb-0.9.2-r2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/dumb/dumb-0.9.2-r2.ebuild,v 1.1 2004/07/06 22:32:24 eradicator Exp $
+
+IUSE=""
+
+inherit eutils
+
+S="${WORKDIR}/${PN}"
+DESCRIPTION="IT/XM/S3M/MOD player library with click removal and IT filters"
+HOMEPAGE="http://dumb.sourceforge.net/"
+SRC_URI="mirror://sourceforge/dumb/${P}-fixed.tar.gz"
+
+KEYWORDS="x86 ~ppc ~alpha ~ia64 ~amd64"
+LICENSE="DUMB-0.9.2"
+SLOT="0"
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cat << EOF > make/config.txt
+include make/unix.inc
+ALL_TARGETS := core core-examples core-headers
+PREFIX := /usr
+EOF
+
+ epatch ${FILESDIR}/${P}-PIC.patch
+}
+
+src_compile() {
+ emake OFLAGS="${CFLAGS}" all || die "emake failed"
+}
+
+src_install() {
+ dodir /usr/lib /usr/include /usr/bin
+ make PREFIX="${D}/usr" install || die "make install failed"
+ dodoc readme.txt release.txt docs/* || die "dodoc failed"
+}
+
+pkg_postinst() {
+ einfo
+ einfo "DUMB's core has been installed. This will enable you to convert module"
+ einfo "files to PCM data (ready for sending to /dev/dsp, writing to a .wav"
+ einfo "file, piping through oggenc, etc.)."
+ einfo
+ einfo "If you are using Allegro, you will also want to 'emerge aldumb'. This"
+ einfo "provides you with a convenient API for playing module files through"
+ einfo "Allegro's sound system, and also enables DUMB to integrate with"
+ einfo "Allegro's datafile system so you can add modules to datafiles."
+ einfo
+ einfo "As a developer, when you distribute your game and write your docs, be"
+ einfo "aware that 'dumb' and 'aldumb' actually come from the same download."
+ einfo "People who don't use Gentoo will only have to download and install one"
+ einfo "package. See /usr/share/doc/${PF}/readme.txt.gz for details on"
+ einfo "how DUMB would be compiled manually."
+ einfo
+}