summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-07-28 06:51:47 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-07-28 06:51:47 +0000
commita35cd50e82d8e3ef5a1860d99f7e73e198c62596 (patch)
treee9ce3e88c7c1d8be5706a1d24f9606fd07bd5f02 /media-libs/faac/faac-1.24-r3.ebuild
parentAdd patch for fue 2.6.0_pre3 thanks to gardo <dbiscocho@skydsl.com.ph> and <c... (diff)
downloadgentoo-2-a35cd50e82d8e3ef5a1860d99f7e73e198c62596.tar.gz
gentoo-2-a35cd50e82d8e3ef5a1860d99f7e73e198c62596.tar.bz2
gentoo-2-a35cd50e82d8e3ef5a1860d99f7e73e198c62596.zip
Revision bump restoring libmp4v2 support, see bug #116173. Thanks to Oliver Crete for the bug and the patience.
(Portage version: 2.1.1_pre3-r5)
Diffstat (limited to 'media-libs/faac/faac-1.24-r3.ebuild')
-rw-r--r--media-libs/faac/faac-1.24-r3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-libs/faac/faac-1.24-r3.ebuild b/media-libs/faac/faac-1.24-r3.ebuild
new file mode 100644
index 000000000000..6bd2edcc7c0d
--- /dev/null
+++ b/media-libs/faac/faac-1.24-r3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/faac/faac-1.24-r3.ebuild,v 1.1 2006/07/28 06:51:47 flameeyes Exp $
+
+inherit libtool eutils autotools
+
+DESCRIPTION="Free MPEG-4 audio codecs by AudioCoding.com"
+HOMEPAGE="http://www.audiocoding.com/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=media-libs/libsndfile-1.0.0
+ media-libs/libmp4v2"
+DEPEND="${RDEPEND}
+ !<media-libs/faad2-2.0-r3"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-tracknumber.patch"
+ epatch "${FILESDIR}/${P}-as-needed.patch"
+
+ eautoreconf
+ elibtoolize
+ epunt_cxx
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README TODO docs/libfaac.pdf
+}