summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-04-30 10:46:48 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-04-30 10:46:48 +0000
commit452d74ef388d5c7c6c45a5fff309abefe85ff028 (patch)
treed65e7661463410e7f8b7ddb21fd317496ff4880d /media-libs/freealut/freealut-1.1.0-r1.ebuild
parentbump version (diff)
downloadgentoo-2-452d74ef388d5c7c6c45a5fff309abefe85ff028.tar.gz
gentoo-2-452d74ef388d5c7c6c45a5fff309abefe85ff028.tar.bz2
gentoo-2-452d74ef388d5c7c6c45a5fff309abefe85ff028.zip
Fix SRC_URI wrt #317889 by Jeff Sweeney.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/freealut/freealut-1.1.0-r1.ebuild')
-rw-r--r--media-libs/freealut/freealut-1.1.0-r1.ebuild27
1 files changed, 14 insertions, 13 deletions
diff --git a/media-libs/freealut/freealut-1.1.0-r1.ebuild b/media-libs/freealut/freealut-1.1.0-r1.ebuild
index b2e58f8ddcb4..cbae626af2e3 100644
--- a/media-libs/freealut/freealut-1.1.0-r1.ebuild
+++ b/media-libs/freealut/freealut-1.1.0-r1.ebuild
@@ -1,37 +1,38 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/freealut/freealut-1.1.0-r1.ebuild,v 1.1 2009/04/29 12:20:52 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/freealut/freealut-1.1.0-r1.ebuild,v 1.2 2010/04/30 10:46:48 ssuominen Exp $
+EAPI=2
inherit autotools eutils
DESCRIPTION="The OpenAL Utility Toolkit"
-SRC_URI="http://www.openal.org/openal_webstf/downloads/${P}.tar.gz"
-HOMEPAGE="http://www.openal.org"
+HOMEPAGE="http://www.openal.org/"
+SRC_URI="http://connect.creativelabs.com/openal/Downloads/ALUT/${P}.tar.gz"
LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
IUSE=""
-RDEPEND=">=media-libs/openal-1.6.372"
-DEPEND="${RDEPEND}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
+DEPEND="media-libs/openal"
+src_prepare() {
# Link against openal and pthread
sed -i -e 's/libalut_la_LIBADD = .*/& -lopenal -lpthread/' src/Makefile.am
AT_M4DIR="${S}/admin/autotools/m4" eautoreconf
}
+src_configure() {
+ econf \
+ --libdir=/usr/$(get_libdir)
+}
+
src_compile() {
- econf --libdir=/usr/$(get_libdir)
- emake all || die "emake all failed"
+ emake all || die
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
+ emake DESTDIR="${D}" install || die
dodoc AUTHORS ChangeLog NEWS README
dohtml doc/*
}