summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2014-04-18 20:36:44 +0000
committerJulian Ospald <hasufell@gentoo.org>2014-04-18 20:36:44 +0000
commit7a359aa93efb8384d45155173f8aa1b7891817c1 (patch)
tree3620a6b53682e07c4fc58f5da14b40f49268675c /media-libs/freealut
parentmask >=media-libs/freealut-1.1.0-r3 for multilib conversion (diff)
downloadgentoo-2-7a359aa93efb8384d45155173f8aa1b7891817c1.tar.gz
gentoo-2-7a359aa93efb8384d45155173f8aa1b7891817c1.tar.bz2
gentoo-2-7a359aa93efb8384d45155173f8aa1b7891817c1.zip
add multilib support
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key BDEED020)
Diffstat (limited to 'media-libs/freealut')
-rw-r--r--media-libs/freealut/ChangeLog7
-rw-r--r--media-libs/freealut/freealut-1.1.0-r3.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/media-libs/freealut/ChangeLog b/media-libs/freealut/ChangeLog
index a08569596aa8..b3ecf1b6d2e5 100644
--- a/media-libs/freealut/ChangeLog
+++ b/media-libs/freealut/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/freealut
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/freealut/ChangeLog,v 1.37 2014/03/19 16:13:10 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/freealut/ChangeLog,v 1.38 2014/04/18 20:36:44 hasufell Exp $
+
+*freealut-1.1.0-r3 (18 Apr 2014)
+
+ 18 Apr 2014; Julian Ospald <hasufell@gentoo.org> +freealut-1.1.0-r3.ebuild:
+ add multilib support
19 Mar 2014; Agostino Sarubbo <ago@gentoo.org> freealut-1.1.0-r2.ebuild:
Stable for alpha, wrt bug #495714
diff --git a/media-libs/freealut/freealut-1.1.0-r3.ebuild b/media-libs/freealut/freealut-1.1.0-r3.ebuild
new file mode 100644
index 000000000000..bab28e75ce61
--- /dev/null
+++ b/media-libs/freealut/freealut-1.1.0-r3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/freealut/freealut-1.1.0-r3.ebuild,v 1.1 2014/04/18 20:36:44 hasufell Exp $
+
+EAPI=5
+inherit eutils autotools multilib-minimal
+
+DESCRIPTION="The OpenAL Utility Toolkit"
+HOMEPAGE="http://www.openal.org/"
+SRC_URI="http://connect.creativelabs.com/openal/Downloads/ALUT/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+RDEPEND="
+ abi_x86_32? (
+ !app-emulation/emul-linux-x86-sdl[-abi_x86_32(-)]
+ !<=app-emulation/emul-linux-x86-sdl-20140406
+ )
+ media-libs/openal[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ # Link against openal and pthread
+ sed -i -e 's/libalut_la_LIBADD = .*/& -lopenal -lpthread/' src/Makefile.am
+ AT_M4DIR="${S}/admin/autotools/m4" eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} econf \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ dohtml doc/*
+ prune_libtool_files
+}