summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2010-06-28 08:42:41 +0000
committerMart Raudsepp <leio@gentoo.org>2010-06-28 08:42:41 +0000
commit471939616018a964f0abbea337863e34a7d6d9ba (patch)
tree72bdf7998fa0ae43f81df500c6979ffef6893047 /media-libs/gst-plugins-base
parentFixes suggested by (QA-man) ssumoinen. (diff)
downloadgentoo-2-471939616018a964f0abbea337863e34a7d6d9ba.tar.gz
gentoo-2-471939616018a964f0abbea337863e34a7d6d9ba.tar.bz2
gentoo-2-471939616018a964f0abbea337863e34a7d6d9ba.zip
Version bump with the following most noteworthy upstream changes: Basic XMP metadata support. On2 VP62 and VP7 support in riff-media. color-matrix/chroma-site field and 8/16-bit grayscale format support in video helper library. Various bug fixes and improvements.
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/gst-plugins-base')
-rw-r--r--media-libs/gst-plugins-base/ChangeLog13
-rw-r--r--media-libs/gst-plugins-base/gst-plugins-base-0.10.29.ebuild42
2 files changed, 54 insertions, 1 deletions
diff --git a/media-libs/gst-plugins-base/ChangeLog b/media-libs/gst-plugins-base/ChangeLog
index 872e2701a6b3..c50308c1d997 100644
--- a/media-libs/gst-plugins-base/ChangeLog
+++ b/media-libs/gst-plugins-base/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for media-libs/gst-plugins-base
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-base/ChangeLog,v 1.129 2010/06/27 13:24:55 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-base/ChangeLog,v 1.130 2010/06/28 08:42:41 leio Exp $
+
+*gst-plugins-base-0.10.29 (28 Jun 2010)
+
+ 28 Jun 2010; Mart Raudsepp <leio@gentoo.org>
+ +gst-plugins-base-0.10.29.ebuild:
+ Version bump with the following most noteworthy upstream changes:
+ Basic XMP metadata support.
+ On2 VP62 and VP7 support in riff-media.
+ color-matrix/chroma-site field and 8/16-bit grayscale format support in
+ video helper library.
+ Various bug fixes and improvements.
27 Jun 2010; <nixnut@gentoo.org> gst-plugins-base-0.10.28.ebuild:
ppc stable #324691
diff --git a/media-libs/gst-plugins-base/gst-plugins-base-0.10.29.ebuild b/media-libs/gst-plugins-base/gst-plugins-base-0.10.29.ebuild
new file mode 100644
index 000000000000..346c67c7a34c
--- /dev/null
+++ b/media-libs/gst-plugins-base/gst-plugins-base-0.10.29.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-base/gst-plugins-base-0.10.29.ebuild,v 1.1 2010/06/28 08:42:41 leio Exp $
+
+# order is important, gnome2 after gst-plugins
+inherit gst-plugins-base gst-plugins10 gnome2 flag-o-matic eutils
+# libtool
+
+DESCRIPTION="Basepack of plugins for gstreamer"
+HOMEPAGE="http://gstreamer.sourceforge.net"
+SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~amd64-linux ~arm ~hppa ~ia64 ~ppc ~ppc-macos ~ppc64 ~sh ~sparc ~sparc-solaris ~x64-macos ~x64-solaris ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~x86-linux ~x86-macos ~x86-solaris"
+IUSE="nls"
+
+RDEPEND=">=dev-libs/glib-2.18
+ >=media-libs/gstreamer-0.10.29
+ >=dev-libs/liboil-0.3.14
+ dev-libs/libxml2
+ app-text/iso-codes
+ !<media-libs/gst-plugins-bad-0.10.10"
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.11.5 )
+ dev-util/pkgconfig"
+
+DOCS="AUTHORS README RELEASE"
+
+src_compile() {
+ # gst doesnt handle opts well, last tested with 0.10.15
+ strip-flags
+ replace-flags "-O3" "-O2"
+
+ gst-plugins-base_src_configure \
+ --disable-introspection \
+ $(use_enable nls)
+ emake || die "emake failed."
+}
+
+src_install() {
+ gnome2_src_install
+}