summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2010-07-03 00:16:01 +0000
committerMart Raudsepp <leio@gentoo.org>2010-07-03 00:16:01 +0000
commitb175d2d7bc630099b0657c87850a6e16c4f8d746 (patch)
tree84dca5d9a404ebe5aa0ac7aa1f8aa4c1f00dd6e4 /media-libs/gst-plugins-good
parentVersion bump (diff)
downloadgentoo-2-b175d2d7bc630099b0657c87850a6e16c4f8d746.tar.gz
gentoo-2-b175d2d7bc630099b0657c87850a6e16c4f8d746.tar.bz2
gentoo-2-b175d2d7bc630099b0657c87850a6e16c4f8d746.zip
Version bump, compatible with gst-plugins-base-0.10.29, fixing bug 326231. Huge amount of upstream improvements, some highlights: Many more color formats supported in various elements (alpha, alphacolor, videobox, videomixer, shapewipe) directly to avoid temporary conversions. Matroska and FLV demuxers: backwards playback support in pull mode. qtdemux: XMP parsing support, replaygain tag reading, etc
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/gst-plugins-good')
-rw-r--r--media-libs/gst-plugins-good/ChangeLog13
-rw-r--r--media-libs/gst-plugins-good/gst-plugins-good-0.10.22.ebuild65
2 files changed, 77 insertions, 1 deletions
diff --git a/media-libs/gst-plugins-good/ChangeLog b/media-libs/gst-plugins-good/ChangeLog
index c23748659095..d8f72b93730f 100644
--- a/media-libs/gst-plugins-good/ChangeLog
+++ b/media-libs/gst-plugins-good/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for media-libs/gst-plugins-good
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-good/ChangeLog,v 1.90 2010/07/01 11:34:29 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-good/ChangeLog,v 1.91 2010/07/03 00:16:01 leio Exp $
+
+*gst-plugins-good-0.10.22 (03 Jul 2010)
+
+ 03 Jul 2010; Mart Raudsepp <leio@gentoo.org>
+ +gst-plugins-good-0.10.22.ebuild:
+ Version bump, compatible with gst-plugins-base-0.10.29, fixing bug 326231
+ Huge amount of upstream improvements, some highlights:
+ Many more color formats supported in various elements (alpha, alphacolor,
+ videobox, videomixer, shapewipe) directly to avoid temporary conversions.
+ Matroska and FLV demuxers: backwards playback support in pull mode.
+ qtdemux: XMP parsing support, replaygain tag reading, etc
01 Jul 2010; Christian Faulhammer <fauli@gentoo.org>
gst-plugins-good-0.10.21.ebuild:
diff --git a/media-libs/gst-plugins-good/gst-plugins-good-0.10.22.ebuild b/media-libs/gst-plugins-good/gst-plugins-good-0.10.22.ebuild
new file mode 100644
index 000000000000..efd5674f1b31
--- /dev/null
+++ b/media-libs/gst-plugins-good/gst-plugins-good-0.10.22.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-good/gst-plugins-good-0.10.22.ebuild,v 1.1 2010/07/03 00:16:01 leio Exp $
+
+# order is important, gnome2 after gst-plugins
+inherit gst-plugins-good gst-plugins10 gnome2 eutils flag-o-matic libtool
+
+DESCRIPTION="Basepack of plugins for gstreamer"
+HOMEPAGE="http://gstreamer.net/"
+SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=media-libs/gst-plugins-base-0.10.29
+ >=media-libs/gstreamer-0.10.29
+ >=dev-libs/liboil-0.3.14
+ sys-libs/zlib
+ app-arch/bzip2"
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.11.5
+ dev-util/pkgconfig
+ !<media-libs/gst-plugins-bad-0.10.18"
+
+# Always enable optional bz2 support for matroska
+# Always enable optional zlib support for qtdemux, id3demux and matroska
+# Many media files require these to work, as some container headers are often compressed, bug 291154
+GST_PLUGINS_BUILD="bz2 zlib"
+
+src_compile() {
+ # gst doesnt handle optimisations well
+ strip-flags
+ replace-flags "-O3" "-O2"
+ filter-flags "-fprefetch-loop-arrays" # see bug 22249
+
+ gst-plugins-good_src_configure \
+ --with-default-audiosink=autoaudiosink \
+ --with-default-visualizer=goom
+
+ emake || die "emake failed."
+}
+
+# override eclass
+src_install() {
+ gnome2_src_install
+}
+
+DOCS="AUTHORS ChangeLog NEWS README RELEASE"
+
+pkg_postinst () {
+ gnome2_pkg_postinst
+
+ echo
+ elog "The Gstreamer plugins setup has changed quite a bit on Gentoo,"
+ elog "applications now should provide the basic plugins needed."
+ echo
+ elog "The new seperate plugins are all named 'gst-plugins-<plugin>'."
+ elog "To get a listing of currently available plugins execute 'emerge -s gst-plugins-'."
+ elog "In most cases it shouldn't be needed though to emerge extra plugins."
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+}