summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2003-02-18 20:17:54 +0000
committerMarinus Schraal <foser@gentoo.org>2003-02-18 20:17:54 +0000
commita98ff1aa711e97df741092be278bf75a961e97ea (patch)
treebf7bd551675868a5f1dc8cbc9bb271ed4790ff37 /media-libs/gst-plugins
parentcleanup (diff)
downloadgentoo-2-a98ff1aa711e97df741092be278bf75a961e97ea.tar.gz
gentoo-2-a98ff1aa711e97df741092be278bf75a961e97ea.tar.bz2
gentoo-2-a98ff1aa711e97df741092be278bf75a961e97ea.zip
added patch
Diffstat (limited to 'media-libs/gst-plugins')
-rw-r--r--media-libs/gst-plugins/ChangeLog7
-rw-r--r--media-libs/gst-plugins/files/digest-gst-plugins-0.6.0-r21
-rw-r--r--media-libs/gst-plugins/files/gst-plugins-0.6-ogg_detection_fix.patch39
-rw-r--r--media-libs/gst-plugins/gst-plugins-0.6.0-r2.ebuild140
4 files changed, 186 insertions, 1 deletions
diff --git a/media-libs/gst-plugins/ChangeLog b/media-libs/gst-plugins/ChangeLog
index f3a2b69c500e..5f1f53005c18 100644
--- a/media-libs/gst-plugins/ChangeLog
+++ b/media-libs/gst-plugins/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for media-libs/gst-plugins
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
# Distributed under the terms of the GNU General Public License, v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins/ChangeLog,v 1.24 2003/02/18 12:37:35 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins/ChangeLog,v 1.25 2003/02/18 20:17:54 foser Exp $
+
+*gst-plugins-0.6.0-r2 (18 Feb 2003)
+
+ 18 Feb 2003; foser <foser@gentoo.org> gst-plugins-0.6.0-r2.ebuild :
+ Added ogg detection fixing patch
*gst-plugins-0.6.0-r1 (06 Feb 2003)
diff --git a/media-libs/gst-plugins/files/digest-gst-plugins-0.6.0-r2 b/media-libs/gst-plugins/files/digest-gst-plugins-0.6.0-r2
new file mode 100644
index 000000000000..8195a933e515
--- /dev/null
+++ b/media-libs/gst-plugins/files/digest-gst-plugins-0.6.0-r2
@@ -0,0 +1 @@
+MD5 6548e5cde239dff066f1eb5b9f62fec5 gst-plugins-0.6.0.tar.bz2 1876447
diff --git a/media-libs/gst-plugins/files/gst-plugins-0.6-ogg_detection_fix.patch b/media-libs/gst-plugins/files/gst-plugins-0.6-ogg_detection_fix.patch
new file mode 100644
index 000000000000..b21f6faff4aa
--- /dev/null
+++ b/media-libs/gst-plugins/files/gst-plugins-0.6-ogg_detection_fix.patch
@@ -0,0 +1,39 @@
+diff -ur gst-plugins-0.6.0/ext/vorbis/vorbis.c gst-plugins-0.6.0.oggpatch/ext/vorbis/vorbis.c
+--- gst-plugins-0.6.0/ext/vorbis/vorbis.c 2002-10-30 21:30:58.000000000 +0100
++++ gst-plugins-0.6.0.oggpatch/ext/vorbis/vorbis.c 2003-02-18 17:52:43.000000000 +0100
+@@ -85,11 +85,31 @@
+ vorbis_type_find (GstBuffer *buf, gpointer private)
+ {
+ gulong head = GULONG_FROM_BE (*((gulong *)GST_BUFFER_DATA (buf)));
++ gint offset;
++ guint8 *data;
++ gint size;
++
++ data = GST_BUFFER_DATA (buf);
++ size = GST_BUFFER_SIZE (buf);
++
++ if (head == 0x4F676753) {
++ return gst_caps_new ("vorbis_type_find", "application/x-ogg", NULL);
++ } else {
++ /* checks for existance of vorbis identification header in case there's an ID3 tag */
++ for (offset = 0; offset < size-7; offset++) {
++ if ( data[offset] == 0x01 &&
++ data[offset+1] == 'v' &&
++ data[offset+2] == 'o' &&
++ data[offset+3] == 'r' &&
++ data[offset+4] == 'b' &&
++ data[offset+5] == 'i' &&
++ data[offset+6] == 's' ) {
++ return gst_caps_new ("vorbis_type_find", "application/x-ogg", NULL);
++ }
++ }
++ }
+
+- if (head != 0x4F676753)
+- return NULL;
+-
+- return gst_caps_new ("vorbis_type_find", "application/x-ogg", NULL);
++ return NULL;
+ }
+
+
diff --git a/media-libs/gst-plugins/gst-plugins-0.6.0-r2.ebuild b/media-libs/gst-plugins/gst-plugins-0.6.0-r2.ebuild
new file mode 100644
index 000000000000..a9ebf3691f2e
--- /dev/null
+++ b/media-libs/gst-plugins/gst-plugins-0.6.0-r2.ebuild
@@ -0,0 +1,140 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins/gst-plugins-0.6.0-r2.ebuild,v 1.1 2003/02/18 20:17:54 foser Exp $
+
+inherit eutils libtool gnome2 flag-o-matic
+
+# Create a major/minor combo for our SLOT and executables suffix
+PVP=($(echo " $PV " | sed 's:[-\._]: :g'))
+PV_MAJ_MIN=${PVP[0]}.${PVP[1]}
+
+IUSE="encode quicktime mpeg jpeg esd gnome mikmod sdl png alsa arts dvd aalib"
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Additional plugins for gstreamer - streaming media framework"
+HOMEPAGE="http://gstreamer.sourceforge.net"
+
+SLOT=${PV_MAJ_MIN}
+LICENSE="LGPL-2.1"
+KEYWORDS="~x86 ~sparc ~ppc"
+
+# required packages
+# there are many many optional libraries. features are compiled if the libraries
+# are present. most optional libraries are from gnome.
+DEPEND="=media-libs/gstreamer-${PV}*
+ >=gnome-base/gconf-1.2.0
+ media-sound/mad
+ media-libs/flac
+ media-sound/cdparanoia
+ media-libs/hermes
+ >=media-libs/libdv-0.9.5
+ media-libs/libvorbis
+ media-libs/libogg
+ encode? ( media-sound/lame )
+ quicktime? ( media-libs/openquicktime )
+ mpeg? ( >=media-libs/libmpeg2-0.3.1 )
+ jpeg? ( media-video/mjpegtools
+ mmx? ( >=media-libs/jpeg-mmx-1.1.2-r1 ) )
+ esd? ( media-sound/esound )
+ gnome? ( >=gnome-base/gnome-vfs-2.0.1 )
+ mikmod? ( media-libs/libmikmod )
+ sdl? ( media-libs/libsdl )
+ png? ( >=media-libs/libpng-1.2.3 )
+ alsa? ( >=media-libs/alsa-lib-0.9.0_rc2
+ virtual/jack )
+ arts? ( >=kde-base/arts-1.0.2 )
+ dvd? ( media-libs/libdvdnav )
+ aalib? ( media-libs/aalib )
+ media-libs/ladspa-sdk"
+
+# oggvorbis now is used by the cvs of ffmpeg
+# oggvorbis? ( media-libs/libvorbis
+# media-libs/libogg )
+
+
+src_unpack() {
+ unpack ${A}
+
+ # ffmpeg libs fix
+ epatch ${FILESDIR}/${PN}-${PV_MAJ_MIN}-ffmpeg_ldflags.patch
+
+ # ogg with id3 tag detection fix by <foser@gentoo.org>
+ epatch ${FILESDIR}/${PN}-${PV_MAJ_MIN}-ogg_detection_fix.patch
+
+ # fix the scripts
+ cd ${S}/tools
+ mv gst-launch-ext gst-launch-ext.old
+ sed -e "s:gst-launch :gst-launch-${PV_MAJ_MIN} :" \
+ -e "s:gst-launch-ext:gst-launch-ext-${PV_MAJ_MIN}:" gst-launch-ext.old > gst-launch-ext
+ chmod +x gst-launch-ext
+
+ mv gst-visualise gst-visualise.old
+ sed -e "s:gst-launch :gst-launch-${PV_MAJ_MIN} :" \
+ -e "s:gst-visualise:gst-visualise-${PV_MAJ_MIN}:" gst-visualise.old > gst-visualise
+ chmod +x gst-visualise
+}
+
+src_compile() {
+ elibtoolize
+
+ # gst doesnt handle optimisations well
+ strip-flags
+ replace-flags "-O3" "-O2"
+
+ local myconf=""
+
+ # FIXME : do this for _all_ IUSE flags
+# use avi \
+# && myconf="${myconf} --enable-avifile" \
+# || myconf="${myconf} --disable-avifile"
+ myconf="${myconf} --enable-avifile"
+ use aalib \
+ && myconf="${myconf} --enable-aalib" \
+ || myconf="${myconf} --disable-aalib"
+ use dvd \
+ && myconf="${myconf} --enable-dvdread --enable-dvdnav \
+ --enable-libdv" \
+ || myconf="${myconf} --disable-dvdread --disable-dvdnav \
+ --disable-libdv"
+ use esd \
+ && myconf="${myconf} --enable-esd --enable-esdtest" \
+ || myconf="${myconf} --disable-esd --disable-esdtest"
+ use gnome \
+ && myconf="${myconf} --enable-gnome_vfs" \
+ || myconf="${myconf} --disable-gnome_vfs"
+ use encode \
+ && myconf="${myconf} --enable-lame" \
+ || myconf="${myconf} --disable-lame"
+ use quicktime \
+ && myconf="${myconf} --enable-openquicktime" \
+ || myconf="${myconf} --disable-openquicktime"
+ use mpeg \
+ && myconf="${myconf} --enable-mpeg2dec" \
+ || myconf="${myconf} --disable-mpeg2dec"
+# use oggvorbis \
+# && myconf="${myconf} --enable-vorbis --enable-vorbistest" \
+# || myconf="${myconf} --disable-vorbis --disable-vorbistest"
+ myconf="${myconf} --enable-vorbis --enable-vorbistest"
+
+ # qcam doesn't work on PPC
+ use ppc && myconf="${myconf} --disable-qcam"
+
+ econf ${myconf} \
+ --program-suffix=-${PV_MAJ_MIN} \
+ || die "./configure failed"
+
+ emake || make || die
+}
+
+src_install () {
+ export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL="1"
+ make DESTDIR=${D} install || die
+ unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
+
+ dodoc AUTHORS COPYING INSTALL README RELEASE TODO
+}
+
+pkg_postinst () {
+ gnome2_gconf_install
+ gst-register-${PV_MAJ_MIN}
+}