summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-09-28 09:37:31 +0000
committerMike Frysinger <vapier@gentoo.org>2013-09-28 09:37:31 +0000
commit650ac2a8bb51979e5be99627339e7b5d0cb35882 (patch)
tree6a6cb0c1bc91196736a5c53e80fa6eff722f32f9 /media-libs/imlib2
parentAdd epatch_user. This fixes bug #478482. (diff)
downloadgentoo-2-650ac2a8bb51979e5be99627339e7b5d0cb35882.tar.gz
gentoo-2-650ac2a8bb51979e5be99627339e7b5d0cb35882.tar.bz2
gentoo-2-650ac2a8bb51979e5be99627339e7b5d0cb35882.zip
Clean up ebuild and merge live git version from E overlay.
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'media-libs/imlib2')
-rw-r--r--media-libs/imlib2/ChangeLog9
-rw-r--r--media-libs/imlib2/files/imlib2-1.4.4-libpng-1.5.patch82
-rw-r--r--media-libs/imlib2/imlib2-1.4.4.ebuild55
-rw-r--r--media-libs/imlib2/imlib2-1.4.5.ebuild33
-rw-r--r--media-libs/imlib2/imlib2-9999.ebuild70
-rw-r--r--media-libs/imlib2/metadata.xml4
6 files changed, 98 insertions, 155 deletions
diff --git a/media-libs/imlib2/ChangeLog b/media-libs/imlib2/ChangeLog
index c53a477a5bd0..22ea8380fbcb 100644
--- a/media-libs/imlib2/ChangeLog
+++ b/media-libs/imlib2/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/imlib2
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/imlib2/ChangeLog,v 1.116 2013/08/13 07:56:56 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/imlib2/ChangeLog,v 1.117 2013/09/28 09:37:31 vapier Exp $
+
+*imlib2-9999 (28 Sep 2013)
+
+ 28 Sep 2013; Mike Frysinger <vapier@gentoo.org> +imlib2-9999.ebuild,
+ -files/imlib2-1.4.4-libpng-1.5.patch, -imlib2-1.4.4.ebuild,
+ imlib2-1.4.5.ebuild, metadata.xml:
+ Clean up ebuild and merge live git version from E overlay.
13 Aug 2013; Samuli Suominen <ssuominen@gentoo.org> imlib2-1.4.4.ebuild,
imlib2-1.4.5.ebuild:
diff --git a/media-libs/imlib2/files/imlib2-1.4.4-libpng-1.5.patch b/media-libs/imlib2/files/imlib2-1.4.4-libpng-1.5.patch
deleted file mode 100644
index 069538ef657d..000000000000
--- a/media-libs/imlib2/files/imlib2-1.4.4-libpng-1.5.patch
+++ /dev/null
@@ -1,82 +0,0 @@
-http://bugs.gentoo.org/354989
-
-# http://sourceforge.net/mailarchive/message.php?msg_id=26972342
-
-$NetBSD: patch-af,v 1.4 2011/01/14 10:02:54 wiz Exp $
-
-Fix build with png-1.5.
-
-has also been committed upstream.
-
---- src/modules/loaders/loader_png.c
-+++ src/modules/loaders/loader_png.c
-@@ -58,7 +58,7 @@
- fclose(f);
- return 0;
- }
-- if (setjmp(png_ptr->jmpbuf))
-+ if (setjmp(png_jmpbuf(png_ptr)))
- {
- png_destroy_read_struct(&png_ptr, &info_ptr, NULL);
- fclose(f);
-@@ -238,7 +238,7 @@
- png_structp png_ptr;
- png_infop info_ptr;
- DATA32 *ptr;
-- int x, y, j;
-+ int x, y, j, interlace;
- png_bytep row_ptr, data = NULL;
- png_color_8 sig_bit;
- int pl = 0;
-@@ -265,7 +265,7 @@
- png_destroy_write_struct(&png_ptr, (png_infopp) NULL);
- return 0;
- }
-- if (setjmp(png_ptr->jmpbuf))
-+ if (setjmp(png_jmpbuf(png_ptr)))
- {
- fclose(f);
- png_destroy_write_struct(&png_ptr, (png_infopp) & info_ptr);
-@@ -274,11 +274,11 @@
- }
-
- /* check whether we should use interlacing */
-+ interlace = PNG_INTERLACE_NONE;
- if ((tag = __imlib_GetTag(im, "interlacing")) && tag->val)
- {
- #ifdef PNG_WRITE_INTERLACING_SUPPORTED
-- png_ptr->interlaced = PNG_INTERLACE_ADAM7;
-- num_passes = png_set_interlace_handling(png_ptr);
-+ interlace = PNG_INTERLACE_ADAM7;
- #endif
- }
-
-@@ -286,7 +286,7 @@
- if (im->flags & F_HAS_ALPHA)
- {
- png_set_IHDR(png_ptr, info_ptr, im->w, im->h, 8,
-- PNG_COLOR_TYPE_RGB_ALPHA, png_ptr->interlaced,
-+ PNG_COLOR_TYPE_RGB_ALPHA, interlace,
- PNG_COMPRESSION_TYPE_BASE, PNG_FILTER_TYPE_BASE);
- #ifdef WORDS_BIGENDIAN
- png_set_swap_alpha(png_ptr);
-@@ -297,7 +297,7 @@
- else
- {
- png_set_IHDR(png_ptr, info_ptr, im->w, im->h, 8, PNG_COLOR_TYPE_RGB,
-- png_ptr->interlaced, PNG_COMPRESSION_TYPE_BASE,
-+ interlace, PNG_COMPRESSION_TYPE_BASE,
- PNG_FILTER_TYPE_BASE);
- data = malloc(im->w * 3 * sizeof(char));
- }
-@@ -344,6 +344,10 @@
- png_set_shift(png_ptr, &sig_bit);
- png_set_packing(png_ptr);
-
-+#ifdef PNG_WRITE_INTERLACING_SUPPORTED
-+ num_passes = png_set_interlace_handling(png_ptr);
-+#endif
-+
- for (pass = 0; pass < num_passes; pass++)
- {
- ptr = im->data;
diff --git a/media-libs/imlib2/imlib2-1.4.4.ebuild b/media-libs/imlib2/imlib2-1.4.4.ebuild
deleted file mode 100644
index 25a2ab4405ea..000000000000
--- a/media-libs/imlib2/imlib2-1.4.4.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/imlib2/imlib2-1.4.4.ebuild,v 1.13 2013/08/13 07:56:56 ssuominen Exp $
-
-EAPI="2"
-
-inherit enlightenment toolchain-funcs
-
-MY_P=${P/_/-}
-DESCRIPTION="Version 2 of an advanced replacement library for libraries like libXpm"
-HOMEPAGE="http://www.enlightenment.org/"
-
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~x86-fbsd"
-IUSE="X bzip2 gif jpeg mmx mp3 png tiff zlib"
-
-RDEPEND="=media-libs/freetype-2*
- bzip2? ( app-arch/bzip2 )
- zlib? ( sys-libs/zlib )
- gif? ( >=media-libs/giflib-4.1.0 )
- png? ( >=media-libs/libpng-1.4:0 )
- jpeg? ( virtual/jpeg:0 )
- tiff? ( >=media-libs/tiff-3.5.5:0 )
- X? ( x11-libs/libXext x11-proto/xextproto )
- mp3? ( media-libs/libid3tag )"
-DEPEND="${RDEPEND}
- png? ( virtual/pkgconfig )"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-libpng-1.5.patch #354989
-}
-
-src_configure() {
- # imlib2 has diff configure options for x86/amd64 mmx
- local myconf=""
- if [[ $(tc-arch) == "amd64" ]] ; then
- myconf="$(use_enable mmx amd64) --disable-mmx"
- else
- myconf="--disable-amd64 $(use_enable mmx)"
- fi
-
- [[ $(gcc-major-version) -ge 4 ]] && myconf="${myconf} --enable-visibility-hiding"
-
- export MY_ECONF="
- $(use_with X x) \
- $(use_with jpeg) \
- $(use_with png) \
- $(use_with tiff) \
- $(use_with gif) \
- $(use_with zlib) \
- $(use_with bzip2) \
- $(use_with mp3 id3) \
- ${myconf} \
- "
- enlightenment_src_configure
-}
diff --git a/media-libs/imlib2/imlib2-1.4.5.ebuild b/media-libs/imlib2/imlib2-1.4.5.ebuild
index 83ab5a8738ba..b5b92ab7a985 100644
--- a/media-libs/imlib2/imlib2-1.4.5.ebuild
+++ b/media-libs/imlib2/imlib2-1.4.5.ebuild
@@ -1,15 +1,22 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/imlib2/imlib2-1.4.5.ebuild,v 1.10 2013/08/13 07:56:56 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/imlib2/imlib2-1.4.5.ebuild,v 1.11 2013/09/28 09:37:31 vapier Exp $
+
+EAPI="4"
+
+EGIT_SUB_PROJECT="legacy"
+EGIT_URI_APPEND=${PN}
+
+if [[ ${PV} != "9999" ]] ; then
+ EKEY_STATE="release"
+fi
-EAPI=4
inherit enlightenment toolchain-funcs
DESCRIPTION="Version 2 of an advanced replacement library for libraries like libXpm"
HOMEPAGE="http://www.enlightenment.org/"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~amd64-fbsd ~x86-fbsd"
-IUSE="X bzip2 gif jpeg mmx mp3 png static-libs tiff zlib"
+IUSE="bzip2 gif jpeg mmx mp3 png static-libs tiff X zlib"
RDEPEND="=media-libs/freetype-2*
bzip2? ( app-arch/bzip2 )
@@ -21,27 +28,26 @@ RDEPEND="=media-libs/freetype-2*
X? (
x11-libs/libX11
x11-libs/libXext
- )
+ )
mp3? ( media-libs/libid3tag )"
DEPEND="${RDEPEND}
png? ( virtual/pkgconfig )
X? (
x11-proto/xextproto
x11-proto/xproto
- )"
+ )"
src_configure() {
# imlib2 has diff configure options for x86/amd64 mmx
- local myconf
if [[ $(tc-arch) == amd64 ]]; then
- myconf="$(use_enable mmx amd64) --disable-mmx"
+ E_ECONF+=( $(use_enable mmx amd64) --disable-mmx )
else
- myconf="--disable-amd64 $(use_enable mmx)"
+ E_ECONF+=( --disable-amd64 $(use_enable mmx) )
fi
- [[ $(gcc-major-version) -ge 4 ]] && myconf="${myconf} --enable-visibility-hiding"
+ [[ $(gcc-major-version) -ge 4 ]] && E_ECONF+=( --enable-visibility-hiding )
- export MY_ECONF="
+ E_ECONF+=(
$(use_enable static-libs static)
$(use_with X x)
$(use_with jpeg)
@@ -51,8 +57,7 @@ src_configure() {
$(use_with zlib)
$(use_with bzip2)
$(use_with mp3 id3)
- ${myconf}
- "
+ )
enlightenment_src_configure
}
@@ -61,5 +66,5 @@ src_install() {
enlightenment_src_install
# enlightenment_src_install should take care of this for us, but it doesn't
- find "${ED}" -name '*.la' -exec rm -f {} +
+ find "${ED}" -name '*.la' -delete
}
diff --git a/media-libs/imlib2/imlib2-9999.ebuild b/media-libs/imlib2/imlib2-9999.ebuild
new file mode 100644
index 000000000000..4434dd7317d6
--- /dev/null
+++ b/media-libs/imlib2/imlib2-9999.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/imlib2/imlib2-9999.ebuild,v 1.18 2013/09/28 09:37:31 vapier Exp $
+
+EAPI="4"
+
+EGIT_SUB_PROJECT="legacy"
+EGIT_URI_APPEND=${PN}
+
+if [[ ${PV} != "9999" ]] ; then
+ EKEY_STATE="stable"
+fi
+
+inherit enlightenment toolchain-funcs
+
+DESCRIPTION="Version 2 of an advanced replacement library for libraries like libXpm"
+HOMEPAGE="http://www.enlightenment.org/"
+
+IUSE="bzip2 gif jpeg mmx mp3 png static-libs tiff X zlib"
+
+RDEPEND="=media-libs/freetype-2*
+ bzip2? ( app-arch/bzip2 )
+ zlib? ( sys-libs/zlib )
+ gif? ( >=media-libs/giflib-4.1.0 )
+ png? ( media-libs/libpng:0 )
+ jpeg? ( virtual/jpeg:0 )
+ tiff? ( media-libs/tiff:0 )
+ X? (
+ x11-libs/libX11
+ x11-libs/libXext
+ )
+ mp3? ( media-libs/libid3tag )"
+DEPEND="${RDEPEND}
+ png? ( virtual/pkgconfig )
+ X? (
+ x11-proto/xextproto
+ x11-proto/xproto
+ )"
+
+src_configure() {
+ # imlib2 has diff configure options for x86/amd64 mmx
+ if [[ $(tc-arch) == amd64 ]]; then
+ E_ECONF+=( $(use_enable mmx amd64) --disable-mmx )
+ else
+ E_ECONF+=( --disable-amd64 $(use_enable mmx) )
+ fi
+
+ [[ $(gcc-major-version) -ge 4 ]] && E_ECONF+=( --enable-visibility-hiding )
+
+ E_ECONF+=(
+ $(use_enable static-libs static)
+ $(use_with X x)
+ $(use_with jpeg)
+ $(use_with png)
+ $(use_with tiff)
+ $(use_with gif)
+ $(use_with zlib)
+ $(use_with bzip2)
+ $(use_with mp3 id3)
+ )
+
+ enlightenment_src_configure
+}
+
+src_install() {
+ enlightenment_src_install
+
+ # enlightenment_src_install should take care of this for us, but it doesn't
+ find "${ED}" -name '*.la' -delete
+}
diff --git a/media-libs/imlib2/metadata.xml b/media-libs/imlib2/metadata.xml
index d4d2cbb6fb49..0bf556b63f44 100644
--- a/media-libs/imlib2/metadata.xml
+++ b/media-libs/imlib2/metadata.xml
@@ -1,9 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer>
- <email>vapier@gentoo.org</email>
-</maintainer>
+<herd>enlightenment</herd>
<longdescription>
Imlib 2 is the successor to Imlib. It is not just a newer version - it is a
completely new library. Imlib2 can be installed alongside Imlib 1.x without any