summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2012-02-19 22:03:14 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2012-02-19 22:03:14 +0000
commitab57414fc251703f5b4785791b8bb29e4e24c001 (patch)
tree11035bb680fd4216c77830e2507e2bcbd283582e /media-libs/jbig2dec
parentRespect LINGUAS wrt bug 403647 by Piotr Szymaniak <szarpaj@grubelek.pl>. Drop... (diff)
downloadgentoo-2-ab57414fc251703f5b4785791b8bb29e4e24c001.tar.gz
gentoo-2-ab57414fc251703f5b4785791b8bb29e4e24c001.tar.bz2
gentoo-2-ab57414fc251703f5b4785791b8bb29e4e24c001.zip
Actually implement test phase... still fails though, bug 324275
(Portage version: 2.1.10.47/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/jbig2dec')
-rw-r--r--media-libs/jbig2dec/ChangeLog6
-rw-r--r--media-libs/jbig2dec/jbig2dec-0.11-r1.ebuild16
2 files changed, 16 insertions, 6 deletions
diff --git a/media-libs/jbig2dec/ChangeLog b/media-libs/jbig2dec/ChangeLog
index 57c43b440487..7f43b5b4e101 100644
--- a/media-libs/jbig2dec/ChangeLog
+++ b/media-libs/jbig2dec/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/jbig2dec
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/jbig2dec/ChangeLog,v 1.14 2012/02/16 18:51:37 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/jbig2dec/ChangeLog,v 1.15 2012/02/19 22:03:14 dilfridge Exp $
+
+ 19 Feb 2012; Andreas K. Huettel <dilfridge@gentoo.org>
+ jbig2dec-0.11-r1.ebuild:
+ Actually implement test phase... still fails though, bug 324275
16 Feb 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> jbig2dec-0.11-r1.ebuild:
x86 stable wrt bug #402907
diff --git a/media-libs/jbig2dec/jbig2dec-0.11-r1.ebuild b/media-libs/jbig2dec/jbig2dec-0.11-r1.ebuild
index 76895076bd3a..c4c42837b535 100644
--- a/media-libs/jbig2dec/jbig2dec-0.11-r1.ebuild
+++ b/media-libs/jbig2dec/jbig2dec-0.11-r1.ebuild
@@ -1,31 +1,37 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/jbig2dec/jbig2dec-0.11-r1.ebuild,v 1.4 2012/02/16 18:51:37 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/jbig2dec/jbig2dec-0.11-r1.ebuild,v 1.5 2012/02/19 22:03:14 dilfridge Exp $
EAPI=4
inherit autotools eutils
DESCRIPTION="A decoder implementation of the JBIG2 image compression format"
HOMEPAGE="http://jbig2dec.sourceforge.net/"
-SRC_URI="http://ghostscript.com/~giles/jbig2/${PN}/${P}.tar.gz"
+SRC_URI="http://ghostscript.com/~giles/jbig2/${PN}/${P}.tar.gz
+ test? ( http://jbig2dec.sourceforge.net/ubc/jb2streams.zip )"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="amd64 ~arm ~hppa ~ppc x86 ~x86-fbsd"
-IUSE="png static-libs"
+IUSE="png static-libs test"
RDEPEND="png? ( >=media-libs/libpng-1.2:0 )"
DEPEND="${RDEPEND}"
RESTRICT="test"
-#the test files are missing from the tarball, nothing is tested and the
-#test function just returns error. permanently restricted, see bug 324275
+# bug 324275
DOCS="CHANGES README"
src_prepare() {
epatch "${FILESDIR}"/${P}-libpng15.patch
eautoreconf
+
+ if use test; then
+ mkdir "${WORKDIR}/ubc" || die
+ mv -v "${WORKDIR}"/*.jb2 "${WORKDIR}/ubc/" || die
+ mv -v "${WORKDIR}"/*.bmp "${WORKDIR}/ubc/" || die
+ fi
}
src_configure() {