summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-08-06 13:48:59 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-08-06 13:48:59 +0000
commit40207f7a8384ab17b97088ee9aa463cae6727aaa (patch)
treed241cce0782ec9e1e0d4af9bcc9b4d309d2b8908 /media-libs/jpeg
parentMake USE flag descriptions more uniform, use imperative form throughout. (diff)
downloadgentoo-2-40207f7a8384ab17b97088ee9aa463cae6727aaa.tar.gz
gentoo-2-40207f7a8384ab17b97088ee9aa463cae6727aaa.tar.bz2
gentoo-2-40207f7a8384ab17b97088ee9aa463cae6727aaa.zip
TRUE & FALSE have to be undefined in order to define the boolean enum wrt #479808 by Stefan Fuchs. Thanks to Andrew Church for pointing me to correct direction.
(Portage version: 2.2.0_alpha191/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'media-libs/jpeg')
-rw-r--r--media-libs/jpeg/ChangeLog10
-rw-r--r--media-libs/jpeg/files/jpeg-9-fix-jmorecfg-boolean-enum.patch16
-rw-r--r--media-libs/jpeg/jpeg-9-r1.ebuild69
3 files changed, 94 insertions, 1 deletions
diff --git a/media-libs/jpeg/ChangeLog b/media-libs/jpeg/ChangeLog
index d49746e4f67b..4602749c94fc 100644
--- a/media-libs/jpeg/ChangeLog
+++ b/media-libs/jpeg/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-libs/jpeg
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/jpeg/ChangeLog,v 1.143 2013/08/01 20:41:55 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/jpeg/ChangeLog,v 1.144 2013/08/06 13:48:59 ssuominen Exp $
+
+*jpeg-9-r1 (06 Aug 2013)
+
+ 06 Aug 2013; Samuli Suominen <ssuominen@gentoo.org> +jpeg-9-r1.ebuild,
+ +files/jpeg-9-fix-jmorecfg-boolean-enum.patch:
+ TRUE & FALSE have to be undefined in order to define the boolean enum wrt
+ #479808 by Stefan Fuchs. Thanks to Andrew Church for pointing me to correct
+ direction.
01 Aug 2013; Samuli Suominen <ssuominen@gentoo.org> -jpeg-6b-r10.ebuild,
-jpeg-8d-r1.ebuild:
diff --git a/media-libs/jpeg/files/jpeg-9-fix-jmorecfg-boolean-enum.patch b/media-libs/jpeg/files/jpeg-9-fix-jmorecfg-boolean-enum.patch
new file mode 100644
index 000000000000..dcac126f2657
--- /dev/null
+++ b/media-libs/jpeg/files/jpeg-9-fix-jmorecfg-boolean-enum.patch
@@ -0,0 +1,16 @@
+http://bugs.gentoo.org/479808
+http://lists.linuxtogo.org/pipermail/openembedded-core/2013-February/036049.html
+
+TRUE & FALSE have to be undefined in order to define the boolean enum
+
+--- jmorecfg.h
++++ jmorecfg.h
+@@ -260,6 +260,8 @@ typedef void noreturn_t;
+ #define TRUE 1
+ #endif
+ #else
++#undef TRUE
++#undef FALSE
+ typedef enum { FALSE = 0, TRUE = 1 } boolean;
+ #endif
+
diff --git a/media-libs/jpeg/jpeg-9-r1.ebuild b/media-libs/jpeg/jpeg-9-r1.ebuild
new file mode 100644
index 000000000000..1ce4ab8e18f0
--- /dev/null
+++ b/media-libs/jpeg/jpeg-9-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/jpeg/jpeg-9-r1.ebuild,v 1.1 2013/08/06 13:48:59 ssuominen Exp $
+
+EAPI=5
+inherit eutils libtool toolchain-funcs multilib-minimal
+
+DESCRIPTION="Library to load, handle and manipulate images in the JPEG format"
+HOMEPAGE="http://jpegclub.org/ http://www.ijg.org/"
+SRC_URI="http://www.ijg.org/files/${PN}src.v${PV}.tar.gz
+ mirror://debian/pool/main/libj/lib${PN}8/lib${PN}8_8d-1.debian.tar.gz"
+
+LICENSE="IJG"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="static-libs"
+
+RDEPEND="!media-libs/libjpeg-turbo:0
+ abi_x86_32? ( !<=app-emulation/emul-linux-x86-baselibs-20130224-r5
+ !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)] )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-7-maxmem_sysconf.patch \
+ "${FILESDIR}"/${P}-fix-jmorecfg-boolean-enum.patch
+ elibtoolize
+}
+
+multilib_src_configure() {
+ # Fix building against this library on eg. Solaris and DragonFly BSD, see:
+ # http://mail-index.netbsd.org/pkgsrc-bugs/2010/01/18/msg035644.html
+ local ldverscript=
+ [[ ${CHOST} == *-solaris* ]] && ldverscript="--disable-ld-version-script"
+
+ ECONF_SOURCE=${S} \
+ econf \
+ $(use_enable static-libs static) \
+ --enable-maxmem=64 \
+ ${ldverscript}
+}
+
+multilib_src_compile() {
+ emake
+
+ if [[ ${ABI} == ${DEFAULT_ABI} ]]; then
+ # Build exifautotran and jpegexiforient
+ cd ../debian/extra
+ emake CC="$(tc-getCC)" CFLAGS="${LDFLAGS} ${CFLAGS}"
+ fi
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+}
+
+multilib_src_install_all() {
+ prune_libtool_files
+
+ dodoc change.log example.c README *.txt
+
+ # Install exifautotran and jpegexiforient
+ newdoc ../debian/changelog changelog.debian
+ cd ../debian/extra
+ emake \
+ DESTDIR="${D}" prefix="${EPREFIX}"/usr \
+ INSTALL="install -m755" INSTALLDIR="install -d -m755" \
+ install
+}