summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-03-09 15:11:59 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-03-09 15:11:59 +0000
commit471ad1b707e01d68ad7443b5a53e5e7555fd6c5b (patch)
treedd29bde2e22407f37de2df61182a40bf1290434e /media-libs/libcdr
parentMarking gnutls-2.12.16 ~ppc64 for bug 402959 (diff)
downloadgentoo-2-471ad1b707e01d68ad7443b5a53e5e7555fd6c5b.tar.gz
gentoo-2-471ad1b707e01d68ad7443b5a53e5e7555fd6c5b.tar.bz2
gentoo-2-471ad1b707e01d68ad7443b5a53e5e7555fd6c5b.zip
Add some release as i forgot to do this.
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/libcdr')
-rw-r--r--media-libs/libcdr/ChangeLog7
-rw-r--r--media-libs/libcdr/libcdr-0.0.4.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/media-libs/libcdr/ChangeLog b/media-libs/libcdr/ChangeLog
index 5117112c061d..3fe77ea67dd0 100644
--- a/media-libs/libcdr/ChangeLog
+++ b/media-libs/libcdr/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/libcdr
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libcdr/ChangeLog,v 1.3 2012/02/27 21:42:16 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libcdr/ChangeLog,v 1.4 2012/03/09 15:11:59 scarabeus Exp $
+
+*libcdr-0.0.4 (09 Mar 2012)
+
+ 09 Mar 2012; Tomáš Chvátal <scarabeus@gentoo.org> +libcdr-0.0.4.ebuild:
+ Add some release as i forgot to do this.
27 Feb 2012; Tomáš Chvátal <scarabeus@gentoo.org> libcdr-9999.ebuild:
Use actual slot.
diff --git a/media-libs/libcdr/libcdr-0.0.4.ebuild b/media-libs/libcdr/libcdr-0.0.4.ebuild
new file mode 100644
index 000000000000..c08e40efde88
--- /dev/null
+++ b/media-libs/libcdr/libcdr-0.0.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libcdr/libcdr-0.0.4.ebuild,v 1.1 2012/03/09 15:11:59 scarabeus Exp $
+
+EAPI=4
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/libreoffice/libcdr/"
+[[ ${PV} == 9999 ]] && vcs="autotools git-2"
+inherit base ${vcs}
+unset vcs
+
+DESCRIPTION="Library parsing the Corel cdr documents"
+HOMEPAGE="http://cgit.freedesktop.org/libreoffice/libcdr/tree/"
+[[ ${PV} == 9999 ]] || SRC_URI="http://dev-www.libreoffice.org/src/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+[[ ${PV} == 9999 ]] || KEYWORDS="~amd64 ~x86"
+IUSE="doc static-libs"
+
+RDEPEND="
+ app-text/libwpd:0.9
+ app-text/libwpg:0.2
+ media-libs/lcms:2
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/libtool
+ doc? ( app-doc/doxygen )
+"
+
+src_prepare() {
+ base_src_prepare
+ [[ -d m4 ]] || mkdir "m4"
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ --disable-werror \
+ $(use_with doc docs)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}