summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-06-18 09:07:25 +0000
committerJustin Lecher <jlec@gentoo.org>2010-06-18 09:07:25 +0000
commit3809e8c611e0bf66c7a4780357a2a046e60b2ac9 (patch)
tree18d34d914f2583dff107fc36272eb16e2285984a /media-libs/libchamplain/libchamplain-0.6.0.ebuild
parentCVS snapshot for e.g. KDE 4 and gvfs support. (diff)
downloadgentoo-2-3809e8c611e0bf66c7a4780357a2a046e60b2ac9.tar.gz
gentoo-2-3809e8c611e0bf66c7a4780357a2a046e60b2ac9.tar.bz2
gentoo-2-3809e8c611e0bf66c7a4780357a2a046e60b2ac9.zip
New Addition, #238423
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/libchamplain/libchamplain-0.6.0.ebuild')
-rw-r--r--media-libs/libchamplain/libchamplain-0.6.0.ebuild82
1 files changed, 82 insertions, 0 deletions
diff --git a/media-libs/libchamplain/libchamplain-0.6.0.ebuild b/media-libs/libchamplain/libchamplain-0.6.0.ebuild
new file mode 100644
index 000000000000..56d4b22a5b81
--- /dev/null
+++ b/media-libs/libchamplain/libchamplain-0.6.0.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libchamplain/libchamplain-0.6.0.ebuild,v 1.1 2010/06/18 09:07:25 jlec Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="python? 2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit gnome2 python
+
+DESCRIPTION="Clutter based world map renderer"
+HOMEPAGE="http://blog.pierlux.com/projects/libchamplain/en/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc gtk introspection python"
+
+RDEPEND="
+ >=dev-libs/glib-2.16
+ >=x11-libs/cairo-1.4
+ >=net-libs/libsoup-2.26[gnome]
+ media-libs/clutter:1.0
+ media-libs/memphis
+ dev-db/sqlite:3
+ gtk? (
+ >=x11-libs/gtk+-2.18
+ media-libs/memphis:0.2
+ >=media-libs/clutter-gtk-0.10:1.0 )
+ python? (
+ dev-python/pyclutter
+ dev-python/pyclutter-gtk )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1.9 )
+ introspection? ( >=dev-libs/gobject-introspection-0.6.3 )"
+
+RESTRICT_PYTHON_ABIS="3.*"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+G2CONF="${G2CONF}
+ --disable-static
+ --enable-memphis
+ $(use_enable debug)
+ $(use_enable gtk)
+ $(use_enable introspection)
+ $(use_enable python)"
+
+src_prepare() {
+ gnome2_src_prepare
+ sed 's:bindings::g' -i Makefile.in || die
+}
+
+src_compile() {
+ gnome2_src_compile
+ if use python; then
+ python_copy_sources bindings
+ building() {
+ emake \
+ PYTHON_INCLUDES="-I$(python_get_includedir)" \
+ pythondir="$(python_get_sitedir)" \
+ pyexecdir="$(python_get_sitedir)"
+ }
+ python_execute_function -s --source-dir bindings building
+ fi
+}
+
+src_install() {
+ gnome2_src_install
+ if use python; then
+ installation() {
+ emake DESTDIR="${ED}" \
+ pythondir="$(python_get_sitedir)" \
+ pyexecdir="$(python_get_sitedir)" \
+ install
+ }
+ python_execute_function -s --source-dir bindings installation
+ python_clean_installation_image
+ fi
+}