summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-06-13 22:18:00 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-06-13 22:18:00 +0000
commitfd49bfa5b2321ac77a9645091b909c45baf63ba1 (patch)
tree90c9c8433d446e56fea12867e30e676a1e8178f1 /media-libs/libdca
parent Fix .desktop entry stuff properly, get rid of the seemingly improper patch f... (diff)
downloadgentoo-2-fd49bfa5b2321ac77a9645091b909c45baf63ba1.tar.gz
gentoo-2-fd49bfa5b2321ac77a9645091b909c45baf63ba1.tar.bz2
gentoo-2-fd49bfa5b2321ac77a9645091b909c45baf63ba1.zip
Don't build tests and examples which aren't installed anyway wrt bug 226341.
(Portage version: 2.1.5.5)
Diffstat (limited to 'media-libs/libdca')
-rw-r--r--media-libs/libdca/ChangeLog11
-rw-r--r--media-libs/libdca/files/libdca-0.0.5-tests-optional.patch37
-rw-r--r--media-libs/libdca/libdca-0.0.5-r1.ebuild40
3 files changed, 86 insertions, 2 deletions
diff --git a/media-libs/libdca/ChangeLog b/media-libs/libdca/ChangeLog
index faa39a43f03f..dd740876db63 100644
--- a/media-libs/libdca/ChangeLog
+++ b/media-libs/libdca/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/libdca
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libdca/ChangeLog,v 1.18 2007/11/03 10:57:07 drac Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libdca/ChangeLog,v 1.19 2008/06/13 22:17:59 loki_val Exp $
+
+*libdca-0.0.5-r1 (13 Jun 2008)
+
+ 13 Jun 2008; Peter Alfredsen <loki_val@gentoo.org>
+ +files/libdca-0.0.5-tests-optional.patch, +libdca-0.0.5-r1.ebuild:
+ Don't build tests and examples which aren't installed anyway wrt bug
+ 226341.
03 Nov 2007; Samuli Suominen <drac@gentoo.org> libdca-0.0.5.ebuild:
Stable arm wrt #192579.
diff --git a/media-libs/libdca/files/libdca-0.0.5-tests-optional.patch b/media-libs/libdca/files/libdca-0.0.5-tests-optional.patch
new file mode 100644
index 000000000000..0f52ac6f5c30
--- /dev/null
+++ b/media-libs/libdca/files/libdca-0.0.5-tests-optional.patch
@@ -0,0 +1,37 @@
+diff -NrU5 libdca-0.0.5.orig/configure.ac libdca-0.0.5/configure.ac
+--- libdca-0.0.5.orig/configure.ac 2008-06-13 23:54:27.000000000 +0200
++++ libdca-0.0.5/configure.ac 2008-06-13 23:55:58.000000000 +0200
+@@ -75,10 +75,17 @@
+ TRY_CFLAGS="$OPT_CFLAGS -xCC -fast -xO5"
+ AC_TRY_CFLAGS([$TRY_CFLAGS $CFLAGS],[OPT_CFLAGS=$TRY_CFLAGS]);;
+ esac
+ fi
+
++dnl Build tests?
++AC_ARG_ENABLE(tests,
++ AS_HELP_STRING([--disable-tests], [Don't build tests during make]),,
++ enable_tests="yes")
++AM_CONDITIONAL(TESTS, [test "$enable_tests" = "yes"])
++
++
+ # dnl Checks for libtool - this must be done after we set cflags
+ # AC_LIBTOOL_WIN32_DLL
+ m4_undefine([AC_PROG_CXX])
+ m4_defun([AC_PROG_CXX],[])
+ m4_undefine([AC_PROG_F77])
+diff -NrU5 libdca-0.0.5.orig/test/Makefile.am libdca-0.0.5/test/Makefile.am
+--- libdca-0.0.5.orig/test/Makefile.am 2008-06-13 23:54:27.000000000 +0200
++++ libdca-0.0.5/test/Makefile.am 2008-06-13 23:54:46.000000000 +0200
+@@ -1,10 +1,12 @@
++if TESTS
+ AM_CFLAGS = $(DCADEC_CFLAGS)
+
+ noinst_PROGRAMS = compare
+ compare_SOURCES = compare.c
+ compare_LDADD = $(COMPARE_LIBS)
+
+ dist_check_SCRIPTS = regression compile globals
+ EXTRA_DIST = tests
+ TESTS = regression compile
+ #broken test: globals
++endif
diff --git a/media-libs/libdca/libdca-0.0.5-r1.ebuild b/media-libs/libdca/libdca-0.0.5-r1.ebuild
new file mode 100644
index 000000000000..77e9e9e1e3d6
--- /dev/null
+++ b/media-libs/libdca/libdca-0.0.5-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libdca/libdca-0.0.5-r1.ebuild,v 1.1 2008/06/13 22:17:59 loki_val Exp $
+
+inherit eutils toolchain-funcs autotools base
+
+DESCRIPTION="library for decoding DTS Coherent Acoustics streams used in DVD"
+HOMEPAGE="http://www.videolan.org/developers/libdca.html"
+SRC_URI="http://www.videolan.org/pub/videolan/${PN}/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="oss debug test"
+
+RDEPEND="!media-libs/libdts"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO doc/${PN}.txt"
+
+PATCHES=( "${FILESDIR}"/${P}-cflags.patch
+ "${FILESDIR}"/${P}-tests-optional.patch )
+
+src_unpack() {
+ base_src_unpack
+ cd "${S}"
+ eautoreconf
+}
+
+src_compile() {
+ econf $(use_enable oss) \
+ $(use_enable debug) \
+ $(use_enable test tests)
+
+ emake OPT_CFLAGS="" || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS README TODO doc/${PN}.txt
+}