summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2005-12-13 11:58:53 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2005-12-13 11:58:53 +0000
commit3f0d776dd38dbb9f753cbb58eeec76d3ae335f24 (patch)
tree5e19b055fc3132da8896d1995fee1bc9e9240ae7 /media-libs/libdvbpsi/libdvbpsi-0.1.5.ebuild
parentDependency cleanup (diff)
downloadgentoo-2-3f0d776dd38dbb9f753cbb58eeec76d3ae335f24.tar.gz
gentoo-2-3f0d776dd38dbb9f753cbb58eeec76d3ae335f24.tar.bz2
gentoo-2-3f0d776dd38dbb9f753cbb58eeec76d3ae335f24.zip
Version bumped, see Bug #105449, thanks to Jesse Adelman <jesse@boldandbusted.com>, added herd media-tv
(Portage version: 2.0.53)
Diffstat (limited to 'media-libs/libdvbpsi/libdvbpsi-0.1.5.ebuild')
-rw-r--r--media-libs/libdvbpsi/libdvbpsi-0.1.5.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-libs/libdvbpsi/libdvbpsi-0.1.5.ebuild b/media-libs/libdvbpsi/libdvbpsi-0.1.5.ebuild
new file mode 100644
index 000000000000..92d328d8a3b2
--- /dev/null
+++ b/media-libs/libdvbpsi/libdvbpsi-0.1.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libdvbpsi/libdvbpsi-0.1.5.ebuild,v 1.1 2005/12/13 11:58:53 zzam Exp $
+
+IUSE="doc"
+
+MY_P=${PN}4-${PV}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="library for MPEG TS/DVB PSI tables decoding and generation"
+HOMEPAGE="http://www.videolan.org/libdvbpsi"
+SRC_URI="http://download.videolan.org/pub/${PN}/${PV}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+# doxygen missing: ~ia64
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+DEPEND="doc? ( >=app-doc/doxygen-1.2.16 )"
+
+src_compile() {
+ econf --enable-release || die "econf failed"
+
+ emake || die "emake failed"
+
+ use doc && ewarn "Attempting to build documentation"
+ use doc && make doc || ewarn "Documentation was not built"
+}
+
+src_install () {
+ einstall || die "einstall failed"
+
+ use doc && dohtml ${S}/doc/doxygen/html/*
+
+ cd ${S}
+ dodoc AUTHORS INSTALL README NEWS
+}