summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-08-11 16:29:45 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-08-11 16:29:45 +0000
commit16bdb7c8962da247292848e10f26b5bdff659488 (patch)
tree457dc7f409e1c95bea4c0ff98309e544e0b8bfca /media-libs/libfame
parentAdd compatibility to latest cuda compiler; respect LDFLAGS (diff)
downloadgentoo-2-16bdb7c8962da247292848e10f26b5bdff659488.tar.gz
gentoo-2-16bdb7c8962da247292848e10f26b5bdff659488.tar.bz2
gentoo-2-16bdb7c8962da247292848e10f26b5bdff659488.zip
Convert to multilib. autoreconf it so that it honours ldflags. Port patches to configure to configure.in.
(Portage version: 2.2.0_alpha196/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-libs/libfame')
-rw-r--r--media-libs/libfame/ChangeLog11
-rw-r--r--media-libs/libfame/files/libfame-0.9.1-mmx-configure.ac.patch20
-rw-r--r--media-libs/libfame/libfame-0.9.1-r2.ebuild44
3 files changed, 73 insertions, 2 deletions
diff --git a/media-libs/libfame/ChangeLog b/media-libs/libfame/ChangeLog
index cf4e293a1c98..036c13c9bcfb 100644
--- a/media-libs/libfame/ChangeLog
+++ b/media-libs/libfame/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/libfame
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libfame/ChangeLog,v 1.56 2011/11/28 03:26:54 radhermit Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libfame/ChangeLog,v 1.57 2013/08/11 16:29:45 aballier Exp $
+
+*libfame-0.9.1-r2 (11 Aug 2013)
+
+ 11 Aug 2013; Alexis Ballier <aballier@gentoo.org> +libfame-0.9.1-r2.ebuild,
+ +files/libfame-0.9.1-mmx-configure.ac.patch:
+ Convert to multilib. autoreconf it so that it honours ldflags. Port patches
+ to configure to configure.in.
28 Nov 2011; Tim Harder <radhermit@gentoo.org> libfame-0.9.1-r1.ebuild:
Fix autotools-utils usage (bug #392147).
diff --git a/media-libs/libfame/files/libfame-0.9.1-mmx-configure.ac.patch b/media-libs/libfame/files/libfame-0.9.1-mmx-configure.ac.patch
new file mode 100644
index 000000000000..ff4e7327ce2f
--- /dev/null
+++ b/media-libs/libfame/files/libfame-0.9.1-mmx-configure.ac.patch
@@ -0,0 +1,20 @@
+Index: libfame-0.9.1/configure.in
+===================================================================
+--- libfame-0.9.1.orig/configure.in
++++ libfame-0.9.1/configure.in
+@@ -101,12 +101,9 @@ if test x$ac_cv_prog_gcc = xyes; then
+ CFLAGS="$CFLAGS -Wall -fexpensive-optimizations -funroll-loops -ffast-math"
+
+ dnl -fstrict-aliasing doesn't seem to be supported by gcc < 2.95
+- gcc_major_version=`$CC --version | \
+- sed -e 's,[[^0-9.]],,g' -e 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\1/'`
+- gcc_minor_version=`$CC --version | \
+- sed -e 's,[[^0-9.]],,g' -e 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\2/'`
+- gcc_micro_version=`$CC --version | \
+- sed -e 's,[[^0-9.]],,g' -e 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\3/'`
++ gcc_major_version=`${CC} -dumpversion | cut -f1 -d.`
++ gcc_minor_version=`${CC} -dumpversion | cut -f2 -d.`
++ gcc_micro_version=`${CC} -dumpversion | cut -f3 -d.`
+
+ dnl ok, I must admit I don't know how to do or/and ;)
+ if test $gcc_major_version -eq 2; then
diff --git a/media-libs/libfame/libfame-0.9.1-r2.ebuild b/media-libs/libfame/libfame-0.9.1-r2.ebuild
new file mode 100644
index 000000000000..0d66ef6575c4
--- /dev/null
+++ b/media-libs/libfame/libfame-0.9.1-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libfame/libfame-0.9.1-r2.ebuild,v 1.1 2013/08/11 16:29:45 aballier Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+
+inherit autotools-multilib
+
+PATCHLEVEL="2"
+DESCRIPTION="MPEG-1 and MPEG-4 video encoding library"
+HOMEPAGE="http://fame.sourceforge.net/"
+SRC_URI="mirror://sourceforge/fame/${P}.tar.gz
+ http://digilander.libero.it/dgp85/gentoo/${PN}-patches-${PATCHLEVEL}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="mmx static-libs"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc43.patch
+ "${FILESDIR}"/${P}-mmx-configure.ac.patch )
+
+DOCS=( AUTHORS BUGS CHANGES README TODO )
+
+src_prepare() {
+ EPATCH_SUFFIX="patch" epatch "${WORKDIR}"/${PV}
+
+ # Do not add -march=i586, bug #41770.
+ sed -i -e 's:-march=i[345]86 ::g' configure.in || die
+
+ rm -f acinclude.m4
+
+ autotools-multilib_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable mmx)
+ )
+ autotools-multilib_src_configure
+}