summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2005-01-23 23:44:41 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2005-01-23 23:44:41 +0000
commit82718ec95f03be1dc6f828d31f8e4bc1b1e1089f (patch)
tree99208bbb278ebfb7069edb1b16d3b23abbc4a1f5 /media-libs/libopendaap
parentFix bug #79216. (diff)
downloadgentoo-2-82718ec95f03be1dc6f828d31f8e4bc1b1e1089f.tar.gz
gentoo-2-82718ec95f03be1dc6f828d31f8e4bc1b1e1089f.tar.bz2
gentoo-2-82718ec95f03be1dc6f828d31f8e4bc1b1e1089f.zip
Correcting types in typedef to be int instead of long.
(Portage version: 2.0.51-r14)
Diffstat (limited to 'media-libs/libopendaap')
-rw-r--r--media-libs/libopendaap/ChangeLog6
-rw-r--r--media-libs/libopendaap/files/libopendaap-0.3.0-types.h13
-rw-r--r--media-libs/libopendaap/libopendaap-0.3.0.ebuild8
3 files changed, 25 insertions, 2 deletions
diff --git a/media-libs/libopendaap/ChangeLog b/media-libs/libopendaap/ChangeLog
index 61870f0720a6..ee4c51039618 100644
--- a/media-libs/libopendaap/ChangeLog
+++ b/media-libs/libopendaap/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/libopendaap
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libopendaap/ChangeLog,v 1.7 2005/01/22 15:58:37 dsd Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libopendaap/ChangeLog,v 1.8 2005/01/23 23:44:41 eradicator Exp $
+
+ 23 Jan 2005; Jeremy Huddleston <eradicator@gentoo.org>
+ +files/libopendaap-0.3.0-types.h, libopendaap-0.3.0.ebuild:
+ Correcting types in typedef to be int instead of long.
*libopendaap-0.3.0 (22 Jan 2005)
diff --git a/media-libs/libopendaap/files/libopendaap-0.3.0-types.h b/media-libs/libopendaap/files/libopendaap-0.3.0-types.h
new file mode 100644
index 000000000000..6973f136d0e0
--- /dev/null
+++ b/media-libs/libopendaap/files/libopendaap-0.3.0-types.h
@@ -0,0 +1,13 @@
+--- libopendaap-0.3.0/mDNS/mDNSClientAPI.h.orig 2005-01-23 15:39:04.834290477 -0800
++++ libopendaap-0.3.0/mDNS/mDNSClientAPI.h 2005-01-23 15:39:41.512250333 -0800
+@@ -483,8 +483,8 @@
+ typedef unsigned char mDNSu8;
+ typedef signed short mDNSs16;
+ typedef unsigned short mDNSu16;
+-typedef signed long mDNSs32;
+-typedef unsigned long mDNSu32;
++typedef signed int mDNSs32;
++typedef unsigned int mDNSu32;
+
+ // To enforce useful type checking, we make mDNSInterfaceID be a pointer to a dummy struct
+ // This way, mDNSInterfaceIDs can be assigned, and compared with each other, but not with other types
diff --git a/media-libs/libopendaap/libopendaap-0.3.0.ebuild b/media-libs/libopendaap/libopendaap-0.3.0.ebuild
index f1439ee338d5..6b1b43990a90 100644
--- a/media-libs/libopendaap/libopendaap-0.3.0.ebuild
+++ b/media-libs/libopendaap/libopendaap-0.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libopendaap/libopendaap-0.3.0.ebuild,v 1.1 2005/01/22 15:58:37 dsd Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libopendaap/libopendaap-0.3.0.ebuild,v 1.2 2005/01/23 23:44:41 eradicator Exp $
IUSE=""
@@ -14,6 +14,12 @@ LICENSE="crazney APSL-2"
KEYWORDS="~amd64 ~x86 ~ppc"
DEPEND="virtual/libc"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-types.h
+}
+
src_install() {
make DESTDIR="${D}" install || die
dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README