summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-05-07 12:49:53 +0000
committerMichał Górny <mgorny@gentoo.org>2013-05-07 12:49:53 +0000
commita5d0b471aabb7a5501165d89460fa1accd6a66bb (patch)
treeaad0422bae09e8a4a07e529d9241f057f098690e /media-libs/libsamplerate
parentMask the next batch of multilib conversions. (diff)
downloadgentoo-2-a5d0b471aabb7a5501165d89460fa1accd6a66bb.tar.gz
gentoo-2-a5d0b471aabb7a5501165d89460fa1accd6a66bb.tar.bz2
gentoo-2-a5d0b471aabb7a5501165d89460fa1accd6a66bb.zip
Convert to multilib wrt bug #466670.
(Portage version: 2.2.0_alpha174/cvs/Linux x86_64, signed Manifest commit with key 9627F456F9DA7643!)
Diffstat (limited to 'media-libs/libsamplerate')
-rw-r--r--media-libs/libsamplerate/ChangeLog9
-rw-r--r--media-libs/libsamplerate/libsamplerate-0.1.8-r1.ebuild48
2 files changed, 55 insertions, 2 deletions
diff --git a/media-libs/libsamplerate/ChangeLog b/media-libs/libsamplerate/ChangeLog
index e6aa9d1bfe29..bb4f07242bd7 100644
--- a/media-libs/libsamplerate/ChangeLog
+++ b/media-libs/libsamplerate/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/libsamplerate
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsamplerate/ChangeLog,v 1.74 2012/05/29 13:29:27 aballier Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsamplerate/ChangeLog,v 1.75 2013/05/07 12:49:53 mgorny Exp $
+
+*libsamplerate-0.1.8-r1 (07 May 2013)
+
+ 07 May 2013; Michał Górny <mgorny@gentoo.org> +libsamplerate-0.1.8-r1.ebuild:
+ Convert to multilib wrt bug #466670.
29 May 2012; Alexis Ballier <aballier@gentoo.org> libsamplerate-0.1.8.ebuild:
keyword ~amd64-fbsd
diff --git a/media-libs/libsamplerate/libsamplerate-0.1.8-r1.ebuild b/media-libs/libsamplerate/libsamplerate-0.1.8-r1.ebuild
new file mode 100644
index 000000000000..172a601becc8
--- /dev/null
+++ b/media-libs/libsamplerate/libsamplerate-0.1.8-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsamplerate/libsamplerate-0.1.8-r1.ebuild,v 1.1 2013/05/07 12:49:53 mgorny Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
+inherit autotools-multilib
+
+DESCRIPTION="Secret Rabbit Code (aka libsamplerate) is a Sample Rate Converter for audio"
+HOMEPAGE="http://www.mega-nerd.com/SRC/"
+SRC_URI="http://www.mega-nerd.com/SRC/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="sndfile static-libs"
+
+RDEPEND="sndfile? ( >=media-libs/libsndfile-1.0.2[${MULTILIB_USEDEP}] )
+ abi_x86_32? ( !<=app-emultaion/emul-linux-x86-soundlibs-20130224 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_prepare() {
+ local PATCHES=(
+ "${FILESDIR}/${PN}-0.1.3-dontbuild-tests-examples.patch"
+ "${FILESDIR}/${P}-lm.patch"
+ )
+
+ AT_M4DIR="M4" \
+ autotools-multilib_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-fftw
+ $(use_enable sndfile)
+ )
+ autotools-multilib_src_configure
+}
+
+src_install() {
+ autotools-multilib_src_install \
+ htmldocdir="${EPREFIX}/usr/share/doc/${PF}/html"
+}