summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-09-20 17:35:37 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-09-20 17:35:37 +0000
commitc714a11e8cb91976bbae7b6d7cc6c5476021f0b2 (patch)
tree9c11f4f15d987fcee9cdb07682d76b8781429c60 /media-libs/libtiger
parentRevision bump to update the conf.d file installed. When an ebuild sets the pi... (diff)
downloadgentoo-2-c714a11e8cb91976bbae7b6d7cc6c5476021f0b2.tar.gz
gentoo-2-c714a11e8cb91976bbae7b6d7cc6c5476021f0b2.tar.bz2
gentoo-2-c714a11e8cb91976bbae7b6d7cc6c5476021f0b2.zip
Add patch from upstream to fix tests on arm
(Portage version: 2.2_rc41/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/libtiger')
-rw-r--r--media-libs/libtiger/ChangeLog6
-rw-r--r--media-libs/libtiger/files/libtiger-0.3.3-check.patch17
-rw-r--r--media-libs/libtiger/libtiger-0.3.3.ebuild5
3 files changed, 25 insertions, 3 deletions
diff --git a/media-libs/libtiger/ChangeLog b/media-libs/libtiger/ChangeLog
index 4e7a15f46682..8ec5fd626395 100644
--- a/media-libs/libtiger/ChangeLog
+++ b/media-libs/libtiger/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/libtiger
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libtiger/ChangeLog,v 1.7 2009/07/22 18:59:21 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libtiger/ChangeLog,v 1.8 2009/09/20 17:35:37 aballier Exp $
+
+ 20 Sep 2009; Alexis Ballier <aballier@gentoo.org> libtiger-0.3.3.ebuild,
+ +files/libtiger-0.3.3-check.patch:
+ Add patch from upstream to fix tests on arm
22 Jul 2009; <solar@gentoo.org> libtiger-0.3.3.ebuild:
- keyword ~arm
diff --git a/media-libs/libtiger/files/libtiger-0.3.3-check.patch b/media-libs/libtiger/files/libtiger-0.3.3-check.patch
new file mode 100644
index 000000000000..bcb32b683096
--- /dev/null
+++ b/media-libs/libtiger/files/libtiger-0.3.3-check.patch
@@ -0,0 +1,17 @@
+http://git.xiph.org/?p=users/oggk/tiger.git;a=commitdiff;h=3233686e501163f38cc28425827b901e258bfcc3
+fixes tests on eg arm.
+
+Index: libtiger-0.3.3/Makefile.in
+===================================================================
+--- libtiger-0.3.3.orig/Makefile.in
++++ libtiger-0.3.3/Makefile.in
+@@ -991,8 +991,7 @@ check-local:
+ @echo " Checking Tiger namespace"
+ @! @NM@ -B lib/.libs/*.a lib/.libs/*.so \
+ | $(GREP) "^[0-9a-z]\{8\} [A-MO-Z] [^\.]" \
+- | $(GREP) -vE " (_DYNAMIC|_init|_fini|_edata|_end|__bss_start)$$" \
+- | $(GREP) -vE " _(rest|save)[fg]pr_[0-9]*(|_x)$$" \
++ | $(GREP) -v "^.\{11\}_" \
+ | $(GREP) -v "^.\{11\}tiger_"
+ @echo " Checking memory allocation routines"
+ @! $(GREP) -EHn '[^_](malloc|realloc|free|calloc|memalign)\(' \
diff --git a/media-libs/libtiger/libtiger-0.3.3.ebuild b/media-libs/libtiger/libtiger-0.3.3.ebuild
index 2a652380d35f..8b5e8cc34629 100644
--- a/media-libs/libtiger/libtiger-0.3.3.ebuild
+++ b/media-libs/libtiger/libtiger-0.3.3.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libtiger/libtiger-0.3.3.ebuild,v 1.7 2009/07/22 18:59:21 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libtiger/libtiger-0.3.3.ebuild,v 1.8 2009/09/20 17:35:37 aballier Exp $
EAPI=2
-inherit libtool
+inherit libtool eutils
DESCRIPTION="A rendering library for Kate streams using Pango and Cairo"
HOMEPAGE="http://code.google.com/p/libtiger/"
@@ -23,6 +23,7 @@ DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )"
src_prepare() {
+ epatch "${FILESDIR}/${P}-check.patch"
elibtoolize
}