summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-02-25 08:07:47 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-02-25 08:07:47 +0000
commitd9b7d64ee9dd7840309da7cd64d5a3b7f8a26e83 (patch)
tree68082d8302ee9ae130af5f656b6644755c588005 /media-libs/libv4l
parentToday's python patches added (diff)
downloadgentoo-2-d9b7d64ee9dd7840309da7cd64d5a3b7f8a26e83.tar.gz
gentoo-2-d9b7d64ee9dd7840309da7cd64d5a3b7f8a26e83.tar.bz2
gentoo-2-d9b7d64ee9dd7840309da7cd64d5a3b7f8a26e83.zip
Version bump.
(Portage version: 2.2_rc63/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/libv4l')
-rw-r--r--media-libs/libv4l/ChangeLog7
-rw-r--r--media-libs/libv4l/libv4l-0.6.4.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/media-libs/libv4l/ChangeLog b/media-libs/libv4l/ChangeLog
index 5cce83bff143..81a53c923f70 100644
--- a/media-libs/libv4l/ChangeLog
+++ b/media-libs/libv4l/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/libv4l
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libv4l/ChangeLog,v 1.23 2010/02/24 19:30:19 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libv4l/ChangeLog,v 1.24 2010/02/25 08:07:47 ssuominen Exp $
+
+*libv4l-0.6.4 (25 Feb 2010)
+
+ 25 Feb 2010; Samuli Suominen <ssuominen@gentoo.org> +libv4l-0.6.4.ebuild:
+ Version bump.
24 Feb 2010; Raúl Porcel <armin76@gentoo.org> libv4l-0.5.3.ebuild,
libv4l-0.6.1.ebuild:
diff --git a/media-libs/libv4l/libv4l-0.6.4.ebuild b/media-libs/libv4l/libv4l-0.6.4.ebuild
new file mode 100644
index 000000000000..0b0710c1e506
--- /dev/null
+++ b/media-libs/libv4l/libv4l-0.6.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libv4l/libv4l-0.6.4.ebuild,v 1.1 2010/02/25 08:07:47 ssuominen Exp $
+
+EAPI=2
+inherit multilib toolchain-funcs
+
+DESCRIPTION="Collection of video4linux userspace libraries"
+HOMEPAGE="http://hansdegoede.livejournal.com/3636.html"
+SRC_URI="http://people.fedoraproject.org/~jwrdegoede/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+src_compile() {
+ tc-export CC
+ emake PREFIX="/usr" LIBDIR="/usr/$(get_libdir)" CFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ emake PREFIX="/usr" LIBDIR="/usr/$(get_libdir)" DESTDIR="${D}" \
+ install || die
+ dodoc ChangeLog README* TODO
+}
+
+pkg_postinst() {
+ elog
+ elog "libv4l includes wrapper libraries for compatibility and pixel format"
+ elog "conversion, which are especially useful for users of the gspca usb"
+ elog "webcam driver in kernel 2.6.27 and higher."
+ elog
+ elog "To add v4l2 compatibility to a v4l application 'myapp', launch it via"
+ elog "LD_PRELOAD=/usr/$(get_libdir)/libv4l/v4l1compat.so myapp"
+ elog "To add automatic pixel format conversion to a v4l2 application, use"
+ elog "LD_PRELOAD=/usr/$(get_libdir)/libv4l/v4l2convert.so myapp"
+ elog
+}