summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-08-09 18:13:21 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-08-09 18:13:21 +0000
commit780b81ce3a666f1eb0e38dd29c53df9e87f5af4d (patch)
tree6c5001f83627c914883dce5c6b7116d80593f4ef /media-libs/libvisio/libvisio-9999.ebuild
parentMarked ~ppc wrt #363625 (diff)
downloadgentoo-2-780b81ce3a666f1eb0e38dd29c53df9e87f5af4d.tar.gz
gentoo-2-780b81ce3a666f1eb0e38dd29c53df9e87f5af4d.tar.bz2
gentoo-2-780b81ce3a666f1eb0e38dd29c53df9e87f5af4d.zip
Initial commit of libvisio library used by libreoffice:3.5. Not for production yet.
(Portage version: 2.2.0_alpha50/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/libvisio/libvisio-9999.ebuild')
-rw-r--r--media-libs/libvisio/libvisio-9999.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/media-libs/libvisio/libvisio-9999.ebuild b/media-libs/libvisio/libvisio-9999.ebuild
new file mode 100644
index 000000000000..3312bdab4ef3
--- /dev/null
+++ b/media-libs/libvisio/libvisio-9999.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libvisio/libvisio-9999.ebuild,v 1.1 2011/08/09 18:13:21 scarabeus Exp $
+
+EAPI=4
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/libreoffice/contrib/libvisio/"
+[[ ${PV} == 9999 ]] && vcs=git-2
+inherit autotools ${vcs}
+unset vcs
+
+DESCRIPTION="Library parsing the visio documents"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/libvisio"
+[[ ${PV} == 9999 ]] || SRC_URI="http://cgit.freedesktop.org/libreoffice/contrib/${PN}/snapshot/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+[[ ${PV} == 9999 ]] || KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ app-text/libwpd:0.9
+ app-text/libwpg:0.2
+"
+DEPEND="${DEPEND}
+ sys-devel/libtool
+ doc? ( app-doc/doxygen )
+"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_with doc docs)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}