summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-09-21 20:35:58 +0000
committerTim Harder <radhermit@gentoo.org>2011-09-21 20:35:58 +0000
commit49098f45fed9a2928f0c48851a19e18d31f4d23f (patch)
tree0e5df3b31c34d476f68515919e3b2772321641f0 /media-libs/libvpx/libvpx-9999.ebuild
parentPrefer vim over gvim to reduce the size of emerge -e @system. (diff)
downloadgentoo-2-49098f45fed9a2928f0c48851a19e18d31f4d23f.tar.gz
gentoo-2-49098f45fed9a2928f0c48851a19e18d31f4d23f.tar.bz2
gentoo-2-49098f45fed9a2928f0c48851a19e18d31f4d23f.zip
Add static-libs support (bug #378307 by Agostino Sarubbo and Nikoli).
(Portage version: 2.2.0_alpha58/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/libvpx/libvpx-9999.ebuild')
-rw-r--r--media-libs/libvpx/libvpx-9999.ebuild20
1 files changed, 10 insertions, 10 deletions
diff --git a/media-libs/libvpx/libvpx-9999.ebuild b/media-libs/libvpx/libvpx-9999.ebuild
index 004575f825b8..15640373f95d 100644
--- a/media-libs/libvpx/libvpx-9999.ebuild
+++ b/media-libs/libvpx/libvpx-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libvpx/libvpx-9999.ebuild,v 1.15 2011/07/29 02:11:44 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libvpx/libvpx-9999.ebuild,v 1.16 2011/09/21 20:35:58 radhermit Exp $
EAPI=4
inherit multilib toolchain-funcs
@@ -22,7 +22,7 @@ HOMEPAGE="http://www.webmproject.org"
LICENSE="BSD"
SLOT="0"
-IUSE="altivec debug doc mmx postproc sse sse2 sse3 ssse3 sse4_1 +threads"
+IUSE="altivec debug doc mmx postproc sse sse2 sse3 ssse3 sse4_1 static-libs +threads"
RDEPEND=""
DEPEND="amd64? ( dev-lang/yasm )
@@ -47,22 +47,22 @@ src_configure() {
--enable-vp8 \
--enable-shared \
$(use_enable altivec) \
+ $(use_enable debug debug-libs) \
+ $(use_enable debug) \
+ $(use_enable doc install-docs) \
$(use_enable mmx) \
+ $(use_enable postproc) \
$(use_enable sse) \
$(use_enable sse2) \
$(use_enable sse3) \
- $(use_enable ssse3) \
$(use_enable sse4_1) \
- $(use_enable debug) \
- $(use_enable debug debug-libs) \
- $(use_enable doc install-docs) \
- $(use_enable postproc) \
+ $(use_enable ssse3) \
+ $(use_enable static-libs static ) \
$(use_enable threads multithread) \
|| die
}
src_install() {
- emake DESTDIR="${D}" install || die
-
- dodoc AUTHORS CHANGELOG README || die
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS CHANGELOG README
}