summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2012-02-10 18:44:38 +0000
committerMatt Turner <mattst88@gentoo.org>2012-02-10 18:44:38 +0000
commit5629bb050c242324ed8640cc2ec6aed20cb92356 (patch)
treefce087483a9665754effa05cf7fac11a8c5ca2cc /media-libs/mesa/files
parentSupport new windowmaker (small API update and function name collision) (diff)
downloadgentoo-2-5629bb050c242324ed8640cc2ec6aed20cb92356.tar.gz
gentoo-2-5629bb050c242324ed8640cc2ec6aed20cb92356.tar.bz2
gentoo-2-5629bb050c242324ed8640cc2ec6aed20cb92356.zip
Version bump.
(Portage version: 2.1.10.44/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'media-libs/mesa/files')
-rw-r--r--media-libs/mesa/files/eselect-mesa.conf.8.036
-rw-r--r--media-libs/mesa/files/mesa-8.0-dont-require-llvm-for-r300.patch27
2 files changed, 63 insertions, 0 deletions
diff --git a/media-libs/mesa/files/eselect-mesa.conf.8.0 b/media-libs/mesa/files/eselect-mesa.conf.8.0
new file mode 100644
index 000000000000..2fc99006df98
--- /dev/null
+++ b/media-libs/mesa/files/eselect-mesa.conf.8.0
@@ -0,0 +1,36 @@
+# mesa classic/gallium implementations in this release
+
+# Syntax description:
+# * MESA_IMPLEMENTATIONS contains a space-delimited list of switchable
+# classic/gallium implementations.
+# * MESA_DRIVERS is an associative array, for each member "foo" of
+# MESA_IMPLEMENTATIONS it contains the following elements:
+# foo,description - Human-readable description of the driver
+# foo,classicdriver - Filename of the classic driver
+# foo,galliumdriver - Filename of the gallium driver
+# foo,default - which of classic or gallium is chosen by default
+
+MESA_IMPLEMENTATIONS="i915 i965 r300 r600 sw"
+declare -A MESA_DRIVERS || die "MESA_DRIVERS already in environment and not associative."
+
+MESA_DRIVERS[i915,description]="i915 (Intel 915, 945)"
+MESA_DRIVERS[i915,classicdriver]="i915_dri.so"
+MESA_DRIVERS[i915,galliumdriver]="i915g_dri.so"
+MESA_DRIVERS[i915,default]="gallium"
+
+MESA_DRIVERS[i965,description]="i965 (Intel 965, G/Q3x, G/Q4x)"
+MESA_DRIVERS[i965,classicdriver]="i965_dri.so"
+MESA_DRIVERS[i965,default]="classic"
+
+MESA_DRIVERS[r300,description]="r300 (Radeon R300-R500)"
+MESA_DRIVERS[r300,galliumdriver]="r300g_dri.so"
+MESA_DRIVERS[r300,default]="gallium"
+
+MESA_DRIVERS[r600,description]="r600 (Radeon R600-R700, Evergreen, Northern Islands)"
+MESA_DRIVERS[r600,galliumdriver]="r600g_dri.so"
+MESA_DRIVERS[r600,default]="gallium"
+
+MESA_DRIVERS[sw,description]="sw (Software renderer)"
+MESA_DRIVERS[sw,classicdriver]="swrast_dri.so"
+MESA_DRIVERS[sw,galliumdriver]="swrastg_dri.so"
+MESA_DRIVERS[sw,default]="gallium"
diff --git a/media-libs/mesa/files/mesa-8.0-dont-require-llvm-for-r300.patch b/media-libs/mesa/files/mesa-8.0-dont-require-llvm-for-r300.patch
new file mode 100644
index 000000000000..6a209148bca8
--- /dev/null
+++ b/media-libs/mesa/files/mesa-8.0-dont-require-llvm-for-r300.patch
@@ -0,0 +1,27 @@
+diff --git a/configure.ac b/configure.ac
+index 846b623..fbd05c1 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1839,14 +1839,6 @@ gallium_check_st() {
+ fi
+ }
+
+-gallium_require_llvm() {
+- if test "x$MESA_LLVM" = x0; then
+- case "$host_cpu" in
+- i*86|x86_64) AC_MSG_ERROR([LLVM is required to build $1 on x86 and x86_64]);;
+- esac
+- fi
+-}
+-
+ dnl Gallium drivers
+ dnl Duplicates in GALLIUM_DRIVERS_DIRS are removed by sorting it after this block
+ if test "x$with_gallium_drivers" != x; then
+@@ -1868,7 +1860,6 @@ if test "x$with_gallium_drivers" != x; then
+ gallium_check_st "i915/drm" "dri-i915" "xorg-i915"
+ ;;
+ xr300)
+- gallium_require_llvm "Gallium R300"
+ GALLIUM_DRIVERS_DIRS="$GALLIUM_DRIVERS_DIRS r300"
+ gallium_check_st "radeon/drm" "dri-r300" "xorg-r300" "" "xvmc-r300" "vdpau-r300" "va-r300"
+ ;;