summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-03-19 18:56:45 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-03-19 18:56:45 +0000
commit03fa8cb1a48d2b4003a5b02b7340e040eacfb4f5 (patch)
tree9f1c7a405015909789570b66622e3c142ef16942 /media-libs/openal
parentBased on vanilla 2.6.32.32 + genpatches-2.6.32.34 + grsecurity-2.2.1-2.6.32.... (diff)
downloadgentoo-2-03fa8cb1a48d2b4003a5b02b7340e040eacfb4f5.tar.gz
gentoo-2-03fa8cb1a48d2b4003a5b02b7340e040eacfb4f5.tar.bz2
gentoo-2-03fa8cb1a48d2b4003a5b02b7340e040eacfb4f5.zip
Version bump.
(Portage version: 2.2.0_alpha27/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/openal')
-rw-r--r--media-libs/openal/ChangeLog9
-rw-r--r--media-libs/openal/openal-1.13.ebuild37
2 files changed, 44 insertions, 2 deletions
diff --git a/media-libs/openal/ChangeLog b/media-libs/openal/ChangeLog
index a83d170e1f71..8a28d8634887 100644
--- a/media-libs/openal/ChangeLog
+++ b/media-libs/openal/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/openal
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/openal/ChangeLog,v 1.142 2010/06/10 03:09:21 jer Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/openal/ChangeLog,v 1.143 2011/03/19 18:56:45 ssuominen Exp $
+
+*openal-1.13 (19 Mar 2011)
+
+ 19 Mar 2011; Samuli Suominen <ssuominen@gentoo.org> +openal-1.13.ebuild:
+ Version bump.
10 Jun 2010; Jeroen Roovers <jer@gentoo.org> openal-1.11.753.ebuild:
Stable for HPPA (bug #309083).
diff --git a/media-libs/openal/openal-1.13.ebuild b/media-libs/openal/openal-1.13.ebuild
new file mode 100644
index 000000000000..980db9e72b6a
--- /dev/null
+++ b/media-libs/openal/openal-1.13.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/openal/openal-1.13.ebuild,v 1.1 2011/03/19 18:56:45 ssuominen Exp $
+
+EAPI=3
+inherit cmake-utils
+
+MY_P=${PN}-soft-${PV}
+
+DESCRIPTION="A software implementation of the OpenAL 3D audio API"
+HOMEPAGE="http://kcat.strangesoft.net/openal.html"
+SRC_URI="http://kcat.strangesoft.net/openal-releases/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
+IUSE="alsa debug oss portaudio pulseaudio"
+
+RDEPEND="alsa? ( media-libs/alsa-lib )
+ portaudio? ( >=media-libs/portaudio-19_pre )
+ pulseaudio? ( media-sound/pulseaudio )"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS="alsoftrc.sample"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use alsa ALSA)
+ $(cmake-utils_use oss OSS)
+ $(cmake-utils_use portaudio PORTAUDIO)
+ $(cmake-utils_use pulseaudio PULSEAUDIO)
+ )
+
+ cmake-utils_src_configure
+}