summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-01-31 14:56:26 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-01-31 14:56:26 +0000
commitb58b0deb1138a5ddf9ca86d417993d90e98db86a (patch)
tree1a23a8eaa434e1f188817e39ff7d90d958bb4a8c /media-libs/openal
parentBuild alstream (example application) only for native ABI to avoid dependency ... (diff)
downloadgentoo-2-b58b0deb1138a5ddf9ca86d417993d90e98db86a.tar.gz
gentoo-2-b58b0deb1138a5ddf9ca86d417993d90e98db86a.tar.bz2
gentoo-2-b58b0deb1138a5ddf9ca86d417993d90e98db86a.zip
drop USE alstream wrt bug #481670
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'media-libs/openal')
-rw-r--r--media-libs/openal/ChangeLog9
-rw-r--r--media-libs/openal/openal-1.15.1-r1.ebuild3
-rw-r--r--media-libs/openal/openal-1.15.1-r2.ebuild51
3 files changed, 60 insertions, 3 deletions
diff --git a/media-libs/openal/ChangeLog b/media-libs/openal/ChangeLog
index 88f6de3925d5..25808faf7a4e 100644
--- a/media-libs/openal/ChangeLog
+++ b/media-libs/openal/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/openal
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/openal/ChangeLog,v 1.172 2014/01/31 14:50:30 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/openal/ChangeLog,v 1.173 2014/01/31 14:56:26 ssuominen Exp $
+
+*openal-1.15.1-r2 (31 Jan 2014)
+
+ 31 Jan 2014; Samuli Suominen <ssuominen@gentoo.org> +openal-1.15.1-r2.ebuild:
+ Remove USE="alstream" (example application build w/ -DEXAMPLES=ON) to drop
+ FFMpeg dependency wrt #481670 because upstream moved all examples to SDL in
+ git and because it fails to compile with certain versions of libav.
31 Jan 2014; Samuli Suominen <ssuominen@gentoo.org> openal-1.15.1-r1.ebuild:
Build alstream (example application) only for native ABI to avoid dependency
diff --git a/media-libs/openal/openal-1.15.1-r1.ebuild b/media-libs/openal/openal-1.15.1-r1.ebuild
index b46653765bf3..e553f37e96a6 100644
--- a/media-libs/openal/openal-1.15.1-r1.ebuild
+++ b/media-libs/openal/openal-1.15.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/openal/openal-1.15.1-r1.ebuild,v 1.6 2014/01/31 14:50:30 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/openal/openal-1.15.1-r1.ebuild,v 1.7 2014/01/31 14:56:26 ssuominen Exp $
EAPI=5
inherit cmake-multilib
@@ -49,7 +49,6 @@ src_configure() {
mycmakeargs+=( "-DEXAMPLES=OFF" )
fi
-
cmake-utils_src_configure
}
diff --git a/media-libs/openal/openal-1.15.1-r2.ebuild b/media-libs/openal/openal-1.15.1-r2.ebuild
new file mode 100644
index 000000000000..5992158cd2ff
--- /dev/null
+++ b/media-libs/openal/openal-1.15.1-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/openal/openal-1.15.1-r2.ebuild,v 1.1 2014/01/31 14:56:26 ssuominen Exp $
+
+EAPI=5
+inherit cmake-multilib
+
+MY_P=${PN}-soft-${PV}
+
+DESCRIPTION="A software implementation of the OpenAL 3D audio API"
+HOMEPAGE="http://kcat.strangesoft.net/openal.html"
+SRC_URI="http://kcat.strangesoft.net/openal-releases/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
+IUSE="alsa coreaudio debug neon oss portaudio pulseaudio sse"
+
+RDEPEND="alsa? ( media-libs/alsa-lib[${MULTILIB_USEDEP}] )
+ portaudio? ( >=media-libs/portaudio-19_pre[${MULTILIB_USEDEP}] )
+ pulseaudio? ( media-sound/pulseaudio[${MULTILIB_USEDEP}] )
+ abi_x86_32? (
+ !<app-emulation/emul-linux-x86-sdl-20131008-r1
+ !app-emulation/emul-linux-x86-sdl[-abi_x86_32(-)]
+ )"
+DEPEND="${RDEPEND}
+ oss? ( virtual/os-headers )"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS="alsoftrc.sample env-vars.txt hrtf.txt README"
+
+src_configure() {
+ # -DEXAMPLES=OFF to avoid FFmpeg dependency wrt #481670
+ my_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use alsa)
+ $(cmake-utils_use coreaudio)
+ $(cmake-utils_use neon)
+ $(cmake-utils_use oss)
+ $(cmake-utils_use portaudio)
+ $(cmake-utils_use pulseaudio)
+ $(cmake-utils_use sse)
+ -DEXAMPLES=OFF
+ )
+
+ cmake-utils_src_configure
+ }
+
+ multilib_parallel_foreach_abi my_configure
+}