summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-08-10 05:28:18 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-08-10 05:28:18 +0000
commit790f6e3927b6f5927a207bc9e780b40a2cedf2d5 (patch)
tree1af936e28c01977d3111bf2975c5f3c3ccc7ca47 /media-libs/raptor
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-790f6e3927b6f5927a207bc9e780b40a2cedf2d5.tar.gz
gentoo-2-790f6e3927b6f5927a207bc9e780b40a2cedf2d5.tar.bz2
gentoo-2-790f6e3927b6f5927a207bc9e780b40a2cedf2d5.zip
version bump
(Portage version: 2.2_rc36/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/raptor')
-rw-r--r--media-libs/raptor/ChangeLog7
-rw-r--r--media-libs/raptor/raptor-1.4.19.ebuild58
2 files changed, 64 insertions, 1 deletions
diff --git a/media-libs/raptor/ChangeLog b/media-libs/raptor/ChangeLog
index ee43ee7eeaaf..9ff7008b2e38 100644
--- a/media-libs/raptor/ChangeLog
+++ b/media-libs/raptor/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/raptor
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/raptor/ChangeLog,v 1.67 2009/06/22 13:04:45 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/raptor/ChangeLog,v 1.68 2009/08/10 05:28:18 aballier Exp $
+
+*raptor-1.4.19 (10 Aug 2009)
+
+ 10 Aug 2009; Alexis Ballier <aballier@gentoo.org> +raptor-1.4.19.ebuild:
+ version bump
22 Jun 2009; Alexis Ballier <aballier@gentoo.org> raptor-1.4.18.ebuild:
keyword ~x86-fbsd
diff --git a/media-libs/raptor/raptor-1.4.19.ebuild b/media-libs/raptor/raptor-1.4.19.ebuild
new file mode 100644
index 000000000000..e2f41ffb2e28
--- /dev/null
+++ b/media-libs/raptor/raptor-1.4.19.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/raptor/raptor-1.4.19.ebuild,v 1.1 2009/08/10 05:28:18 aballier Exp $
+
+EAPI=2
+inherit eutils libtool
+
+DESCRIPTION="The RDF Parser Toolkit"
+HOMEPAGE="http://librdf.org/raptor"
+SRC_URI="http://download.librdf.org/source/${P}.tar.gz"
+
+LICENSE="LGPL-2.1 Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="curl debug unicode xml"
+
+RDEPEND="unicode? ( >=dev-libs/glib-2 )
+ xml? ( >=dev-libs/libxml2-2.6.8 )
+ !xml? ( dev-libs/expat )
+ curl? ( net-misc/curl )
+ dev-libs/libxslt"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ dev-util/pkgconfig"
+
+src_prepare() {
+ epunt_cxx
+ elibtoolize # needed for .so versionning on bsd
+}
+
+src_configure() {
+ local myconf
+
+ if use xml; then
+ myconf="${myconf} --with-xml-parser=libxml"
+ else
+ myconf="${myconf} --with-xml-parser=expat"
+ fi
+
+ if use curl; then
+ myconf="${myconf} --with-www=curl"
+ elif use xml; then
+ myconf="${myconf} --with-www=xml"
+ else
+ myconf="${myconf} --with-www=none"
+ fi
+
+ econf \
+ $(use_enable unicode nfc-check) \
+ $(use_enable debug) \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS NOTICE README
+ dohtml NEWS.html README.html RELEASE.html
+}