summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-07-13 17:13:52 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-07-13 17:13:52 +0000
commit8814f8df73b30e8525ce88085c110a4bd43ef200 (patch)
tree8b695be31a1e9d78df48bb11534d732a3b19d0c2 /media-libs/raspberrypi-userland
parentStable for x86, wrt bug #460278 (diff)
downloadgentoo-2-8814f8df73b30e8525ce88085c110a4bd43ef200.tar.gz
gentoo-2-8814f8df73b30e8525ce88085c110a4bd43ef200.tar.bz2
gentoo-2-8814f8df73b30e8525ce88085c110a4bd43ef200.zip
New snapshot.
(Portage version: 2.1.12.2/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'media-libs/raspberrypi-userland')
-rw-r--r--media-libs/raspberrypi-userland/ChangeLog8
-rw-r--r--media-libs/raspberrypi-userland/raspberrypi-userland-0_pre20130705.ebuild61
-rw-r--r--media-libs/raspberrypi-userland/raspberrypi-userland-9999.ebuild9
3 files changed, 76 insertions, 2 deletions
diff --git a/media-libs/raspberrypi-userland/ChangeLog b/media-libs/raspberrypi-userland/ChangeLog
index 32d560c0adae..a190259faf94 100644
--- a/media-libs/raspberrypi-userland/ChangeLog
+++ b/media-libs/raspberrypi-userland/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/raspberrypi-userland
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/raspberrypi-userland/ChangeLog,v 1.3 2013/02/02 00:57:27 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/raspberrypi-userland/ChangeLog,v 1.4 2013/07/13 17:13:52 chithanh Exp $
+
+*raspberrypi-userland-0_pre20130705 (13 Jul 2013)
+
+ 13 Jul 2013; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +raspberrypi-userland-0_pre20130705.ebuild, raspberrypi-userland-9999.ebuild:
+ New snapshot.
*raspberrypi-userland-9999 (02 Feb 2013)
*raspberrypi-userland-0_pre20130131 (02 Feb 2013)
diff --git a/media-libs/raspberrypi-userland/raspberrypi-userland-0_pre20130705.ebuild b/media-libs/raspberrypi-userland/raspberrypi-userland-0_pre20130705.ebuild
new file mode 100644
index 000000000000..e1226941bde4
--- /dev/null
+++ b/media-libs/raspberrypi-userland/raspberrypi-userland-0_pre20130705.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/raspberrypi-userland/raspberrypi-userland-0_pre20130705.ebuild,v 1.1 2013/07/13 17:13:52 chithanh Exp $
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Raspberry Pi userspace tools and libraries"
+HOMEPAGE="https://github.com/raspberrypi/userland"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/${PN/-//}.git"
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="mirror://gentoo/${P}.tar.xz"
+ KEYWORDS="~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+# TODO:
+# * port vcfiled init script
+# * stuff is still installed to hardcoded /opt/vc location, investigate whether
+# anything else depends on it being there
+# * live ebuild
+
+src_unpack() {
+ if [[ ${PV} == 9999* ]]; then
+ git-2_src_unpack
+ else
+ default
+ mv userland-*/ ${P}/ || die
+ fi
+}
+
+src_prepare() {
+ # init script for Debian, not useful on Gentoo
+ sed -i "/DESTINATION \/etc\/init.d/,+2d" interface/vmcs_host/linux/vcfiled/CMakeLists.txt || die
+}
+
+src_configure() {
+ # toolchain file not needed, but build fails if it is not specified
+ local mycmakeargs="-DCMAKE_TOOLCHAIN_FILE=/dev/null"
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ doenvd "${FILESDIR}"/04${PN}
+
+ # enable dynamic switching of the GL implementation
+ dodir /usr/lib/opengl
+ dosym ../../../opt/vc /usr/lib/opengl/${PN}
+
+ # tell eselect opengl that we do not have libGL
+ touch "${ED}"/opt/vc/.gles-only
+}
diff --git a/media-libs/raspberrypi-userland/raspberrypi-userland-9999.ebuild b/media-libs/raspberrypi-userland/raspberrypi-userland-9999.ebuild
index 2a9176f1f299..2193bd3eef0f 100644
--- a/media-libs/raspberrypi-userland/raspberrypi-userland-9999.ebuild
+++ b/media-libs/raspberrypi-userland/raspberrypi-userland-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/raspberrypi-userland/raspberrypi-userland-9999.ebuild,v 1.1 2013/02/02 00:57:27 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/raspberrypi-userland/raspberrypi-userland-9999.ebuild,v 1.2 2013/07/13 17:13:52 chithanh Exp $
EAPI=5
@@ -51,4 +51,11 @@ src_configure() {
src_install() {
cmake-utils_src_install
doenvd "${FILESDIR}"/04${PN}
+
+ # enable dynamic switching of the GL implementation
+ dodir /usr/lib/opengl
+ dosym ../../../opt/vc /usr/lib/opengl/${PN}
+
+ # tell eselect opengl that we do not have libGL
+ touch "${ED}"/opt/vc/.gles-only
}