summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-10-26 08:09:20 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-10-26 08:09:20 +0000
commit6e2f873bbbc5c6792485176f5143b3497dfc8233 (patch)
treeda93878cd2012f9f6da6649c06368e87162c649e /media-libs/sbc
parentSupport Samba 4; reported and patch provided by Torsten Kurbad, patch slightl... (diff)
downloadgentoo-2-6e2f873bbbc5c6792485176f5143b3497dfc8233.tar.gz
gentoo-2-6e2f873bbbc5c6792485176f5143b3497dfc8233.tar.bz2
gentoo-2-6e2f873bbbc5c6792485176f5143b3497dfc8233.zip
Convert to multilib, by Reinis Danne, bug #488282
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-libs/sbc')
-rw-r--r--media-libs/sbc/ChangeLog7
-rw-r--r--media-libs/sbc/sbc-1.1-r1.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/media-libs/sbc/ChangeLog b/media-libs/sbc/ChangeLog
index 14b094132fdb..45ae577f3373 100644
--- a/media-libs/sbc/ChangeLog
+++ b/media-libs/sbc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/sbc
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/sbc/ChangeLog,v 1.8 2013/10/09 13:54:46 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sbc/ChangeLog,v 1.9 2013/10/26 08:09:20 aballier Exp $
+
+*sbc-1.1-r1 (26 Oct 2013)
+
+ 26 Oct 2013; Alexis Ballier <aballier@gentoo.org> +sbc-1.1-r1.ebuild:
+ Convert to multilib, by Reinis Danne, bug #488282
09 Oct 2013; Jeroen Roovers <jer@gentoo.org> sbc-1.1.ebuild:
Stable for HPPA (bug #477662).
diff --git a/media-libs/sbc/sbc-1.1-r1.ebuild b/media-libs/sbc/sbc-1.1-r1.ebuild
new file mode 100644
index 000000000000..28e2102186e6
--- /dev/null
+++ b/media-libs/sbc/sbc-1.1-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sbc/sbc-1.1-r1.ebuild,v 1.1 2013/10/26 08:09:20 aballier Exp $
+
+EAPI=5
+inherit eutils multilib multilib-minimal
+
+DESCRIPTION="An audio codec to connect bluetooth high quality audio devices like headphones or loudspeakers"
+HOMEPAGE="http://git.kernel.org/?p=bluetooth/sbc.git http://www.bluez.org/sbc-10/"
+SRC_URI="mirror://kernel/linux/bluetooth/${P}.tar.xz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE="static-libs"
+
+# --enable-tester is building src/sbctester but the tarball is missing required
+# .wav file to execute it
+RESTRICT="test"
+
+DEPEND="virtual/pkgconfig"
+
+DOCS="AUTHORS ChangeLog"
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ $(use_enable static-libs static) \
+ --disable-tester
+}
+
+multilib_src_install_all() {
+ prune_libtool_files
+}