summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-09-12 23:49:38 +0000
committerMike Frysinger <vapier@gentoo.org>2005-09-12 23:49:38 +0000
commitc139901cfcff7944652fca071b4eb0c761788c45 (patch)
treef062cb6c5b12cb9990216320a9e32819b336bb1a /media-libs/smpeg
parentadded to ~amd64 and bumped svk to 1.04 (diff)
downloadgentoo-2-c139901cfcff7944652fca071b4eb0c761788c45.tar.gz
gentoo-2-c139901cfcff7944652fca071b4eb0c761788c45.tar.bz2
gentoo-2-c139901cfcff7944652fca071b4eb0c761788c45.zip
fix mmx support #105582
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'media-libs/smpeg')
-rw-r--r--media-libs/smpeg/smpeg-0.4.4-r6.ebuild12
1 files changed, 4 insertions, 8 deletions
diff --git a/media-libs/smpeg/smpeg-0.4.4-r6.ebuild b/media-libs/smpeg/smpeg-0.4.4-r6.ebuild
index e87328e5f5f7..9eb8d6a0b929 100644
--- a/media-libs/smpeg/smpeg-0.4.4-r6.ebuild
+++ b/media-libs/smpeg/smpeg-0.4.4-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/smpeg/smpeg-0.4.4-r6.ebuild,v 1.2 2005/08/23 19:57:29 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/smpeg/smpeg-0.4.4-r6.ebuild,v 1.3 2005/09/12 23:49:38 vapier Exp $
inherit eutils toolchain-funcs
@@ -11,7 +11,7 @@ SRC_URI="ftp://ftp.lokigames.com/pub/open-source/smpeg/${P}.tar.gz"
LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86"
-IUSE="X gtk opengl debug"
+IUSE="X gtk opengl debug mmx"
DEPEND=">=media-libs/libsdl-1.2.0
opengl? ( virtual/opengl virtual/glu )
@@ -37,19 +37,15 @@ src_unpack() {
}
src_compile() {
- export CC="$(tc-getCC)"
- export CXX="$(tc-getCXX)"
- export RANLIB="$(tc-getRANLIB)"
- export AR="$(tc-getAR)"
+ tc-export CC CXX RANLIB AR
- # --enable-mmx causes test apps to crash on startup #470
- # $(use_enable mmx) \
econf \
$(use_enable debug) \
$(use_enable debug assertions) \
$(use_enable gtk gtk-player) \
$(use_with X x) \
$(use_enable opengl opengl-player) \
+ $(use_enable mmx) \
|| die "econf failed"
emake || die "emake failed"