summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-01-07 15:33:51 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-01-07 15:33:51 +0000
commit62c7000a2c4cf28ddaf82ed8f2e72eb711ebe818 (patch)
tree4a22f96e3eecea801fe00f537bbcc1ad77cb2699 /media-libs/suil/suil-0.4.4.ebuild
parentinitial import, ebuild by Gavin Pryke (diff)
downloadgentoo-2-62c7000a2c4cf28ddaf82ed8f2e72eb711ebe818.tar.gz
gentoo-2-62c7000a2c4cf28ddaf82ed8f2e72eb711ebe818.tar.bz2
gentoo-2-62c7000a2c4cf28ddaf82ed8f2e72eb711ebe818.zip
initial import, ebuild by me
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/suil/suil-0.4.4.ebuild')
-rw-r--r--media-libs/suil/suil-0.4.4.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-libs/suil/suil-0.4.4.ebuild b/media-libs/suil/suil-0.4.4.ebuild
new file mode 100644
index 000000000000..203f42a0435d
--- /dev/null
+++ b/media-libs/suil/suil-0.4.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/suil/suil-0.4.4.ebuild,v 1.1 2012/01/07 15:33:51 aballier Exp $
+
+EAPI=4
+
+inherit base waf-utils
+
+DESCRIPTION="Lightweight C library for loading and wrapping LV2 plugin UIs"
+HOMEPAGE="http://drobilla.net/software/suil/"
+SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc gtk qt4"
+
+RDEPEND=">=media-libs/lv2core-6
+ media-libs/lv2-ui
+ gtk? ( x11-libs/gtk+:2 )
+ qt4? ( x11-libs/qt-gui:4 )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ dev-util/pkgconfig"
+
+PATCHES=( "${FILESDIR}/ldconfig.patch" )
+DOCS=( "AUTHORS" "README" "ChangeLog" )
+
+src_configure() {
+ # otherwise automagic
+ use gtk || sed -i -e 's/gtk+-2.0/DiSaBlEd/' wscript
+ use qt4 || sed -i -e 's/QtGui/DiSaBlEd/' wscript
+ waf-utils_src_configure \
+ "--mandir=/usr/share/man" \
+ "--docdir=/usr/share/doc/${PF}" \
+ $(use doc && echo "--docs")
+}