summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Meier <maekke@gentoo.org>2008-09-19 22:43:00 +0000
committerMarkus Meier <maekke@gentoo.org>2008-09-19 22:43:00 +0000
commit6d7f3f20246cc1da8b09a4a5a49a3bc7d8f97825 (patch)
treeaa6fe67c39868ab712bdc2ff4a532c66c5de6327 /media-libs/tiff/tiff-3.8.2-r5.ebuild
parentold (diff)
downloadgentoo-2-6d7f3f20246cc1da8b09a4a5a49a3bc7d8f97825.tar.gz
gentoo-2-6d7f3f20246cc1da8b09a4a5a49a3bc7d8f97825.tar.bz2
gentoo-2-6d7f3f20246cc1da8b09a4a5a49a3bc7d8f97825.zip
bump, this should fix the tiff2pdf problem of bug #145055
(Portage version: 2.2_rc8/cvs/Linux 2.6.27-rc6 i686)
Diffstat (limited to 'media-libs/tiff/tiff-3.8.2-r5.ebuild')
-rw-r--r--media-libs/tiff/tiff-3.8.2-r5.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/media-libs/tiff/tiff-3.8.2-r5.ebuild b/media-libs/tiff/tiff-3.8.2-r5.ebuild
new file mode 100644
index 000000000000..e0e6ddedd5ab
--- /dev/null
+++ b/media-libs/tiff/tiff-3.8.2-r5.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/tiff/tiff-3.8.2-r5.ebuild,v 1.1 2008/09/19 22:43:00 maekke Exp $
+
+inherit eutils libtool
+
+DESCRIPTION="Library for manipulation of TIFF (Tag Image File Format) images"
+HOMEPAGE="http://www.remotesensing.org/libtiff/"
+SRC_URI="ftp://ftp.remotesensing.org/pub/libtiff/${P}.tar.gz
+ mirror://gentoo/${P}-tiff2pdf-20080903.patch.bz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="jpeg jbig nocxx zlib"
+
+DEPEND="jpeg? ( >=media-libs/jpeg-6b )
+ jbig? ( >=media-libs/jbigkit-1.6-r1 )
+ zlib? ( >=sys-libs/zlib-1.1.3-r2 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${WORKDIR}"/${P}-tiff2pdf-20080903.patch
+ epatch "${FILESDIR}"/${P}-tiffsplit.patch
+ if use jbig; then
+ epatch "${FILESDIR}"/${PN}-jbig.patch
+ fi
+ epatch "${FILESDIR}"/${P}-goo-sec.patch
+ epatch "${FILESDIR}"/${P}-CVE-2008-2327.patch
+ elibtoolize
+}
+
+src_compile() {
+ econf \
+ $(use_enable !nocxx cxx) \
+ $(use_enable zlib) \
+ $(use_enable jpeg) \
+ $(use_enable jbig) \
+ --with-pic --without-x \
+ --with-docdir=/usr/share/doc/${PF} \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "make install failed"
+ dodoc README TODO VERSION
+}
+
+pkg_postinst() {
+ echo
+ elog "JBIG support is intended for Hylafax fax compression, so we"
+ elog "really need more feedback in other areas (most testing has"
+ elog "been done with fax). Be sure to recompile anything linked"
+ elog "against tiff if you rebuild it with jbig support."
+ echo
+}