summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-10-30 14:14:21 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-10-30 14:14:21 +0000
commit06ab4a0813cf6aacbad3338607a13ee71c39bcd5 (patch)
treeea7ba4eb65988b6aeaa9f4f4494e7edbe5a13e0f /media-libs/tse3/tse3-0.3.0-r1.ebuild
parentVersion bump to 1.4.0_rc8, renaming of the module to openafs (instead of libafs) (diff)
downloadgentoo-2-06ab4a0813cf6aacbad3338607a13ee71c39bcd5.tar.gz
gentoo-2-06ab4a0813cf6aacbad3338607a13ee71c39bcd5.tar.bz2
gentoo-2-06ab4a0813cf6aacbad3338607a13ee71c39bcd5.zip
Re-create autotools support with eautoreconf (and run elibtoolize), so that .so extension on libraries is respected. Fixes bug #94484.
(Portage version: 2.0.53_rc6)
Diffstat (limited to 'media-libs/tse3/tse3-0.3.0-r1.ebuild')
-rw-r--r--media-libs/tse3/tse3-0.3.0-r1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/media-libs/tse3/tse3-0.3.0-r1.ebuild b/media-libs/tse3/tse3-0.3.0-r1.ebuild
new file mode 100644
index 000000000000..8d10a170351d
--- /dev/null
+++ b/media-libs/tse3/tse3-0.3.0-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/tse3/tse3-0.3.0-r1.ebuild,v 1.1 2005/10/30 14:14:21 flameeyes Exp $
+
+inherit eutils libtool autotools
+
+DESCRIPTION="TSE3 Sequencer library"
+HOMEPAGE="http://TSE3.sourceforge.net/"
+SRC_URI="mirror://sourceforge/tse3/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="alsa oss arts"
+
+RDEPEND="alsa? ( media-libs/alsa-lib )
+ arts? ( kde-base/arts )"
+
+DEPEND="${RDEPEND}
+ sys-devel/automake
+ sys-devel/autoconf
+ sys-devel/libtool"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ # support 64bit machines properly
+ epatch ${FILESDIR}/${PN}-0.2.7-size_t-64bit.patch
+ # gcc-3.4 patch
+ epatch ${FILESDIR}/${PN}-0.2.7-gcc34.patch
+ # gcc-4 patch (bug #100708)
+ epatch ${FILESDIR}/${PN}-0.2.7-gcc4.patch
+
+ eautoreconf
+ elibtoolize
+}
+
+src_compile() {
+ local myconf=""
+
+ use arts || myconf="${myconf} --without-arts"
+ use alsa || myconf="${myconf} --without-alsa"
+ use oss || myconf="${myconf} --without-oss"
+
+ econf ${myconf} || die "./configure failed"
+ emake -j1 || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+}