summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-09-09 21:48:36 +0000
committerTim Harder <radhermit@gentoo.org>2012-09-09 21:48:36 +0000
commit445a605b2c7d1d68ad0378a2b07ec4b518a45b32 (patch)
tree24a0f14035628ea3c3a7a51d2b78bd6863259fb5 /media-libs
parentStable ppc, bug #434486 (diff)
downloadgentoo-2-445a605b2c7d1d68ad0378a2b07ec4b518a45b32.tar.gz
gentoo-2-445a605b2c7d1d68ad0378a2b07ec4b518a45b32.tar.bz2
gentoo-2-445a605b2c7d1d68ad0378a2b07ec4b518a45b32.zip
Version bump.
(Portage version: 2.2.0_alpha124/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libsoundtouch/ChangeLog8
-rw-r--r--media-libs/libsoundtouch/files/libsoundtouch-1.7.0-flags.patch22
-rw-r--r--media-libs/libsoundtouch/libsoundtouch-1.7.0.ebuild44
3 files changed, 73 insertions, 1 deletions
diff --git a/media-libs/libsoundtouch/ChangeLog b/media-libs/libsoundtouch/ChangeLog
index eaccdc6bbc95..b80bf4d81ddc 100644
--- a/media-libs/libsoundtouch/ChangeLog
+++ b/media-libs/libsoundtouch/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/libsoundtouch
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsoundtouch/ChangeLog,v 1.56 2012/08/06 00:52:47 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsoundtouch/ChangeLog,v 1.57 2012/09/09 21:48:36 radhermit Exp $
+
+*libsoundtouch-1.7.0 (09 Sep 2012)
+
+ 09 Sep 2012; Tim Harder <radhermit@gentoo.org> +libsoundtouch-1.7.0.ebuild,
+ +files/libsoundtouch-1.7.0-flags.patch:
+ Version bump.
06 Aug 2012; Anthony G. Basile <blueness@gentoo.org>
libsoundtouch-1.6.0.ebuild:
diff --git a/media-libs/libsoundtouch/files/libsoundtouch-1.7.0-flags.patch b/media-libs/libsoundtouch/files/libsoundtouch-1.7.0-flags.patch
new file mode 100644
index 000000000000..2b1e1ac80958
--- /dev/null
+++ b/media-libs/libsoundtouch/files/libsoundtouch-1.7.0-flags.patch
@@ -0,0 +1,22 @@
+--- soundtouch/source/SoundStretch/Makefile.am
++++ soundtouch/source/SoundStretch/Makefile.am
+@@ -48,7 +48,7 @@
+ # soundstretch_LDFLAGS=-s
+
+ ## additional compiler flags
+-soundstretch_CXXFLAGS=-O3
++#soundstretch_CXXFLAGS=-O3
+
+ #clean-local:
+ # -rm -f additional-files-to-remove-on-make-clean
+--- soundtouch/source/SoundTouch/Makefile.am
++++ soundtouch/source/SoundTouch/Makefile.am
+@@ -32,7 +32,7 @@
+
+
+ # Compiler flags
+-AM_CXXFLAGS=-O3 -fcheck-new -I../../include
++AM_CXXFLAGS=-fcheck-new -I../../include
+
+ # Compile the files that need MMX and SSE individually.
+ libSoundTouch_la_LIBADD=libSoundTouchMMX.la libSoundTouchSSE.la
diff --git a/media-libs/libsoundtouch/libsoundtouch-1.7.0.ebuild b/media-libs/libsoundtouch/libsoundtouch-1.7.0.ebuild
new file mode 100644
index 000000000000..35ef4a54729a
--- /dev/null
+++ b/media-libs/libsoundtouch/libsoundtouch-1.7.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsoundtouch/libsoundtouch-1.7.0.ebuild,v 1.1 2012/09/09 21:48:36 radhermit Exp $
+
+EAPI=4
+inherit autotools eutils flag-o-matic
+
+MY_PN=${PN/lib}
+
+DESCRIPTION="Audio processing library for changing tempo, pitch and playback rates."
+HOMEPAGE="http://www.surina.net/soundtouch/"
+SRC_URI="http://www.surina.net/soundtouch/${P/lib}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~x86"
+IUSE="sse2 static-libs"
+
+DEPEND="virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-flags.patch
+ sed -i -e "s:^\(pkgdoc_DATA=\)COPYING.TXT :\1:" Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ --disable-integer-samples \
+ --enable-x86-optimizations=$(usex sse2) \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" pkgdocdir="${EPREFIX}"/usr/share/doc/${PF}/html install
+ prune_libtool_files
+}