summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2009-02-15 00:08:24 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2009-02-15 00:08:24 +0000
commit652273d1e00bf94afc49774ce2839974110b417a (patch)
treed4180ab6e433e62ac25ec966ea109e0a99dc552c /media-libs
parentVersion bump. (diff)
downloadgentoo-2-652273d1e00bf94afc49774ce2839974110b417a.tar.gz
gentoo-2-652273d1e00bf94afc49774ce2839974110b417a.tar.bz2
gentoo-2-652273d1e00bf94afc49774ce2839974110b417a.zip
Add fix for gcc-4.3 warning, bug 256799. Thanks to Gene Seto <geneseto@hotmail.com> for patch. Drop old version.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libfame/ChangeLog10
-rw-r--r--media-libs/libfame/files/libfame-0.9.1-gcc43.patch33
-rw-r--r--media-libs/libfame/libfame-0.9.0.ebuild41
-rw-r--r--media-libs/libfame/libfame-0.9.1-r1.ebuild5
4 files changed, 44 insertions, 45 deletions
diff --git a/media-libs/libfame/ChangeLog b/media-libs/libfame/ChangeLog
index 421e58a138e8..82d0bdc08ad7 100644
--- a/media-libs/libfame/ChangeLog
+++ b/media-libs/libfame/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/libfame
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libfame/ChangeLog,v 1.51 2007/02/22 01:53:39 peper Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libfame/ChangeLog,v 1.52 2009/02/15 00:08:23 loki_val Exp $
+
+ 15 Feb 2009; Peter Alfredsen <loki_val@gentoo.org>
+ +files/libfame-0.9.1-gcc43.patch, -libfame-0.9.0.ebuild,
+ libfame-0.9.1-r1.ebuild:
+ Add fix for gcc-4.3 warning, bug 256799. Thanks to Gene Seto
+ <geneseto@hotmail.com> for patch. Drop old version.
22 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
diff --git a/media-libs/libfame/files/libfame-0.9.1-gcc43.patch b/media-libs/libfame/files/libfame-0.9.1-gcc43.patch
new file mode 100644
index 000000000000..71fdbf59c522
--- /dev/null
+++ b/media-libs/libfame/files/libfame-0.9.1-gcc43.patch
@@ -0,0 +1,33 @@
+diff -rupN libfame-0.9.1b/src/fame_motion_pmvfast.c libfame-0.9.1/src/fame_motion_pmvfast.c
+--- libfame-0.9.1b/src/fame_motion_pmvfast.c 2009-02-03 01:30:26.000000000 -0400
++++ libfame-0.9.1/src/fame_motion_pmvfast.c 2009-02-03 01:31:33.000000000 -0400
+@@ -19,6 +19,7 @@
+
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+ #include "fame.h"
+ #include "fame_malloc.h"
+ #include "fame_motion.h"
+diff -rupN libfame-0.9.1b/src/fame_rate_1param.c libfame-0.9.1/src/fame_rate_1param.c
+--- libfame-0.9.1b/src/fame_rate_1param.c 2009-02-03 01:30:26.000000000 -0400
++++ libfame-0.9.1/src/fame_rate_1param.c 2009-02-03 01:31:15.000000000 -0400
+@@ -19,6 +19,7 @@
+
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+ #include <math.h>
+ #include "fame.h"
+ #include "fame_rate_1param.h"
+diff -rupN libfame-0.9.1b/src/fame_rate_simple.c libfame-0.9.1/src/fame_rate_simple.c
+--- libfame-0.9.1b/src/fame_rate_simple.c 2009-02-03 01:30:26.000000000 -0400
++++ libfame-0.9.1/src/fame_rate_simple.c 2009-02-03 01:30:57.000000000 -0400
+@@ -19,6 +19,7 @@
+
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+ #include <math.h>
+ #include "fame.h"
+ #include "fame_rate_simple.h"
diff --git a/media-libs/libfame/libfame-0.9.0.ebuild b/media-libs/libfame/libfame-0.9.0.ebuild
deleted file mode 100644
index 789959d29c97..000000000000
--- a/media-libs/libfame/libfame-0.9.0.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libfame/libfame-0.9.0.ebuild,v 1.24 2006/10/28 23:39:39 flameeyes Exp $
-
-inherit flag-o-matic
-
-DESCRIPTION="MPEG-1 and MPEG-4 video encoding library"
-HOMEPAGE="http://fame.sourceforge.net/"
-SRC_URI="mirror://sourceforge/fame/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc sparc x86"
-IUSE="mmx"
-
-src_unpack() {
- unpack ${A} || die
- cd ${S} || die
-
- [[ "${ARCH}" == "amd64" ]] && libtoolize -c -f
-}
-
-src_compile() {
- filter-flags -fprefetch-loop-arrays
- econf $(use_enable mmx) || die
- emake || die
-}
-
-src_install() {
- dodir /usr
- dodir /usr/lib
-
- einstall install || die
- dobin libfame-config
-
- insinto /usr/share/aclocal
- doins libfame.m4
-
- dodoc CHANGES README
- doman doc/*.3
-}
diff --git a/media-libs/libfame/libfame-0.9.1-r1.ebuild b/media-libs/libfame/libfame-0.9.1-r1.ebuild
index 2b9b4812cc45..59d915689e0b 100644
--- a/media-libs/libfame/libfame-0.9.1-r1.ebuild
+++ b/media-libs/libfame/libfame-0.9.1-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libfame/libfame-0.9.1-r1.ebuild,v 1.25 2006/10/28 23:39:39 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libfame/libfame-0.9.1-r1.ebuild,v 1.26 2009/02/15 00:08:23 loki_val Exp $
inherit flag-o-matic toolchain-funcs eutils
@@ -25,6 +25,7 @@ src_unpack() {
# Do not add -march=i586, bug #41770.
sed -i -e 's:-march=i[345]86 ::g' configure
+ epatch "${FILESDIR}/${P}-gcc43.patch"
}
src_compile() {