summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2004-03-22 00:29:41 +0000
committerMarinus Schraal <foser@gentoo.org>2004-03-22 00:29:41 +0000
commit6671fd72e8993d7e808d6281a4aabb0769529e26 (patch)
tree423f1e783f7dfd8eddf71b761bce5a31814f7796 /media-libs
parentkyro-kernel to kyro-drivers (diff)
downloadgentoo-2-6671fd72e8993d7e808d6281a4aabb0769529e26.tar.gz
gentoo-2-6671fd72e8993d7e808d6281a4aabb0769529e26.tar.bz2
gentoo-2-6671fd72e8993d7e808d6281a4aabb0769529e26.zip
gnome 2.6 commit
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/gst-plugins/ChangeLog7
-rw-r--r--media-libs/gst-plugins/files/digest-gst-plugins-0.8.01
-rw-r--r--media-libs/gst-plugins/gst-plugins-0.8.0.ebuild104
3 files changed, 111 insertions, 1 deletions
diff --git a/media-libs/gst-plugins/ChangeLog b/media-libs/gst-plugins/ChangeLog
index 514e603ef727..f3b2b0b439d0 100644
--- a/media-libs/gst-plugins/ChangeLog
+++ b/media-libs/gst-plugins/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for media-libs/gst-plugins
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
# Distributed under the terms of the GNU General Public License, v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins/ChangeLog,v 1.60 2004/03/16 04:52:40 geoman Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins/ChangeLog,v 1.61 2004/03/22 00:29:41 foser Exp $
+
+*gst-plugins-0.8.0 (21 Mar 2004)
+
+ 21 Mar 2004; foser <foser@gentoo.org> gst-plugins-0.8.0.ebuild :
+ Gnome 2.6 commit
15 Mar 2004; Stephen P. Becker <geoman@gentoo.org> gst-plugins-0.6.4.ebuild:
Added ~mips keyword.
diff --git a/media-libs/gst-plugins/files/digest-gst-plugins-0.8.0 b/media-libs/gst-plugins/files/digest-gst-plugins-0.8.0
new file mode 100644
index 000000000000..f759a94352d1
--- /dev/null
+++ b/media-libs/gst-plugins/files/digest-gst-plugins-0.8.0
@@ -0,0 +1 @@
+MD5 3735f701a25a37ed0b1ec6f3d861a658 gst-plugins-0.8.0.tar.bz2 1751685
diff --git a/media-libs/gst-plugins/gst-plugins-0.8.0.ebuild b/media-libs/gst-plugins/gst-plugins-0.8.0.ebuild
new file mode 100644
index 000000000000..584b435993f7
--- /dev/null
+++ b/media-libs/gst-plugins/gst-plugins-0.8.0.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins/gst-plugins-0.8.0.ebuild,v 1.1 2004/03/22 00:29:41 foser Exp $
+
+# IMPORTANT
+#
+# Since gst-plugins uses a local copy of ffmpeg we consider this a non-external plugin
+# In essence this means gst-plugins without any external plugins already provides a
+# wide range of audio/video codecs
+#
+# This may change in the future, but for now 3rd-party apps do probably not need to depend
+# on mpeg/avi plugins etcetera unless they are directly referenced
+
+# order is important, gnome2 after gst-plugins
+inherit gst-plugins gnome2 eutils flag-o-matic
+
+DESCRIPTION="Basepack of plugins for gstreamer"
+HOMEPAGE="http://gstreamer.net/"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~amd64 ~ia64 ~mips"
+
+RDEPEND="=media-libs/gstreamer-${PV}*
+ >=gnome-base/gconf-1.2"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.11.5
+ >=dev-util/pkgconfig-0.9"
+
+#PDEPEND=">=media-plugins/gst-plugins-oss-${PV}"
+
+#BUILD_GST_PLUGINS="ffmpeg"
+#BUILD_GST_PLUGINS=""
+BUILD_GST_PLUGINS="oss"
+# FIXME : build the oss plugin here, because
+# it won't build as a seperate module
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${S}
+ # ppc asm included in the resample plugin seems to be broken,
+ # using a slower but working version for now
+ #
+ # ppc team : patch needs to be redone, also if this is _really_
+ # a problem it should be sent upstream (why have ppc specific code
+ # if it doesn't work)
+ # <foser@gentoo.org>
+# epatch ${FILESDIR}/noppcasm.patch
+
+}
+
+src_compile() {
+
+ elibtoolize
+
+ # gst doesnt handle optimisations well
+ strip-flags
+ replace-flags "-O3" "-O2"
+ filter-flags "-fprefetch-loop-arrays" # see bug 22249
+ if use alpha || use amd64 || use ia64 || use hppa; then
+ append-flags -fPIC
+ fi
+
+ gst-plugins_src_configure
+
+ emake || die
+
+}
+
+src_install() {
+
+ gnome2_src_install
+ gst-plugins_remove_unversioned_binaries
+
+}
+
+DOCS="AUTHORS COPYING INSTALL README RELEASE TODO"
+
+pkg_postinst () {
+
+ gnome2_pkg_postinst
+ gst-plugins_pkg_postinst
+
+ echo ""
+ einfo "The Gstreamer plugins setup has changed quite a bit on Gentoo,"
+ einfo "applications now should provide you with the basic plugins."
+ echo ""
+ einfo "Right now this package installs at least an OSS output plugin to have"
+ einfo "a standard sound output plugin, but this might change in the future."
+ echo ""
+ einfo "The new seperate plugins are all named 'gst-plugins-<plugin>'."
+ einfo "To get a listing of currently available plugins do 'emerge -s gst-plugins-'."
+ einfo "In most cases it shouldn't be needed though to emerge extra plugins."
+
+}
+
+pkg_postrm() {
+
+ gnome2_pkg_postrm
+ gst-plugins_pkg_postrm
+
+}