summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2003-03-23 22:05:42 +0000
committerArcady Genkin <agenkin@gentoo.org>2003-03-23 22:05:42 +0000
commit80e8915691fbae7e81ffc8eca10cc3a7e5cc008f (patch)
tree3d3d7dcafbb25cc65c5566e27c27d0337bc5a109 /media-libs
parentadded ~ppc to waimea (diff)
downloadgentoo-2-80e8915691fbae7e81ffc8eca10cc3a7e5cc008f.tar.gz
gentoo-2-80e8915691fbae7e81ffc8eca10cc3a7e5cc008f.tar.bz2
gentoo-2-80e8915691fbae7e81ffc8eca10cc3a7e5cc008f.zip
Version bump to 1-beta9.
Fixed einstall bug in 0.9.13-r3 (bug #16841).
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/xine-lib/ChangeLog12
-rw-r--r--media-libs/xine-lib/files/digest-xine-lib-0.9.13-r31
-rw-r--r--media-libs/xine-lib/files/digest-xine-lib-1_beta91
-rw-r--r--media-libs/xine-lib/xine-lib-0.9.13-r3.ebuild136
-rw-r--r--media-libs/xine-lib/xine-lib-1_beta9.ebuild120
5 files changed, 269 insertions, 1 deletions
diff --git a/media-libs/xine-lib/ChangeLog b/media-libs/xine-lib/ChangeLog
index 50fbe48664bc..27a18e5610cb 100644
--- a/media-libs/xine-lib/ChangeLog
+++ b/media-libs/xine-lib/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for media-libs/xine-lib
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/ChangeLog,v 1.46 2003/03/08 20:46:19 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/ChangeLog,v 1.47 2003/03/23 22:05:42 agenkin Exp $
+
+*xine-lib-1_beta9 (23 Mar 2003)
+
+ 23 Mar 2003; Arcady Genkin <agenkin@gentoo.org> :
+ Version bump.
+
+*xine-lib-0.9.13-r3 (23 Mar 2003)
+
+ 23 Mar 2003; Arcady Genkin <agenkin@gentoo.org> :
+ Fixed installation problem for portage >=2.0.47 (bug #16841).
*xine-lib-1_beta8 (08 Mar 2003)
diff --git a/media-libs/xine-lib/files/digest-xine-lib-0.9.13-r3 b/media-libs/xine-lib/files/digest-xine-lib-0.9.13-r3
new file mode 100644
index 000000000000..8f38da8ba0ba
--- /dev/null
+++ b/media-libs/xine-lib/files/digest-xine-lib-0.9.13-r3
@@ -0,0 +1 @@
+MD5 2e37c40bb78732187e3375a220405063 xine-lib-0.9.13.tar.gz 2751090
diff --git a/media-libs/xine-lib/files/digest-xine-lib-1_beta9 b/media-libs/xine-lib/files/digest-xine-lib-1_beta9
new file mode 100644
index 000000000000..5b0e9d246553
--- /dev/null
+++ b/media-libs/xine-lib/files/digest-xine-lib-1_beta9
@@ -0,0 +1 @@
+MD5 bd921a5098443fe4f138a41fb79caf9c xine-lib-1-beta9.tar.gz 3756004
diff --git a/media-libs/xine-lib/xine-lib-0.9.13-r3.ebuild b/media-libs/xine-lib/xine-lib-0.9.13-r3.ebuild
new file mode 100644
index 000000000000..daa9f96aa074
--- /dev/null
+++ b/media-libs/xine-lib/xine-lib-0.9.13-r3.ebuild
@@ -0,0 +1,136 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-0.9.13-r3.ebuild,v 1.1 2003/03/23 22:05:42 agenkin Exp $
+
+IUSE="arts esd avi nls dvd aalib X directfb oggvorbis alsa"
+
+inherit libtool || die "I lost my inheritance"
+
+# this build doesn't play nice with -maltivec (gcc 3.2 only option) on ppc
+inherit flag-o-matic || die "I lost my inheritance"
+filter-flags "-maltivec -mabi=altivec"
+replace-flags k6-3 i686
+replace-flags k6-2 i686
+replace-flags k6 i686
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Xine is a free gpl-licensed video player for unix-like systems"
+HOMEPAGE="http://xine.sourceforge.net/"
+SRC_URI="mirror://sourceforge/xine/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc sparc "
+
+DEPEND="oggvorbis? ( media-libs/libvorbis )
+ X? ( virtual/x11 )
+ avi? ( >=media-libs/win32codecs-0.50
+ media-libs/divx4linux )
+ esd? ( media-sound/esound )
+ dvd? ( >=media-libs/libdvdcss-0.0.3.3
+ >=media-libs/libdvdread-0.9.2 )
+ arts? ( kde-base/arts )
+ alsa? ( media-libs/alsa-lib )
+ aalib? ( media-libs/aalib )
+ directfb? ( >=dev-libs/DirectFB-0.9.9
+ dev-util/pkgconfig )"
+
+RDEPEND="${DEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+
+ patch -p1 < ${FILESDIR}/xine-lib-configure.patch || \
+ die "configure patch failed"
+
+ # allows kxine to work; see bug #5412
+ patch -p1 < ${FILESDIR}/${P}-kxine.patch || \
+ die "patching for kxine support failed"
+
+ if [ `use directfb` ]; then
+ patch -p0 < ${FILESDIR}/xineconfig.patch-${PV} || \
+ die "dfb patch 1 failed"
+# patch -p2 < ${FILESDIR}/${PF}-directfb.patch || \
+# die "dfb patch 2 failed"
+ else
+ patch -p1 < ${FILESDIR}/${PN}-disable-directfb.patch || \
+ die "no dfb patch failed"
+ fi
+}
+
+src_compile() {
+
+ elibtoolize
+
+ # Most of these are not working currently, but are here for completeness
+ # don't use the --disable-XXXtest because that defaults to ON not OFF
+ local myconf
+ use X \
+ || myconf="${myconf} --disable-x11 --disable-xv"
+ use esd \
+ || myconf="${myconf} --disable-esd"
+ # --disable-esdtest"
+ use nls \
+ || myconf="${myconf} --disable-nls"
+ use alsa \
+ || myconf="${myconf} --disable-alsa"
+ # --disable-alsatest"
+ use arts \
+ || myconf="${myconf} --disable-arts"
+ # --disable-artstest"
+
+ # This breaks because with the test disabled, it defaults to
+ # "found" check with the next release until then let it autodetect.
+ # See bug #2377.
+ use aalib || myconf="${myconf} --disable-aalib"
+ # --disable-aalibtest"
+
+ # Configure script is broken, even if you pass the flags below it
+ # still assumes ogg is installed and tries to compile it, giving you
+ # bug #5244. But leaving ogg for autodetection works.
+ use oggvorbis \
+ || myconf="${myconf} --disable-ogg --disable-vorbis"
+# --disable-oggtest \
+# --disable-vorbistest"
+
+ use avi \
+ && myconf="${myconf} --with-w32-path=/usr/lib/win32" \
+ || myconf="${myconf} --disable-asf"
+
+ einfo "myconf: ${myconf}"
+
+ econf ${myconf} || die
+
+ elibtoolize
+
+ emake || die
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+
+ # Xine's makefiles install some file incorrectly. (Bug #8583).
+ dodir /usr/share/xine/fonts
+ mv ${D}/usr/share/*.xinefont.gz ${D}/usr/share/xine/fonts/
+ dodir /usr/share/xine/skins
+ mv ${D}/usr/share/xine_logo.mpv ${D}/usr/share/xine/skins/
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL README TODO
+ cd ${S}/doc
+ dodoc dataflow.dia README*
+
+}
+
+pkg_postinst() {
+
+ einfo
+ einfo "Please note, a new version of xine-lib has been installed,"
+ einfo "for library consistency you need to unmerge old versions"
+ einfo "of xine-lib before merging xine-ui."
+ einfo
+
+}
diff --git a/media-libs/xine-lib/xine-lib-1_beta9.ebuild b/media-libs/xine-lib/xine-lib-1_beta9.ebuild
new file mode 100644
index 000000000000..8b26a926cee9
--- /dev/null
+++ b/media-libs/xine-lib/xine-lib-1_beta9.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-1_beta9.ebuild,v 1.1 2003/03/23 22:05:42 agenkin Exp $
+
+DESCRIPTION="Core libraries for Xine movie player."
+HOMEPAGE="http://xine.sourceforge.net/"
+LICENSE="GPL-2"
+
+DEPEND="oggvorbis? ( media-libs/libvorbis )
+ X? ( virtual/x11 )
+ avi? ( >=media-libs/win32codecs-0.50
+ media-libs/divx4linux )
+ esd? ( media-sound/esound )
+ dvd? ( >=media-libs/libdvdcss-0.0.3.3
+ >=media-libs/libdvdread-0.9.2 )
+ arts? ( kde-base/arts )
+ alsa? ( media-libs/alsa-lib )
+ aalib? ( media-libs/aalib )
+ directfb? ( >=dev-libs/DirectFB-0.9.9
+ dev-util/pkgconfig )
+ >=media-libs/flac-1.0.4
+ >=media-libs/libsdl-1.1.5
+ >=media-libs/libfame-0.9.0
+ >=media-libs/xvid-0.9.0"
+
+RDEPEND="${DEPEND}
+ nls? ( sys-devel/gettext )"
+
+IUSE="arts esd avi nls dvd aalib X directfb oggvorbis alsa"
+
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+
+S=${WORKDIR}/${PN}-${PV/_/-}
+SRC_URI="mirror://sourceforge/xine/${PN}-${PV/_/-}.tar.gz"
+
+# this build doesn't play nice with -maltivec (gcc 3.2 only option) on ppc
+inherit flag-o-matic || die "I lost my inheritance"
+filter-flags "-maltivec -mabi=altivec"
+replace-flags k6-3 i686
+replace-flags k6-2 i686
+replace-flags k6 i686
+
+
+src_compile() {
+
+ # Make sure that the older libraries are not installed (bug #15081).
+ if [ -f /usr/lib/libxine.so.0 ]
+ then
+ einfo "Please uninstall older xine libraries.";
+ einfo "The compilation cannot procede.";
+ die
+ fi
+
+ # Use the built-in dvdnav plugin.
+ local myconf="--with-included-dvdnav"
+
+ # Most of these are not working currently, but are here for completeness
+ # don't use the --disable-XXXtest because that defaults to ON not OFF
+ use X \
+ || myconf="${myconf} --disable-x11" # --disable-xv"
+ use esd \
+ || myconf="${myconf} --disable-esd" # --disable-esdtest"
+ use nls \
+ || myconf="${myconf} --disable-nls"
+ use alsa \
+ || myconf="${myconf} --disable-alsa" # --disable-alsatest"
+ use arts \
+ || myconf="${myconf} --disable-arts" # --disable-artstest"
+ use aalib \
+ || myconf="${myconf} --disable-aalib" # --disable-aalibtest"
+ use oggvorbis \
+ || myconf="${myconf} --disable-ogg --disable-vorbis"
+ #--disable-oggtest --disable-vorbistest"
+ use avi \
+ && myconf="${myconf} --with-w32-path=/usr/lib/win32" \
+ || myconf="${myconf} --disable-asf"
+
+ einfo "myconf: ${myconf}"
+
+ # Very specific optimization is set by configure
+ # Should fix problems like the one found on bug #11779
+ # raker@gentoo.org (25 Dec 2002)
+ unset CFLAGS
+ unset CXXFLAGS
+
+ econf ${myconf} || die
+ make || die
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+
+ # Xine's makefiles install some file incorrectly. (Gentoo bug #8583, #16112).
+ dodir /usr/share/xine/libxine1/fonts
+ mv ${D}/usr/share/*.xinefont.gz ${D}/usr/share/xine/libxine1/fonts/
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL README TODO
+ cd ${S}/doc
+ dodoc dataflow.dia README*
+
+}
+
+pkg_postinst() {
+
+ einfo
+ einfo "Please note, a new version of xine-lib has been installed,"
+ einfo "for library consistency you need to unmerge old versions"
+ einfo "of xine-lib before merging xine-ui."
+ einfo
+ einfo "This library version 1 is incompatible with the plugins,"
+ einfo "designed for the prior library versions (such as xine-d4d,"
+ einfo "xine-d5d, xine-dmd, and xind-dvdnav."
+ einfo
+ einfo "Also make sure to remove your ~/.xine if upgrading from"
+ einfo "a previous version."
+ einfo
+
+}