summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Crête <tester@gentoo.org>2009-04-28 15:11:54 +0000
committerOlivier Crête <tester@gentoo.org>2009-04-28 15:11:54 +0000
commit96a95c49d5236b5ba0f1c7c05e472ec2231dd4c3 (patch)
tree642b547134e9471a96d1f25908a69145ecb32135 /media-libs
parentunmasking mediastreamer as ortp-0.15.0 is unmasked (diff)
downloadgentoo-2-96a95c49d5236b5ba0f1c7c05e472ec2231dd4c3.tar.gz
gentoo-2-96a95c49d5236b5ba0f1c7c05e472ec2231dd4c3.tar.bz2
gentoo-2-96a95c49d5236b5ba0f1c7c05e472ec2231dd4c3.zip
Re-make hal optional, bug #267759
(Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libgpod/ChangeLog8
-rw-r--r--media-libs/libgpod/files/libgpod-0.5.2-no-gdk.patch26
-rw-r--r--media-libs/libgpod/files/libgpod-0.7.2-compile-without-hal.patch18
-rw-r--r--media-libs/libgpod/libgpod-0.5.2.ebuild57
-rw-r--r--media-libs/libgpod/libgpod-0.7.2.ebuild15
5 files changed, 35 insertions, 89 deletions
diff --git a/media-libs/libgpod/ChangeLog b/media-libs/libgpod/ChangeLog
index 6d64469ee56f..ffdef7e2ab4d 100644
--- a/media-libs/libgpod/ChangeLog
+++ b/media-libs/libgpod/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/libgpod
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libgpod/ChangeLog,v 1.59 2009/04/26 16:12:14 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libgpod/ChangeLog,v 1.60 2009/04/28 15:11:54 tester Exp $
+
+ 28 Apr 2009; Olivier Crête <tester@gentoo.org>
+ -files/libgpod-0.5.2-no-gdk.patch,
+ +files/libgpod-0.7.2-compile-without-hal.patch, -libgpod-0.5.2.ebuild,
+ libgpod-0.7.2.ebuild:
+ Re-make hal optional, bug #267759
26 Apr 2009; Olivier Crête <tester@gentoo.org> libgpod-0.7.2.ebuild:
Add undocumented build-time dep on xsltproc
diff --git a/media-libs/libgpod/files/libgpod-0.5.2-no-gdk.patch b/media-libs/libgpod/files/libgpod-0.5.2-no-gdk.patch
deleted file mode 100644
index 32bc4938bd1f..000000000000
--- a/media-libs/libgpod/files/libgpod-0.5.2-no-gdk.patch
+++ /dev/null
@@ -1,26 +0,0 @@
---- itdb_artwork.c~ 2007-05-07 07:42:09.000000000 -0400
-+++ itdb_artwork.c 2007-06-28 10:41:02.000000000 -0400
-@@ -849,9 +849,11 @@
- g_return_if_fail (thumb);
-
- g_free (thumb->image_data);
-+#ifdef HAVE_GDKPIXBUF
- if (thumb->pixbuf) {
- g_object_unref (G_OBJECT (thumb->pixbuf));
- }
-+#endif
- g_free (thumb->filename);
- g_free (thumb);
- }
-@@ -883,9 +885,11 @@
- memcpy (new_thumb->image_data, thumb->image_data,
- new_thumb->image_data_len);
- }
-+#ifdef HAVE_GDKPIXBUF
- if (thumb->pixbuf) {
- g_object_ref (G_OBJECT (thumb->pixbuf));
- }
-+#endif
- return new_thumb;
- }
-
diff --git a/media-libs/libgpod/files/libgpod-0.7.2-compile-without-hal.patch b/media-libs/libgpod/files/libgpod-0.7.2-compile-without-hal.patch
new file mode 100644
index 000000000000..3a98023aad32
--- /dev/null
+++ b/media-libs/libgpod/files/libgpod-0.7.2-compile-without-hal.patch
@@ -0,0 +1,18 @@
+--- libgpod-0.7.2-orig/tools/Makefile.am 2009-04-15 23:18:36.000000000 +0200
++++ libgpod-0.7.2/tools/Makefile.am 2009-04-28 12:35:43.000000000 +0200
+@@ -1,7 +1,6 @@
+ if HAVE_SGUTILS
+
+ bin_PROGRAMS=ipod-read-sysinfo-extended
+-noinst_PROGRAMS=ipod-time-sync
+
+ ipod_read_sysinfo_extended_SOURCES = \
+ read-sysinfoextended-sgutils.c \
+@@ -12,6 +11,7 @@
+ if HAVE_HAL
+ haldir = $(HALCALLOUTSDIR)
+ hal_PROGRAMS = libgpod-callout
++noinst_PROGRAMS=ipod-time-sync
+
+ libgpod_callout_SOURCES = \
+ hal-callout.c \
diff --git a/media-libs/libgpod/libgpod-0.5.2.ebuild b/media-libs/libgpod/libgpod-0.5.2.ebuild
deleted file mode 100644
index d5615ccb6722..000000000000
--- a/media-libs/libgpod/libgpod-0.5.2.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libgpod/libgpod-0.5.2.ebuild,v 1.9 2008/01/08 15:18:16 armin76 Exp $
-
-inherit eutils
-
-DESCRIPTION="Shared library to access the contents of an iPod"
-HOMEPAGE="http://www.gtkpod.org/libgpod.html"
-SRC_URI="mirror://sourceforge/gtkpod/${P}.tar.gz"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~ia64 ppc ppc64 sparc x86"
-IUSE="gtk python doc"
-
-RDEPEND=">=dev-libs/glib-2.4
- gtk? ( >=x11-libs/gtk+-2 )
- python? ( >=dev-lang/python-2.3
- >=dev-lang/swig-1.3.24
- >=x11-libs/gtk+-2
- media-libs/mutagen )"
-DEPEND="${RDEPEND}
- doc? ( dev-util/gtk-doc )
- dev-util/pkgconfig"
-
-# The tests dont passe
-RESTRICT="test"
-
-src_unpack() {
- unpack ${A}
-
- cd "${S}"/src
- epatch "${FILESDIR}"/${P}-no-gdk.patch
-}
-
-src_compile() {
-
- local myconf
-
- if use gtk || use python; then
- myconf="--enable-gdk-pixbuf"
- else
- myconf="--disable-gdk-pixbuf"
- fi
-
- econf ${myconf} \
- $(use_enable doc gtk-doc) \
- $(use_with python) || die "configure failed"
-
- emake || die "make failed"
-
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "install failed"
- dodoc README TROUBLESHOOTING AUTHORS
-}
diff --git a/media-libs/libgpod/libgpod-0.7.2.ebuild b/media-libs/libgpod/libgpod-0.7.2.ebuild
index 96a81e8e978c..0021df98f361 100644
--- a/media-libs/libgpod/libgpod-0.7.2.ebuild
+++ b/media-libs/libgpod/libgpod-0.7.2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libgpod/libgpod-0.7.2.ebuild,v 1.2 2009/04/26 16:12:14 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libgpod/libgpod-0.7.2.ebuild,v 1.3 2009/04/28 15:11:54 tester Exp $
EAPI=2
-inherit eutils
+inherit autotools eutils
DESCRIPTION="Shared library to access the contents of an iPod"
HOMEPAGE="http://www.gtkpod.org/libgpod.html"
@@ -13,12 +13,12 @@ SRC_URI="mirror://sourceforge/gtkpod/${P}.tar.gz"
LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="+gtk python test"
+IUSE="+gtk python test hal"
RDEPEND=">=dev-libs/glib-2.16
sys-apps/sg3_utils
dev-libs/libxml2
- =sys-apps/hal-0.5*
+ hal? ( =sys-apps/hal-0.5* )
gtk? ( >=x11-libs/gtk+-2.6 )
python? ( >=dev-lang/python-2.3
>=media-libs/mutagen-1.8
@@ -29,9 +29,14 @@ DEPEND="${RDEPEND}
dev-util/pkgconfig
dev-libs/libxslt"
+src_prepare() {
+ epatch "${FILESDIR}/${P}-compile-without-hal.patch"
+ eautoreconf
+}
+
src_configure() {
econf \
- --with-hal \
+ $(use_with hal) \
$(use_enable gtk gdk-pixbuf) \
$(use_enable python pygobject) \
$(use_with python) || die "configure failed"