summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-05 17:19:14 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-05 17:19:14 +0000
commitc10bdb4a9fec3d0928f542efe64b2abe898ecacd (patch)
tree190a0d451f07280252d59115b8a34e6f9919848d /media-libs
parentalpha/ia64/sparc stable wrt #346403 (diff)
downloadgentoo-2-c10bdb4a9fec3d0928f542efe64b2abe898ecacd.tar.gz
gentoo-2-c10bdb4a9fec3d0928f542efe64b2abe898ecacd.tar.bz2
gentoo-2-c10bdb4a9fec3d0928f542efe64b2abe898ecacd.zip
Fix building with Python 3.
(Portage version: 2.2.0_alpha6_p21/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/mesa/ChangeLog6
-rw-r--r--media-libs/mesa/mesa-7.9.ebuild8
2 files changed, 11 insertions, 3 deletions
diff --git a/media-libs/mesa/ChangeLog b/media-libs/mesa/ChangeLog
index 2d2d40c71e8e..beeb5ad7e031 100644
--- a/media-libs/mesa/ChangeLog
+++ b/media-libs/mesa/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/mesa
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/ChangeLog,v 1.296 2010/11/29 18:23:36 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/ChangeLog,v 1.297 2010/12/05 17:19:14 arfrever Exp $
+
+ 05 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ mesa-7.9.ebuild:
+ Fix building with Python 3.
29 Nov 2010; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
mesa-7.9.ebuild:
diff --git a/media-libs/mesa/mesa-7.9.ebuild b/media-libs/mesa/mesa-7.9.ebuild
index ef0557b1bdd9..20b7f0711b55 100644
--- a/media-libs/mesa/mesa-7.9.ebuild
+++ b/media-libs/mesa/mesa-7.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-7.9.ebuild,v 1.2 2010/11/29 18:23:36 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-7.9.ebuild,v 1.3 2010/12/05 17:19:14 arfrever Exp $
EAPI=3
@@ -11,7 +11,7 @@ if [[ ${PV} = 9999* ]]; then
EXPERIMENTAL="true"
fi
-inherit base autotools multilib flag-o-matic toolchain-funcs ${GIT_ECLASS}
+inherit base autotools multilib flag-o-matic python toolchain-funcs ${GIT_ECLASS}
OPENGL_DIR="xorg-x11"
@@ -89,6 +89,7 @@ for card in ${RADEON_CARDS}; do
done
DEPEND="${RDEPEND}
+ =dev-lang/python-2*
dev-util/pkgconfig
x11-misc/makedepend
>=x11-proto/dri2proto-2.2
@@ -116,6 +117,9 @@ pkg_setup() {
# recommended by upstream
append-flags -ffast-math
+
+ python_set_active_version 2
+ python_pkg_setup
}
src_unpack() {