summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2009-09-19 04:10:34 +0000
committerSteve Arnold <nerdboy@gentoo.org>2009-09-19 04:10:34 +0000
commitdacfdb9ca7d955302a4a8f1edadc50de73ffac46 (patch)
tree67420bf1a512667e75f8858169aaaee5677c9c99 /media-libs
parentRestrict tests as they are unstable see #282439. (diff)
downloadgentoo-2-dacfdb9ca7d955302a4a8f1edadc50de73ffac46.tar.gz
gentoo-2-dacfdb9ca7d955302a4a8f1edadc50de73ffac46.tar.bz2
gentoo-2-dacfdb9ca7d955302a4a8f1edadc50de73ffac46.zip
Updated to current stable (required for gdal). Closes bug 285285.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/tiff/ChangeLog8
-rw-r--r--media-libs/tiff/tiff-3.9.1.ebuild52
2 files changed, 59 insertions, 1 deletions
diff --git a/media-libs/tiff/ChangeLog b/media-libs/tiff/ChangeLog
index f455f0907273..41f57320b4e6 100644
--- a/media-libs/tiff/ChangeLog
+++ b/media-libs/tiff/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/tiff
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/tiff/ChangeLog,v 1.131 2009/07/27 22:00:17 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/tiff/ChangeLog,v 1.132 2009/09/19 04:10:34 nerdboy Exp $
+
+*tiff-3.9.1 (19 Sep 2009)
+
+ 19 Sep 2009; Steve Arnold <nerdboy@gentoo.org> +tiff-3.9.1.ebuild:
+ Updated to current upstream stable stable (required for gdal). Closes
+ bug 285285. Also fixes bug in gdal rendering (see bug #285310).
27 Jul 2009; Markus Meier <maekke@gentoo.org> tiff-3.8.2-r8.ebuild:
amd64 stable, bug #276988
diff --git a/media-libs/tiff/tiff-3.9.1.ebuild b/media-libs/tiff/tiff-3.9.1.ebuild
new file mode 100644
index 000000000000..99e28507df13
--- /dev/null
+++ b/media-libs/tiff/tiff-3.9.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/tiff/tiff-3.9.1.ebuild,v 1.1 2009/09/19 04:10:34 nerdboy Exp $
+
+EAPI=2
+
+inherit eutils libtool
+
+DESCRIPTION="Library for manipulation of TIFF (Tag Image File Format) images"
+HOMEPAGE="http://www.remotesensing.org/libtiff/"
+SRC_URI="ftp://ftp.remotesensing.org/pub/libtiff/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="jpeg jbig nocxx zlib"
+
+RDEPEND="jpeg? ( >=media-libs/jpeg-6b )
+ jbig? ( >=media-libs/jbigkit-1.6-r1 )
+ zlib? ( >=sys-libs/zlib-1.1.3-r2 )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.8.2-CVE-2009-2285.patch
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ $(use_enable !nocxx cxx) \
+ $(use_enable zlib) \
+ $(use_enable jpeg) \
+ $(use_enable jbig) \
+ --with-pic --without-x \
+ --with-docdir=/usr/share/doc/${PF}
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "make install failed"
+ dodoc README TODO VERSION
+}
+
+pkg_postinst() {
+ if use jbig; then
+ echo
+ elog "JBIG support is intended for Hylafax fax compression, so we"
+ elog "really need more feedback in other areas (most testing has"
+ elog "been done with fax). Be sure to recompile anything linked"
+ elog "against tiff if you rebuild it with jbig support."
+ echo
+ fi
+}