summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-03-22 01:49:50 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-03-22 01:49:50 +0000
commit70f5922f5f67c31edce9f07ad2d19bb1d7a1ddb3 (patch)
tree2289c6b3a5d01606838a21c94f4ae4e082b3c9da /media-plugins/live
parentRename the variable on all ebuilds, since it could never have worked before a... (diff)
downloadgentoo-2-70f5922f5f67c31edce9f07ad2d19bb1d7a1ddb3.tar.gz
gentoo-2-70f5922f5f67c31edce9f07ad2d19bb1d7a1ddb3.tar.bz2
gentoo-2-70f5922f5f67c31edce9f07ad2d19bb1d7a1ddb3.zip
remove latest version: it breaks api, abi hasnt been bumped, and mplayer fails to build, bug #409043, we will readd a newer version when things will be saner
(Portage version: 2.2.0_alpha93/cvs/Linux x86_64)
Diffstat (limited to 'media-plugins/live')
-rw-r--r--media-plugins/live/ChangeLog7
-rw-r--r--media-plugins/live/live-2012.02.29.ebuild112
2 files changed, 6 insertions, 113 deletions
diff --git a/media-plugins/live/ChangeLog b/media-plugins/live/ChangeLog
index b730f366a3fa..251617544ecf 100644
--- a/media-plugins/live/ChangeLog
+++ b/media-plugins/live/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-plugins/live
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/live/ChangeLog,v 1.144 2012/03/21 12:01:58 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/live/ChangeLog,v 1.145 2012/03/22 01:49:50 aballier Exp $
+
+ 22 Mar 2012; Alexis Ballier <aballier@gentoo.org> -live-2012.02.29.ebuild:
+ remove latest version: it breaks api, abi hasnt been bumped, and mplayer
+ fails to build, bug #409043, we will readd a newer version when things will
+ be saner
21 Mar 2012; Agostino Sarubbo <ago@gentoo.org> live-2012.01.07.ebuild:
Stable for amd64, wrt bug #408983
diff --git a/media-plugins/live/live-2012.02.29.ebuild b/media-plugins/live/live-2012.02.29.ebuild
deleted file mode 100644
index 95dd35196c0c..000000000000
--- a/media-plugins/live/live-2012.02.29.ebuild
+++ /dev/null
@@ -1,112 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/live/live-2012.02.29.ebuild,v 1.1 2012/03/20 10:05:44 aballier Exp $
-
-EAPI=3
-inherit flag-o-matic eutils toolchain-funcs multilib
-
-DESCRIPTION="Source-code libraries for standards-based RTP/RTCP/RTSP multimedia streaming, suitable for embedded and/or low-cost streaming applications"
-HOMEPAGE="http://www.live555.com/"
-SRC_URI="http://www.live555.com/liveMedia/public/${P/-/.}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-IUSE=""
-
-S="${WORKDIR}"
-
-# Alexis Ballier <aballier@gentoo.org>
-# Be careful, bump this everytime you bump the package and the ABI has changed.
-# If you don't know, ask someone.
-LIVE_ABI_VERSION=4
-
-src_prepare() {
- cd "${WORKDIR}"
- epatch "${FILESDIR}/${PN}-recursive.patch"
-
- cp -pPR live live-shared
- mv live live-static
-
- cp "${FILESDIR}/config.gentoo" live-static
- cp "${FILESDIR}/config.gentoo-so-r1" live-shared
-
- case ${CHOST} in
- *-solaris*)
- sed -i \
- -e '/^COMPILE_OPTS /s/$/ -DSOLARIS/' \
- -e '/^LIBS_FOR_CONSOLE_APPLICATION /s/$/ -lsocket -lnsl/' \
- live-static/config.gentoo \
- live-shared/config.gentoo-so-r1 \
- || die
- ;;
- *-darwin*)
- sed -i \
- -e '/^COMPILE_OPTS /s/$/ -DBSD=1 -DHAVE_SOCKADDR_LEN=1/' \
- -e '/^LINK /s/$/ /' \
- -e '/^LIBRARY_LINK /s/$/ /' \
- -e '/^LIBRARY_LINK_OPTS /s/-Bstatic//' \
- live-static/config.gentoo \
- || die static
- sed -i \
- -e '/^COMPILE_OPTS /s/$/ -DBSD=1 -DHAVE_SOCKADDR_LEN=1/' \
- -e '/^LINK /s/$/ /' \
- -e '/^LIBRARY_LINK /s/=.*$/= $(CXX) -o /' \
- -e '/^LIBRARY_LINK_OPTS /s:-shared.*$:-undefined suppress -flat_namespace -dynamiclib -install_name '"${EPREFIX}/usr/$(get_libdir)/"'$@:' \
- live-shared/config.gentoo-so-r1 \
- || die shared
- ;;
- esac
-}
-
-src_configure() { :; }
-
-src_compile() {
- tc-export CC CXX LD
-
- cd "${WORKDIR}/live-static"
-
- einfo "Beginning static library build"
- ./genMakefiles gentoo
- emake -j1 LINK_OPTS="-L. $(raw-ldflags)" || die "failed to build static libraries"
-
- einfo "Beginning programs build"
- cd "${WORKDIR}/live-static/testProgs"
- emake LINK_OPTS="-L. ${LDFLAGS}" || die "failed to build test programs"
- cd "${WORKDIR}/live-static/mediaServer"
- emake LINK_OPTS="-L. ${LDFLAGS}" || die "failed to build the mediaserver"
-
- cd "${WORKDIR}/live-shared"
- einfo "Beginning shared library build"
- ./genMakefiles gentoo-so-r1
- local suffix=$(get_libname ${LIVE_ABI_VERSION})
- emake -j1 LINK_OPTS="-L. ${LDFLAGS}" LIB_SUFFIX="${suffix#.}" || die "failed to build shared libraries"
-}
-
-src_install() {
- for library in UsageEnvironment liveMedia BasicUsageEnvironment groupsock; do
- dolib.a live-static/${library}/lib${library}.a
- dolib.so live-shared/${library}/lib${library}$(get_libname ${LIVE_ABI_VERSION})
- dosym lib${library}$(get_libname ${LIVE_ABI_VERSION}) /usr/$(get_libdir)/lib${library}$(get_libname)
-
- insinto /usr/include/${library}
- doins live-shared/${library}/include/*h
- done
-
- # Should we really install these?
- find live-static/testProgs -type f -perm +111 -print0 | \
- xargs -0 dobin
-
- #install included live555MediaServer aplication
- dobin live-static/mediaServer/live555MediaServer
-
- # install docs
- dodoc live-static/README
-}
-
-pkg_postinst() {
- ewarn "If you are upgrading from a version prior to live-2008.02.08"
- ewarn "Please make sure to rebuild applications built against ${PN}"
- ewarn "like vlc or mplayer. ${PN} may have had ABI changes and ${PN}"
- ewarn "support might be broken."
-}