summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-11-19 20:50:10 +0000
committerMichał Górny <mgorny@gentoo.org>2012-11-19 20:50:10 +0000
commit0797256ee5ba506cb6aa8bc4224d0a766c9fc179 (patch)
tree3804e2618385db02e486ed9014c7ed257361ddd7 /media-plugins/mediastreamer-x264
parentversion bump wrt #405555 (diff)
downloadgentoo-2-0797256ee5ba506cb6aa8bc4224d0a766c9fc179.tar.gz
gentoo-2-0797256ee5ba506cb6aa8bc4224d0a766c9fc179.tar.bz2
gentoo-2-0797256ee5ba506cb6aa8bc4224d0a766c9fc179.zip
Version bump wrt bug #416201. Thanks to Andrew Savchenko for his effort on linphone ebuilds.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'media-plugins/mediastreamer-x264')
-rw-r--r--media-plugins/mediastreamer-x264/ChangeLog10
-rw-r--r--media-plugins/mediastreamer-x264/mediastreamer-x264-1.4.2.ebuild29
2 files changed, 37 insertions, 2 deletions
diff --git a/media-plugins/mediastreamer-x264/ChangeLog b/media-plugins/mediastreamer-x264/ChangeLog
index 3133532e5f68..06b318f1618f 100644
--- a/media-plugins/mediastreamer-x264/ChangeLog
+++ b/media-plugins/mediastreamer-x264/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-plugins/mediastreamer-x264
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mediastreamer-x264/ChangeLog,v 1.19 2012/05/16 12:18:30 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mediastreamer-x264/ChangeLog,v 1.20 2012/11/19 20:50:10 mgorny Exp $
+
+*mediastreamer-x264-1.4.2 (19 Nov 2012)
+
+ 19 Nov 2012; Michał Górny <mgorny@gentoo.org>
+ +mediastreamer-x264-1.4.2.ebuild:
+ Version bump wrt bug #416201. Thanks to Andrew Savchenko for his effort on
+ linphone ebuilds.
16 May 2012; Tomáš Chvátal <scarabeus@gentoo.org>
-mediastreamer-x264-1.1.7.ebuild, -mediastreamer-x264-1.3.3.ebuild,
@@ -80,4 +87,3 @@
28 Apr 2009; Mounir Lamouri <volkmar@gentoo.org> +metadata.xml,
+mediastreamer-x264-1.1.7.ebuild:
Initial commit
-
diff --git a/media-plugins/mediastreamer-x264/mediastreamer-x264-1.4.2.ebuild b/media-plugins/mediastreamer-x264/mediastreamer-x264-1.4.2.ebuild
new file mode 100644
index 000000000000..328b8701c53c
--- /dev/null
+++ b/media-plugins/mediastreamer-x264/mediastreamer-x264-1.4.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mediastreamer-x264/mediastreamer-x264-1.4.2.ebuild,v 1.1 2012/11/19 20:50:10 mgorny Exp $
+
+EAPI="4"
+
+MY_P="msx264-${PV}"
+
+DESCRIPTION="mediastreamer plugin: add H264 support"
+HOMEPAGE="http://www.linphone.org/"
+SRC_URI="mirror://nongnu/linphone/plugins/sources/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND=">=media-libs/mediastreamer-2.7.0[video]
+ >=media-libs/x264-0.0.20100118
+ virtual/ffmpeg"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ # strict: don't want -Werror
+ econf \
+ --disable-strict
+}